aboutsummaryrefslogtreecommitdiff
path: root/games/amphetamine
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-07 16:44:01 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-07 16:44:01 +0000
commitc64d835b37268a9b1ac07766f3778c2ff45d270f (patch)
treea6b5974ff91bcf31598dce64d13b797846cca17e /games/amphetamine
parentfa77fb4d8800c7a541f6746ee834872087cdd8c4 (diff)
downloadports-c64d835b37268a9b1ac07766f3778c2ff45d270f.tar.gz
ports-c64d835b37268a9b1ac07766f3778c2ff45d270f.zip
- Fix build on non-i386 arch
PR: ports/63875 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=103210
Diffstat (limited to 'games/amphetamine')
-rw-r--r--games/amphetamine/Makefile8
-rw-r--r--games/amphetamine/files/patch-ab6
2 files changed, 4 insertions, 10 deletions
diff --git a/games/amphetamine/Makefile b/games/amphetamine/Makefile
index c08c9cfa6d62..76411bf975cd 100644
--- a/games/amphetamine/Makefile
+++ b/games/amphetamine/Makefile
@@ -24,14 +24,8 @@ USE_GMAKE= yes
DATAVERSION= 0.8.6
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} != "i386" && ${ARCH} != "alpha"
-BROKEN= "Does not compile on !i386 and !alpha"
-.endif
-
post-install:
@cd ${WRKDIR}/amph && ${FIND} . | \
${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/share/amph
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/amphetamine/files/patch-ab b/games/amphetamine/files/patch-ab
index 94fa208ff509..fe93a29098cc 100644
--- a/games/amphetamine/files/patch-ab
+++ b/games/amphetamine/files/patch-ab
@@ -1,7 +1,7 @@
--- src/Main.cpp.orig Sun Mar 24 17:49:09 2002
+++ src/Main.cpp Mon Mar 1 19:51:09 2004
@@ -1,3 +1,7 @@
-+#if defined(__FreeBSD__) && ( defined(__i386__) || defined(__amd64__) )
++#if defined(__FreeBSD__) && defined(__i386__)
+#include <floatingpoint.h>
+#endif
+
@@ -12,7 +12,7 @@
my_argv = argv;
if (checkCommandLine()) return 0;
-+#if defined(__FreeBSD__) && ( defined(__i386__) || defined(__amd64__) )
++#if defined(__FreeBSD__) && defined(__i386__)
+ fpsetmask(fpgetmask() & ~(FP_X_DZ|FP_X_INV));
+#endif
gApplication = new CApplication();
@@ -22,7 +22,7 @@
gApplication->Quit();
delete gApplication;
-+#if defined(__FreeBSD__) && ( defined(__i386__) || defined(__amd64__) )
++#if defined(__FreeBSD__) && defined(__i386__)
+ fpresetsticky(FP_X_DZ|FP_X_INV);
+ fpsetmask(FP_X_DZ|FP_X_INV);
+#endif