aboutsummaryrefslogtreecommitdiff
path: root/games/annelid
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-04-24 21:01:09 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-04-24 21:01:09 +0000
commit22a7dd427c2a6a149f58808435365cdca610f569 (patch)
tree39e16063bfd195abc0ce933081ec2e4bd71819a5 /games/annelid
parent8f251079f1435cf0d470fccef1db71f5d78b9a90 (diff)
downloadports-22a7dd427c2a6a149f58808435365cdca610f569.tar.gz
ports-22a7dd427c2a6a149f58808435365cdca610f569.zip
- Remove USE_REINPLACE.
- Remove '@' from installation commands. - Format tabs and put targets at the end. - Fix OPTIONS handling. - Bump PORTREVISION. Approved by: garga (mentor)
Notes
Notes: svn path=/head/; revision=160378
Diffstat (limited to 'games/annelid')
-rw-r--r--games/annelid/Makefile45
1 files changed, 22 insertions, 23 deletions
diff --git a/games/annelid/Makefile b/games/annelid/Makefile
index 61e9ade46812..236756026951 100644
--- a/games/annelid/Makefile
+++ b/games/annelid/Makefile
@@ -7,6 +7,7 @@
PORTNAME= annelid
PORTVERSION= 1
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://www.garthgillespie.com/annelid/ \
${MASTER_SITE_LOCAL}
@@ -23,8 +24,6 @@ USE_ZIP= yes
USE_GMAKE= yes
USE_SDL= sdl
USE_GL= yes
-USE_REINPLACE= yes
-
NO_WRKSUBDIR= yes
OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on
@@ -36,35 +35,35 @@ DATAFILES= annelid.dat apple.tga apple.wav backd.tga backn.tga font.dat \
score.wav segment.tga shrink.wav slow.wav speed.wav title.tga \
vortex.wav
-do-install:
-# Script
- @${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-sh ${PREFIX}/bin/${PORTNAME}
-
-# Program
- @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/libexec
-
-# Data
- @${MKDIR} ${DATADIR}
-.for f in ${DATAFILES}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
-.endfor
-
.include <bsd.port.pre.mk>
post-patch:
-# Fix Makefile
+# Fix Makefile.
@${REINPLACE_CMD} -e 's|%%CFLAGS%%|${CFLAGS}| ; \
- s|%%X11BASE%%|${X11BASE}| ; \
- s|sdl-config|${SDL_CONFIG}|' \
- ${WRKSRC}/${MAKEFILE}
+ s|%%X11BASE%%|${X11BASE}| ; \
+ s|sdl-config|${SDL_CONFIG}|' \
+ ${WRKSRC}/${MAKEFILE}
-# Fix SDL include statement
+# Fix SDL include statement.
@${REINPLACE_CMD} -e 's|\(#include.*\)SDL/\(SDL.*\)|\1\2|' \
- ${WRKSRC}/*.cpp ${WRKSRC}/*.h
+ ${WRKSRC}/*.cpp ${WRKSRC}/*.h
-# Enable/disable compilation optimizations
-.if !defined(WITH_OPTIMIZED_CFLAGS)
+# Enable/disable compilation optimizations.
+.if defined(WITHOUT_OPTIMIZED_CFLAGS)
@${REINPLACE_CMD} -e 's|$$(OPT)||' ${WRKSRC}/${MAKEFILE}
.endif
+do-install:
+# Script.
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}-sh ${PREFIX}/bin/${PORTNAME}
+
+# Program.
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/libexec
+
+# Data.
+ ${MKDIR} ${DATADIR}
+.for f in ${DATAFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DATADIR}
+.endfor
+
.include <bsd.port.post.mk>