aboutsummaryrefslogtreecommitdiff
path: root/games/atomix
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-08-28 07:58:46 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-08-28 07:58:46 +0000
commit9e389814c321a23b61eb0beb65d8994791245073 (patch)
treee4b5577665085822f82a42a2e9fc9db21b323f1f /games/atomix
parentb6214e24cd945896703bff4d21515de1ea931816 (diff)
downloadports-9e389814c321a23b61eb0beb65d8994791245073.tar.gz
ports-9e389814c321a23b61eb0beb65d8994791245073.zip
Update to 1.2.2a.
Notes
Notes: svn path=/head/; revision=141033
Diffstat (limited to 'games/atomix')
-rw-r--r--games/atomix/Makefile17
-rw-r--r--games/atomix/distinfo4
-rw-r--r--games/atomix/files/patch-src::Makefile.in12
-rw-r--r--games/atomix/files/patch-src::goal-view.c10
-rw-r--r--games/atomix/files/patch-src::level-convert.c10
-rw-r--r--games/atomix/pkg-install13
-rw-r--r--games/atomix/pkg-plist47
7 files changed, 52 insertions, 61 deletions
diff --git a/games/atomix/Makefile b/games/atomix/Makefile
index 6c87420d1148..aaba98726cb6 100644
--- a/games/atomix/Makefile
+++ b/games/atomix/Makefile
@@ -3,24 +3,27 @@
# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports-stable/games/atomix/Makefile,v 1.2 2005/08/04 04:03:32 marcus Exp $
#
PORTNAME= atomix
-PORTVERSION= 1.0
-PORTREVISION= 4
+PORTVERSION= 1.2.2a
CATEGORIES= games gnome
-MASTER_SITES= http://jens.triq.net/download/
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
+DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A yet another little mind game
-USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack intlhack libgnome libgnomeui libgnomecanvas libxml2
+USE_GMAKE= yes
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
-USE_REINPLACE= yes
+ LDFLAGS="-L${LOCALBASE}/lib"
post-patch:
@${REINPLACE_CMD} -e 's/games\.games/games:games/' ${WRKSRC}/Makefile.in
diff --git a/games/atomix/distinfo b/games/atomix/distinfo
index 99055b7295e6..84effc86cddb 100644
--- a/games/atomix/distinfo
+++ b/games/atomix/distinfo
@@ -1,2 +1,2 @@
-MD5 (atomix-1.0.tar.gz) = 9c2c63ab1a3ea4c7b0246e1629aa9f4e
-SIZE (atomix-1.0.tar.gz) = 310060
+MD5 (gnome2/atomix-1.2.2a.tar.bz2) = e5ef6717b3ed10a8501a0db0815f99d9
+SIZE (gnome2/atomix-1.2.2a.tar.bz2) = 294459
diff --git a/games/atomix/files/patch-src::Makefile.in b/games/atomix/files/patch-src::Makefile.in
deleted file mode 100644
index c642375f9a39..000000000000
--- a/games/atomix/files/patch-src::Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/Makefile.in.orig Thu Dec 11 10:54:14 2003
-+++ src/Makefile.in Thu Dec 11 10:55:37 2003
-@@ -447,7 +447,8 @@
- mostlyclean distclean maintainer-clean
-
-
--@INTLTOOL_XML_RULE@
-+%.xml: %.xml.in
-+ @cp $< $@
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/games/atomix/files/patch-src::goal-view.c b/games/atomix/files/patch-src::goal-view.c
deleted file mode 100644
index e0d887ac24b1..000000000000
--- a/games/atomix/files/patch-src::goal-view.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/goal-view.c.orig Fri Aug 13 19:03:11 2004
-+++ src/goal-view.c Fri Aug 13 19:03:42 2004
-@@ -96,6 +96,7 @@
- case TILE_TYPE_WALL:
- case TILE_TYPE_UNKNOWN:
- default:
-+ ;
- }
- g_object_unref (tile);
- }
diff --git a/games/atomix/files/patch-src::level-convert.c b/games/atomix/files/patch-src::level-convert.c
deleted file mode 100644
index 1ae7ad48f9b0..000000000000
--- a/games/atomix/files/patch-src::level-convert.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/level-convert.c.orig Fri Aug 13 19:04:13 2004
-+++ src/level-convert.c Fri Aug 13 19:04:40 2004
-@@ -579,6 +579,7 @@
- case TILE_TYPE_FLOOR:
- type_str = "TILE_TYPE_FLOOR"; break;
- default:
-+ ;
- }
-
- if (type_str == NULL) return;
diff --git a/games/atomix/pkg-install b/games/atomix/pkg-install
new file mode 100644
index 000000000000..e4e48b646a60
--- /dev/null
+++ b/games/atomix/pkg-install
@@ -0,0 +1,13 @@
+#!/bin/sh
+
+if [ "$2" = "POST-INSTALL" ]; then
+ mkdir -p ${PKG_PREFIX}/share/gnome/games
+ SCORES="atomix.scores"
+ for i in ${SCORES}; do
+ if [ ! -f ${PKG_PREFIX}/share/gnome/games/${i} ]; then
+ touch -f ${PKG_PREFIX}/share/gnome/games/${i}
+ chown games:games ${PKG_PREFIX}/share/gnome/games/${i}
+ chmod 0664 ${PKG_PREFIX}/share/gnome/games/${i}
+ fi
+ done
+fi
diff --git a/games/atomix/pkg-plist b/games/atomix/pkg-plist
index 915b0bc176c3..3bbb22947f09 100644
--- a/games/atomix/pkg-plist
+++ b/games/atomix/pkg-plist
@@ -1,26 +1,26 @@
bin/atomix
share/gnome/applications/atomix.desktop
share/gnome/atomix/atomix-logo.png
-share/gnome/atomix/level/aceticacid.atomix
-share/gnome/atomix/level/acetone.atomix
-share/gnome/atomix/level/buthanol.atomix
-share/gnome/atomix/level/cyclo-buthane.atomix
-share/gnome/atomix/level/dimethylether.atomix
-share/gnome/atomix/level/ethan.atomix
-share/gnome/atomix/level/ethanal.atomix
-share/gnome/atomix/level/ethanol.atomix
-share/gnome/atomix/level/ethylene.atomix
-share/gnome/atomix/level/formaldehyd.atomix
-share/gnome/atomix/level/glycerin.atomix
-share/gnome/atomix/level/lactic-acid.atomix
-share/gnome/atomix/level/methane.atomix
-share/gnome/atomix/level/methanol.atomix
-share/gnome/atomix/level/propanal.atomix
-share/gnome/atomix/level/propylen.atomix
-share/gnome/atomix/level/pyran.atomix
+share/gnome/atomix/level/aceticacid.atomix.xml
+share/gnome/atomix/level/acetone.atomix.xml
+share/gnome/atomix/level/buthanol.atomix.xml
+share/gnome/atomix/level/cyclo-buthane.atomix.xml
+share/gnome/atomix/level/dimethylether.atomix.xml
+share/gnome/atomix/level/ethan.atomix.xml
+share/gnome/atomix/level/ethanal.atomix.xml
+share/gnome/atomix/level/ethanol.atomix.xml
+share/gnome/atomix/level/ethylene.atomix.xml
+share/gnome/atomix/level/glycerin.atomix.xml
+share/gnome/atomix/level/lactic-acid.atomix.xml
+share/gnome/atomix/level/methanal.atomix.xml
+share/gnome/atomix/level/methane.atomix.xml
+share/gnome/atomix/level/methanol.atomix.xml
+share/gnome/atomix/level/propanal.atomix.xml
+share/gnome/atomix/level/propylen.atomix.xml
+share/gnome/atomix/level/pyran.atomix.xml
share/gnome/atomix/level/sequence
-share/gnome/atomix/level/transbutylen.atomix
-share/gnome/atomix/level/water.atomix
+share/gnome/atomix/level/transbutylen.atomix.xml
+share/gnome/atomix/level/water.atomix.xml
share/gnome/atomix/themes/default/arrow-bottom.png
share/gnome/atomix/themes/default/arrow-left.png
share/gnome/atomix/themes/default/arrow-right.png
@@ -66,24 +66,31 @@ share/gnome/atomix/themes/default/wall-vertical-leftx.png
share/gnome/atomix/themes/default/wall-vertical-rightx.png
share/gnome/atomix/themes/default/wall-vertical-top-end.png
share/gnome/atomix/themes/default/wall-vertical.png
-share/gnome/games/atomix.scores
+@unexec [ -s %D/share/gnome/games/atomix.scores ] || rm -f %D/share/gnome/games/atomix.scores
share/gnome/gnome-2.0/ui/atomix-ui.xml
+share/gnome/pixmaps/atomix-icon.png
share/locale/am/LC_MESSAGES/atomix.mo
share/locale/az/LC_MESSAGES/atomix.mo
share/locale/be/LC_MESSAGES/atomix.mo
+share/locale/bg/LC_MESSAGES/atomix.mo
share/locale/ca/LC_MESSAGES/atomix.mo
share/locale/cs/LC_MESSAGES/atomix.mo
share/locale/da/LC_MESSAGES/atomix.mo
share/locale/de/LC_MESSAGES/atomix.mo
share/locale/el/LC_MESSAGES/atomix.mo
+share/locale/en_CA/LC_MESSAGES/atomix.mo
+share/locale/en_GB/LC_MESSAGES/atomix.mo
share/locale/es/LC_MESSAGES/atomix.mo
share/locale/et/LC_MESSAGES/atomix.mo
share/locale/fa/LC_MESSAGES/atomix.mo
share/locale/fr/LC_MESSAGES/atomix.mo
+share/locale/ga/LC_MESSAGES/atomix.mo
share/locale/gl/LC_MESSAGES/atomix.mo
+share/locale/gu/LC_MESSAGES/atomix.mo
share/locale/he/LC_MESSAGES/atomix.mo
share/locale/hi/LC_MESSAGES/atomix.mo
share/locale/hu/LC_MESSAGES/atomix.mo
+share/locale/is/LC_MESSAGES/atomix.mo
share/locale/it/LC_MESSAGES/atomix.mo
share/locale/ja/LC_MESSAGES/atomix.mo
share/locale/kn/LC_MESSAGES/atomix.mo