aboutsummaryrefslogtreecommitdiff
path: root/games/bastet
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-10-21 18:57:58 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-10-21 18:57:58 +0000
commitf3b0d98ca7344c949daf698ed1198eecb7412ce3 (patch)
treeae2504883dc28f9f0fd94673d733aaa85c9e5b81 /games/bastet
parentd7e7582683f9ba02c17eaab6a76e20ccea436111 (diff)
downloadports-f3b0d98ca7344c949daf698ed1198eecb7412ce3.tar.gz
ports-f3b0d98ca7344c949daf698ed1198eecb7412ce3.zip
Add bastet, an ncurses Tetris clone which is harder than every other Tetris.
Bastet stands for "bastard tetris" and uses a special algorithm designed to choose the worst brick possible.
Notes
Notes: svn path=/head/; revision=119915
Diffstat (limited to 'games/bastet')
-rw-r--r--games/bastet/Makefile20
-rw-r--r--games/bastet/distinfo2
-rw-r--r--games/bastet/files/patch-Makefile21
-rw-r--r--games/bastet/files/patch-bast.c11
-rw-r--r--games/bastet/pkg-descr13
-rw-r--r--games/bastet/pkg-plist3
6 files changed, 70 insertions, 0 deletions
diff --git a/games/bastet/Makefile b/games/bastet/Makefile
new file mode 100644
index 000000000000..c3de0ee62f27
--- /dev/null
+++ b/games/bastet/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: bastet
+# Date created: 21 Oct 2004
+# Whom: Michael Nottebrock <lofi@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bastet
+PORTVERSION= 0.41
+CATEGORIES= games
+MASTER_SITES= http://fph.altervista.org/prog/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= An ncurses Tetris clone which is harder than every other Tetris
+
+USE_GMAKE= yes
+MAKE_ENV= DATADIR=${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/games/bastet/distinfo b/games/bastet/distinfo
new file mode 100644
index 000000000000..069979c0d668
--- /dev/null
+++ b/games/bastet/distinfo
@@ -0,0 +1,2 @@
+MD5 (bastet-0.41.tgz) = 48379dc98916ba083e9be5544f552a06
+SIZE (bastet-0.41.tgz) = 24195
diff --git a/games/bastet/files/patch-Makefile b/games/bastet/files/patch-Makefile
new file mode 100644
index 000000000000..0fd6be981b0d
--- /dev/null
+++ b/games/bastet/files/patch-Makefile
@@ -0,0 +1,21 @@
+--- Makefile.orig Tue Oct 19 19:54:58 2004
++++ Makefile Thu Oct 21 20:43:02 2004
+@@ -1,8 +1,8 @@
+ #makefile for bastet (c) 2004 Federico Poloni
+
+ #default paths
+-BIN_PREFIX=/usr/bin/
+-DATA_PREFIX=/var/games/
++BIN_PREFIX=$(PREFIX)/bin/
++DATA_PREFIX=$(PREFIX)/share/bastet/
+ HISCORE=bastet.scores
+
+ #in order to handle highscores properly, bastet must be setuid.
+@@ -41,6 +41,7 @@
+ cp $(EXNAME) $(BIN_PREFIX)
+ chown $(GAME_USER) $(BIN_PREFIX)$(EXNAME)
+ chmod u+s $(BIN_PREFIX)$(EXNAME)
++ mkdir -p $(DATA_PREFIX)
+ touch $(DATA_PREFIX)$(HISCORE)
+ chown $(GAME_USER) $(DATA_PREFIX)$(HISCORE)
+ chmod 644 $(DATA_PREFIX)$(HISCORE)
diff --git a/games/bastet/files/patch-bast.c b/games/bastet/files/patch-bast.c
new file mode 100644
index 000000000000..8d392fd4acaa
--- /dev/null
+++ b/games/bastet/files/patch-bast.c
@@ -0,0 +1,11 @@
+--- bast.c.orig Thu Oct 21 20:32:29 2004
++++ bast.c Thu Oct 21 20:32:39 2004
+@@ -1,7 +1,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <ncurses.h>
+-#include <termio.h>
++#include <termios.h>
+ #include <assert.h>
+ #include <unistd.h>
+ #include <string.h>
diff --git a/games/bastet/pkg-descr b/games/bastet/pkg-descr
new file mode 100644
index 000000000000..799946d49051
--- /dev/null
+++ b/games/bastet/pkg-descr
@@ -0,0 +1,13 @@
+Have you ever thought Tetris(R) was evil because it wouldn't send
+you that straight "I" brick you needed in order to clear four rows
+at the same time?
+
+Well Tetris(R) probably isn't evil, but Bastet
+certainly is. Bastet stands for "bastard tetris", and is a
+simple ncurses-based Tetris(R) clone for Linux. Unlike normal
+Tetris(R), however, Bastet does not choose your next brick at random.
+Instead, Bastet uses a special algorithm designed to choose the
+worst brick possible.
+
+As you can imagine, playing Bastet can be a
+very frustrating experience!
diff --git a/games/bastet/pkg-plist b/games/bastet/pkg-plist
new file mode 100644
index 000000000000..9009caf8143f
--- /dev/null
+++ b/games/bastet/pkg-plist
@@ -0,0 +1,3 @@
+bin/bastet
+%%DATADIR%%/bastet.scores
+@dirrm %%DATADIR%%