aboutsummaryrefslogtreecommitdiff
path: root/games/battletanks
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-04-10 22:03:33 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-04-10 22:03:33 +0000
commita081958af0d2de1740200effae7363107b7d073e (patch)
treecbfb2eda9e19b0c289b6aebe504e3d0e55ce9039 /games/battletanks
parentc1f235092712d844da3d39bf8046d029d0ab26d7 (diff)
downloadports-a081958af0d2de1740200effae7363107b7d073e.tar.gz
ports-a081958af0d2de1740200effae7363107b7d073e.zip
- Add missing dependency and fix the build
Pointy hat to: danfe
Notes
Notes: svn path=/head/; revision=211023
Diffstat (limited to 'games/battletanks')
-rw-r--r--games/battletanks/Makefile3
-rw-r--r--games/battletanks/files/patch-sdlx-SConscript10
2 files changed, 12 insertions, 1 deletions
diff --git a/games/battletanks/Makefile b/games/battletanks/Makefile
index 71f4b6b97752..880e0d4f4f6c 100644
--- a/games/battletanks/Makefile
+++ b/games/battletanks/Makefile
@@ -15,7 +15,8 @@ COMMENT= Fast 2D tank arcade game with multiplayer and split-screen modes
LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
openal.0:${PORTSDIR}/audio/openal \
- expat.6:${PORTSDIR}/textproc/expat2
+ expat.6:${PORTSDIR}/textproc/expat2 \
+ vorbisfile.5:${PORTSDIR}/audio/libvorbis
USE_BZIP2= yes
USE_LDCONFIG= yes
diff --git a/games/battletanks/files/patch-sdlx-SConscript b/games/battletanks/files/patch-sdlx-SConscript
new file mode 100644
index 000000000000..4619d7d791ce
--- /dev/null
+++ b/games/battletanks/files/patch-sdlx-SConscript
@@ -0,0 +1,10 @@
+--- sdlx/SConscript.orig 2007-11-16 08:26:16.000000000 +0100
++++ sdlx/SConscript 2008-04-10 23:54:03.000000000 +0200
+@@ -14,7 +14,6 @@
+ #c_map_env.Append(CXXFLAGS=['-fforce-addr', '-fprefetch-loop-arrays'])
+ c_map = c_map_env.SharedObject('c_map.cpp')
+ #libs.append('GL')
+- libs.append('rt')
+ libs.append('X11')
+ env.Append(LINKFLAGS=' -Wl,-rpath-link build/' + env['mode'] + '/mrt')
+ else: