aboutsummaryrefslogtreecommitdiff
path: root/games/bloodfrontier
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-03-15 11:51:06 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-03-15 11:51:06 +0000
commit19e2b6a6eb2412c2bc6e9c1203711234275f0e80 (patch)
treee55e1765d3f2fc582db249816aec9fba6ea0e0c2 /games/bloodfrontier
parent8d774333123e9a4edbcd7a92b253ffce0d6828a0 (diff)
downloadports-19e2b6a6eb2412c2bc6e9c1203711234275f0e80.tar.gz
ports-19e2b6a6eb2412c2bc6e9c1203711234275f0e80.zip
Improve style, consistency and fix minor issues in Cube-based ports
- Convert to option helpers - Drop unused libGLU dependency (except for games/cube) - Track direct dependency on libX11 (for XFetchBytes) - Drop redundant MKDIR before COPYTREE_* macros [1] - Wrap cd related commands with parentheses [1] - Wrap lines exceeding 80 characters - Bump PORTREVISION to pick up changes in dependencies, plist (assaultcube) and catch regressions early [1] - games/assaultcube: CLIENT uses openal/vorbisfile *instead* of SDL_mixer - games/assaultcube: drop unused gettext-tools dependency [1] - games/assaultcube: convert to PLIST_DIRS [1] - games/assaultcube: add patch for source/src/bot/bot_waypoint.cpp file to fix "invalid source encoding" warning [1] - games/{cube,bloodfrontier}: MASTER or SERVER don't need libX11 - games/redeclipse: tell how large the package is in IGNORE message - games/redeclipse: use PORTDATA to hold list of dirs for COPYTREE_SHARE Differential Revision: https://reviews.freebsd.org/D1831 PR: 197582 [1] PR: 197583 [2] Submitted by: lightside@gmx.com [1] Requested by: lightside@gmx.com [1] Reviewed by: amdmi3, lightside@gmx.com (maintainers) Approved by: maintainer timeout (1 month) [2] Approved by: bapt (mentor)
Notes
Notes: svn path=/head/; revision=381324
Diffstat (limited to 'games/bloodfrontier')
-rw-r--r--games/bloodfrontier/Makefile44
1 files changed, 19 insertions, 25 deletions
diff --git a/games/bloodfrontier/Makefile b/games/bloodfrontier/Makefile
index 955ffb86e863..306f3336c62f 100644
--- a/games/bloodfrontier/Makefile
+++ b/games/bloodfrontier/Makefile
@@ -3,7 +3,7 @@
PORTNAME= bloodfrontier
DISTVERSION= B2
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Blood%20Frontier%20Beta%202
DISTNAME= ${PORTNAME}-${DISTVERSION}-linux
@@ -18,11 +18,10 @@ GNU_CONFIGURE= yes
CONFIGURE_WRKSRC= ${WRKSRC}/src/enet
BUILD_WRKSRC= ${WRKSRC}/src
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_XORG= x11
-ALL_TARGET= libenet ${BINARIES}
+ALL_TARGET= libenet
-SUB_FILES= bfclient bfserver
+SUB_FILES= ${PLIST_FILES:Mbin/*:T}
PORTDATA= *
@@ -32,7 +31,15 @@ OPTIONS_MULTI_COMPONENTS=CLIENT DEDICATED
OPTIONS_DEFAULT= CLIENT DEDICATED OPTIMIZED_CFLAGS
CLIENT_DESC= Build client
+CLIENT_USE= GL=gl SDL=image,mixer,sdl XORG=x11
+CLIENT_ALL_TARGET= client
+CLIENT_PLIST_FILES= bin/bfclient libexec/bfclient \
+ share/pixmaps/${PORTNAME}.ico
DEDICATED_DESC= Build dedicated server
+DEDICATED_PLIST_FILES= bin/bfserver libexec/bfserver
+DEDICATED_ALL_TARGET= server
+OPTIMIZED_CFLAGS_CFLAGS= -O3 -fomit-frame-pointer
+OPTIMIZED_CFLAGS_CXXFLAGS= -O3 -fomit-frame-pointer
.include <bsd.port.options.mk>
@@ -41,11 +48,6 @@ BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
.if ${PORT_OPTIONS:MCLIENT}
-USE_GL= yes
-USE_SDL= image mixer sdl
-PLIST_FILES+= bin/bfclient libexec/bfclient share/pixmaps/${PORTNAME}.ico
-BINARIES+= client
-
DESKTOP_ENTRIES="Blood Frontier" \
"${COMMENT}" \
"${PREFIX}/share/pixmaps/${PORTNAME}.ico" \
@@ -54,25 +56,17 @@ DESKTOP_ENTRIES="Blood Frontier" \
""
.endif
-.if ${PORT_OPTIONS:MDEDICATED}
-PLIST_FILES+= bin/bfserver libexec/bfserver
-BINARIES+= server
-.endif
-
-.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
-CFLAGS+= -O3 -fomit-frame-pointer
-CXXFLAGS+= -O3 -fomit-frame-pointer
-.endif
-
do-install:
-.for f in ${BINARIES}
- ${INSTALL_SCRIPT} ${WRKDIR}/bf${f} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/bf${f} ${STAGEDIR}${PREFIX}/libexec
+.for f in ${PLIST_FILES:Mbin/*}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${f:T} ${STAGEDIR}${PREFIX}/${f}
+.endfor
+.for f in ${PLIST_FILES:Mlibexec/*}
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${f:T} ${STAGEDIR}${PREFIX}/${f:H}
.endfor
.if ${PORT_OPTIONS:MCLIENT}
- ${INSTALL_DATA} ${WRKSRC}/src/${PORTNAME}.ico ${STAGEDIR}${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/src/${PORTNAME}.ico \
+ ${STAGEDIR}${PREFIX}/share/pixmaps
.endif
- ${MKDIR} ${STAGEDIR}${DATADIR}
- cd ${WRKSRC}/data && ${COPYTREE_SHARE} "." ${STAGEDIR}${DATADIR}/
+ (cd ${WRKSRC}/data && ${COPYTREE_SHARE} "." ${STAGEDIR}${DATADIR})
.include <bsd.port.mk>