aboutsummaryrefslogtreecommitdiff
path: root/games/bsdtris/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-02 13:02:40 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-02 13:02:40 +0000
commitc19f42a07d5307c1c67e88402b66f578a1d7632f (patch)
tree86f0768c4e856c06264bd9921d6ccb0ca24984ed /games/bsdtris/Makefile
parent3dcce89b74b95a8023462ccc4a717f5fd683ba4e (diff)
downloadports-c19f42a07d5307c1c67e88402b66f578a1d7632f.tar.gz
ports-c19f42a07d5307c1c67e88402b66f578a1d7632f.zip
games/tetris -> games/bsdtris
PR: ports/50535
Notes
Notes: svn path=/head/; revision=77987
Diffstat (limited to 'games/bsdtris/Makefile')
-rw-r--r--games/bsdtris/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/games/bsdtris/Makefile b/games/bsdtris/Makefile
new file mode 100644
index 000000000000..af385039f70c
--- /dev/null
+++ b/games/bsdtris/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: bsdtris
+# Date created: 01 Apr 2003
+# Whom: Yonatan <Yonatan@xpert.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bsdtris
+PORTVERSION= 1
+CATEGORIES= games
+MASTER_SITES= http://www.mavetju.org/download/adopted/
+DISTNAME= ${PORTNAME}-01042003
+
+MAINTAINER= yonatan@xpert.com
+COMMENT= BSD version of Text-based tetris game
+
+NO_WRKSUBDIR= yes
+USE_REINPLACE= yes
+
+MAN6= bsdtris.6
+
+post-patch:
+ ${REINPLACE_CMD} -E "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/pathnames.h
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/tetris.6 ${PREFIX}/man/man6/bsdtris.6
+
+.include <bsd.port.mk>