aboutsummaryrefslogtreecommitdiff
path: root/games/bubble-chains
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-05-07 15:20:30 +0000
committerChris Rees <crees@FreeBSD.org>2012-05-07 15:20:30 +0000
commit625cd9889f1b5bf29bd4b3eec309c20207cf440d (patch)
treeefa919acd81f3360462a041ce0cf1e1fa0d5a3fd /games/bubble-chains
parent5cf03bbdc47df604675d73caec628e53b3c9698f (diff)
downloadports-625cd9889f1b5bf29bd4b3eec309c20207cf440d.tar.gz
ports-625cd9889f1b5bf29bd4b3eec309c20207cf440d.zip
The aim of Bubble Chains is to remove all of the targets on each level,
and to do this before the time (indicated with the blue-colored bar at the right) runs out. Keep doing this until you have passed the last level and won the game. WWW: http://bubble-chains.sintegrial.com/ PR: ports/167234 Submitted by: nemysis@gmx.ch
Notes
Notes: svn path=/head/; revision=296138
Diffstat (limited to 'games/bubble-chains')
-rw-r--r--games/bubble-chains/Makefile75
-rw-r--r--games/bubble-chains/distinfo2
-rw-r--r--games/bubble-chains/pkg-descr6
-rw-r--r--games/bubble-chains/pkg-plist4
4 files changed, 87 insertions, 0 deletions
diff --git a/games/bubble-chains/Makefile b/games/bubble-chains/Makefile
new file mode 100644
index 000000000000..c77865ca9cf3
--- /dev/null
+++ b/games/bubble-chains/Makefile
@@ -0,0 +1,75 @@
+# New ports collection makefile for: bubble-chains
+# Date created: 21 April 2012
+# Whom: nemysis@gmx.ch
+#
+# $FreeBSD$
+#
+
+PORTNAME= chains
+PORTVERSION= 0.1.1
+CATEGORIES= games
+MASTER_SITES= http://bubble-chains.sintegrial.com/files/
+PKGNAMEPREFIX= bubble-
+EXTRACT_SUFX= -src.7z
+
+MAINTAINER= nemysis@gmx.ch
+COMMENT= The aim is to remove all of the targets on each level
+
+LICENSE= GPLv2
+
+EXTRACT_DEPENDS= 7z:${PORTSDIR}/archivers/p7zip
+BUILD_DEPENDS= 7z:${PORTSDIR}/archivers/p7zip
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src
+
+USE_SDL= sdl image mixer
+USE_GL= glut glew glu
+USE_XORG= xrandr
+USE_QT_VER= 4
+QT_COMPONENTS= moc_build qmake_build rcc_build uic_build iconengines imageformats \
+ corelib svg xml opengl network
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ENV+= UIC="${UIC}" QMAKE="${QMAKE}" QMAKESPEC="${QMAKESPEC}"
+MAKE_ENV+= QMAKESPEC="${QMAKESPEC}"
+
+PORTDATA= *
+PORTDOCS= README
+
+P7ZIP_CMD= ${LOCALBASE}/bin/7z
+P7ZIP_ARGS= x -o${WRKDIR}
+
+MAKE_JOBS_SAFE= yes
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${P7ZIP_CMD} ${P7ZIP_ARGS} ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local/games/chains|${DATADIR}|' \
+ ${WRKSRC}/main.cpp ${WRKSRC}/Game.pro
+
+do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
+ ${QMAKE} ${QMAKEFLAGS} PREFIX=${PREFIX} ${WRKSRC}/Game.pro
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/images/logo.png \
+ ${PREFIX}/share/pixmaps/bubble-chains.png
+ ${INSTALL_DATA} ${WRKSRC}/icon.ico \
+ ${PREFIX}/share/pixmaps/bubble-chains.ico
+.if !defined (NOPORTDATA)
+ ${MKDIR} ${DATADIR}
+. for d in data
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${DATADIR})
+. endfor
+.endif
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/bubble-chains/distinfo b/games/bubble-chains/distinfo
new file mode 100644
index 000000000000..6f860b296590
--- /dev/null
+++ b/games/bubble-chains/distinfo
@@ -0,0 +1,2 @@
+SHA256 (chains-0.1.1-src.7z) = c1c487c51e8cba1640a49497debe5962f692e17df1272994c5dfaee9d6eb304f
+SIZE (chains-0.1.1-src.7z) = 3282431
diff --git a/games/bubble-chains/pkg-descr b/games/bubble-chains/pkg-descr
new file mode 100644
index 000000000000..ca91ccfc51e5
--- /dev/null
+++ b/games/bubble-chains/pkg-descr
@@ -0,0 +1,6 @@
+The aim of Bubble Chains is to remove all of the targets on each level,
+and to do this before the time
+(indicated with the blue-colored bar at the right) runs out.
+Keep doing this until you have passed the last level and won the game.
+
+WWW: http://bubble-chains.sintegrial.com/
diff --git a/games/bubble-chains/pkg-plist b/games/bubble-chains/pkg-plist
new file mode 100644
index 000000000000..4f981612e5d3
--- /dev/null
+++ b/games/bubble-chains/pkg-plist
@@ -0,0 +1,4 @@
+bin/chains
+share/pixmaps/bubble-chains.ico
+share/pixmaps/bubble-chains.png
+@dirrm share/applications