aboutsummaryrefslogtreecommitdiff
path: root/games/capicity
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-01-11 13:32:35 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-01-11 13:32:35 +0000
commit6205570d643c4bc5c181cefe65004acea8147de6 (patch)
tree9685bce47449efc8831ddffd1925f2513fa3f25e /games/capicity
parent6aae51b6c6bed4f950fa25b15ef65f22046b90d2 (diff)
downloadports-6205570d643c4bc5c181cefe65004acea8147de6.tar.gz
ports-6205570d643c4bc5c181cefe65004acea8147de6.zip
- Change Desktop entry file
- Support STAGEDIR
Notes
Notes: svn path=/head/; revision=339425
Diffstat (limited to 'games/capicity')
-rw-r--r--games/capicity/Makefile25
1 files changed, 12 insertions, 13 deletions
diff --git a/games/capicity/Makefile b/games/capicity/Makefile
index 24f21b340f77..fece468948a7 100644
--- a/games/capicity/Makefile
+++ b/games/capicity/Makefile
@@ -31,8 +31,8 @@ PORTDOCS= README changelog
INSTALLS_ICONS= yes
ICON_SIZES= 16x16 22x22 24x24 32x32 48x48 64x64
-DESKTOP_ENTRIES="Capi City" "${COMMENT}" "${PORTNAME}" \
- "${PORTNAME}" "Game;BoardGame;" false
+DESKTOP_ENTRIES="Capi City" "" "${PORTNAME}" \
+ "${PORTNAME}" "Game;BoardGame;" ""
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
@@ -40,30 +40,29 @@ OPTIONS_SUB= yes
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext
-NO_STAGE= yes
.include <bsd.port.options.mk>
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/CapiCity ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/CapiCity \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.for d in games images
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${DATADIR})
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${d} ${STAGEDIR}${DATADIR})
.endfor
.if ${PORT_OPTIONS:MNLS}
- @(cd ${WRKSRC} && ${COPYTREE_SHARE} ts ${DATADIR})
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ts ${STAGEDIR}${DATADIR})
.endif
.for s in ${ICON_SIZES}
- @${MKDIR} ${PREFIX}/share/icons/hicolor/${s}/apps
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps
${INSTALL_DATA} ${WRKSRC}/icons/${s}.png \
- ${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
+ ${STAGEDIR}${PREFIX}/share/icons/hicolor/${s}/apps/${PORTNAME}.png
.endfor
- ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${PREFIX}/share/pixmaps/
+ ${LN} -sf ${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>