aboutsummaryrefslogtreecommitdiff
path: root/games/ceferino
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-28 20:01:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-28 20:01:20 +0000
commit10cb2031f933c79ed14b9cd556ccd60953797fb3 (patch)
tree2a81143032c8b4438400cd11f5b7d967519231c4 /games/ceferino
parent23bd19382bf8fe92cd0217f9c0d871a7a2366816 (diff)
downloadports-10cb2031f933c79ed14b9cd556ccd60953797fb3.tar.gz
ports-10cb2031f933c79ed14b9cd556ccd60953797fb3.zip
- Optionalize gettext support
PR: ports/92338 Submitted by: Jose Alonso Cardenas Marquez <acardenas@bsd.org.pe> (maintainer)
Notes
Notes: svn path=/head/; revision=154659
Diffstat (limited to 'games/ceferino')
-rw-r--r--games/ceferino/Makefile18
-rw-r--r--games/ceferino/pkg-plist6
2 files changed, 19 insertions, 5 deletions
diff --git a/games/ceferino/Makefile b/games/ceferino/Makefile
index 38975f03ff5d..7239c5bf2d6c 100644
--- a/games/ceferino/Makefile
+++ b/games/ceferino/Makefile
@@ -17,7 +17,6 @@ USE_X_PREFIX= yes
USE_SDL= sdl mixer image
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_REINPLACE= yes
CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD}
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -25,6 +24,19 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CEFEDIRS= ima musicas niveles sonidos
+OPTIONS= NLS "Native Language Support" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+FLAG_NLS= true
+.endif
+
post-extract:
@${FIND} -E ${WRKSRC}/src/ -type f -iregex ".*\.(cpp|h)" \
-print0 | ${XARGS} -0 ${REINPLACE_CMD} -e 's/<SDL/<SDL11/'
@@ -38,10 +50,12 @@ do-install:
${INSTALL_PROGRAM} ceferino ceferinoeditor ceferinosetup ${PREFIX}/bin && \
${FIND} ${CEFEDIRS} -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
${FIND} -E ${CEFEDIRS} -type f -iregex ".*\.(png|jpg|xm|map|wav)" -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
+.if defined(FLAG_NLS)
.for FILE in es ca fr
${MKDIR} ${PREFIX}/share/locale/${FILE}/LC_MESSAGES && \
${INSTALL_DATA} ${WRKSRC}/po/${FILE}.gmo ${PREFIX}/share/locale/${FILE}/LC_MESSAGES/${PORTNAME}.mo
.endfor
+.endif
post-install:
.if !defined(NOPORTDOCS)
@@ -50,4 +64,4 @@ post-install:
${INSTALL_DATA} AUTHORS ChangeLog README README_ES ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/ceferino/pkg-plist b/games/ceferino/pkg-plist
index 616a99c001ee..6ca0b0794fb2 100644
--- a/games/ceferino/pkg-plist
+++ b/games/ceferino/pkg-plist
@@ -5,9 +5,9 @@ bin/ceferinoeditor
%%DOCSDIR%%/ChangeLog
%%DOCSDIR%%/README
%%DOCSDIR%%/README_ES
-share/locale/ca/LC_MESSAGES/ceferino.mo
-share/locale/es/LC_MESSAGES/ceferino.mo
-share/locale/fr/LC_MESSAGES/ceferino.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/ceferino.mo
+%%NLS%%share/locale/es/LC_MESSAGES/ceferino.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/ceferino.mo
%%DATADIR%%/ima/barra.png
%%DATADIR%%/ima/cargando.png
%%DATADIR%%/ima/editor.png