aboutsummaryrefslogtreecommitdiff
path: root/games/chromium-bsu
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /games/chromium-bsu
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'games/chromium-bsu')
-rw-r--r--games/chromium-bsu/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/games/chromium-bsu/Makefile b/games/chromium-bsu/Makefile
index d67106bc9193..1b0dda417322 100644
--- a/games/chromium-bsu/Makefile
+++ b/games/chromium-bsu/Makefile
@@ -22,16 +22,16 @@ LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
openal.0:${PORTSDIR}/audio/openal \
alut.1:${PORTSDIR}/audio/freealut
-USE_GL= yes
+USE_GL= glu
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/Chromium-0.9
post-patch:
@${REINPLACE_CMD} -e 's|-lopenal|& -lalut|g' \
- -e 's|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/src/Makefile
- @${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/src-setup/Makefile
- @${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|g' ${WRKSRC}/support/glpng/src/Makefile
+ -e 's|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/src/Makefile
+ @${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/src-setup/Makefile
+ @${REINPLACE_CMD} -e 's|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/support/glpng/src/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/chromium ${PREFIX}/bin