aboutsummaryrefslogtreecommitdiff
path: root/games/columns
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2000-10-28 15:41:32 +0000
committerKevin Lo <kevlo@FreeBSD.org>2000-10-28 15:41:32 +0000
commit1d349d2977492c6054001f1e38db2fa01481d71f (patch)
treeaa7aac242afe269256fd7e1a8361ae42badcaf4c /games/columns
parentb768ef5d2498bc51852a1b76c1339e6bf0a560c4 (diff)
downloadports-1d349d2977492c6054001f1e38db2fa01481d71f.tar.gz
ports-1d349d2977492c6054001f1e38db2fa01481d71f.zip
Update to version 1.2b
PR: 22363 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=34362
Diffstat (limited to 'games/columns')
-rw-r--r--games/columns/Makefile16
-rw-r--r--games/columns/distinfo2
-rw-r--r--games/columns/files/patch-ab71
-rw-r--r--games/columns/files/patch-ac10
-rw-r--r--games/columns/pkg-descr4
-rw-r--r--games/columns/pkg-plist35
6 files changed, 45 insertions, 93 deletions
diff --git a/games/columns/Makefile b/games/columns/Makefile
index 03c476295024..71e9b060e23f 100644
--- a/games/columns/Makefile
+++ b/games/columns/Makefile
@@ -6,24 +6,22 @@
#
PORTNAME= columns
-PORTVERSION= 1.1
+PORTVERSION= 1.2b
CATEGORIES= games
-MASTER_SITES= ftp://ftp.phreax.net/
+MASTER_SITES= http://www.rzuser.uni-heidelberg.de/~dheck/columns/
+DISTNAME= Columns-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= SDL-1.0.2:${PORTSDIR}/devel/sdl
-ALL_TARGET= # empty
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl-config
USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/columns ${PREFIX}/bin
- @${MKDIR} ${PREFIX}/share/columns
- ${INSTALL_DATA} ${WRKSRC}/*.bmp ${PREFIX}/share/columns
- ${INSTALL_DATA} ${WRKSRC}/*.ofn ${PREFIX}/share/columns
- ${INSTALL_DATA} ${WRKSRC}/*.wav ${PREFIX}/share/columns
+post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/columns
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/columns
diff --git a/games/columns/distinfo b/games/columns/distinfo
index 6e462d3eb3b3..77d25b606969 100644
--- a/games/columns/distinfo
+++ b/games/columns/distinfo
@@ -1 +1 @@
-MD5 (columns-1.1.tar.gz) = 0fda1a083e15def49e727e57c5e3ea20
+MD5 (Columns-1.2b.tar.gz) = acedc5cab018b5033ce1b857505e9ee1
diff --git a/games/columns/files/patch-ab b/games/columns/files/patch-ab
index 3f9d920d3c2b..b8b0f61fd8a2 100644
--- a/games/columns/files/patch-ab
+++ b/games/columns/files/patch-ab
@@ -1,71 +1,12 @@
---- columns.cc Thu Aug 5 15:19:15 1999
-+++ /home/andy/tmp/wrk/columns.cc Thu Aug 26 12:05:16 1999
-@@ -2,7 +2,9 @@
-
+--- columns.cc.orig Fri Mar 17 09:52:55 2000
++++ columns.cc Sat Oct 28 03:29:21 2000
+@@ -22,7 +22,9 @@
+ #include <stdarg.h>
#include <stdio.h>
#include <string.h>
-+#ifndef __FreeBSD__
++#ifndef __STDC__
#include <malloc.h>
+#endif
#include <stdlib.h>
- #include <sys/time.h>
+ #include <time.h>
#include <SDL/SDL.h>
-@@ -924,22 +926,22 @@
- void init_sound ()
- {
- audio_init ();
-- drop_wav = audio_load ("drop.wav");
-- rotate_wav = audio_load ("rotate.wav");
-- move_wav = audio_load ("move.wav");
-- gameover_wav = audio_load ("gameover.wav");
-- hello_wav = audio_load ("hello.wav");
-- perfect_wav = audio_load ("perfect.wav");
-- applause_wav = audio_load ("applause.wav");
-- remove_wav = audio_load ("remove.wav");
-- level_wav = audio_load ("level.wav");
-- bye_wav = audio_load ("bye.wav");
-+ drop_wav = audio_load (PREFIX "/share/columns/drop.wav");
-+ rotate_wav = audio_load (PREFIX "/share/columns/rotate.wav");
-+ move_wav = audio_load (PREFIX "/share/columns/move.wav");
-+ gameover_wav = audio_load (PREFIX "/share/columns/gameover.wav");
-+ hello_wav = audio_load (PREFIX "/share/columns/hello.wav");
-+ perfect_wav = audio_load (PREFIX "/share/columns/perfect.wav");
-+ applause_wav = audio_load (PREFIX "/share/columns/applause.wav");
-+ remove_wav = audio_load (PREFIX "/share/columns/remove.wav");
-+ level_wav = audio_load (PREFIX "/share/columns/level.wav");
-+ bye_wav = audio_load (PREFIX "/share/columns/bye.wav");
- }
-
- /* load bitmaps */
- void init_gfx ()
- {
-- SDL_Surface *img = SDL_LoadBMP ("tiles.bmp");
-+ SDL_Surface *img = SDL_LoadBMP (PREFIX "/share/columns/tiles.bmp");
- if (img == NULL) {
- fprintf (stderr, "couldn't load 'tiles.bmp'\n");
- exit (1);
-@@ -950,11 +952,11 @@
- SDL_SetColorKey (tiles, SDL_SRCCOLORKEY, 0);
-
- {
-- FILE *fp = fopen("bg.bmp", "rb");
-+ FILE *fp = fopen(PREFIX "/share/columns/bg.bmp", "rb");
- background = NULL;
- if (fp != NULL) {
- fclose (fp);
-- img = SDL_LoadBMP ("bg.bmp");
-+ img = SDL_LoadBMP (PREFIX "/share/columns/bg.bmp");
- if (img == NULL) {
- fprintf (stderr, "couldn't load `bg.bmp': %s\n", SDL_GetError ());
- } else {
-@@ -979,8 +981,8 @@
- void init_fonts ()
- {
- /* Load font data. */
-- small_font = load_font ("small.ofn");
-- big_font = load_font ("big.ofn");
-+ small_font = load_font (PREFIX "/share/columns/small.ofn");
-+ big_font = load_font (PREFIX "/share/columns/big.ofn");
- if (small_font == NULL || big_font == NULL) {
- fprintf (stderr, "couldn't load fonts\n");
- exit (1);
diff --git a/games/columns/files/patch-ac b/games/columns/files/patch-ac
new file mode 100644
index 000000000000..f7623dbe5c97
--- /dev/null
+++ b/games/columns/files/patch-ac
@@ -0,0 +1,10 @@
+--- configure.orig Fri Mar 17 08:33:59 2000
++++ configure Sat Oct 28 03:23:44 2000
+@@ -1292,6 +1292,7 @@
+ rm -f conf.sdltest
+
+ CFLAGS="$CFLAGS $SDL_CFLAGS"
++CXXFLAGS="$CXXFLAGS $SDL_CFLAGS"
+ LIBS="$LIBS $SDL_LIBS"
+
+ # Finally create all the generated files
diff --git a/games/columns/pkg-descr b/games/columns/pkg-descr
index fa8fe017dad7..9082cedd0d19 100644
--- a/games/columns/pkg-descr
+++ b/games/columns/pkg-descr
@@ -6,6 +6,6 @@ the public domain, so you may do everything you like with it. If
you have any questions or suggestions, don't hesitate to drop me a
line.
-Author: Daniel (dheck@gmx.net, daniel@phreax.net)
+Author: Daniel (dheck@gmx.net, dheck@ix.urz.uni-heidelberg.de)
-WWW: http://www.phreax.net/24h/
+WWW: http://www.rzuser.uni-heidelberg.de/~dheck/columns/
diff --git a/games/columns/pkg-plist b/games/columns/pkg-plist
index cdb19dbfa59e..c7ad4f660490 100644
--- a/games/columns/pkg-plist
+++ b/games/columns/pkg-plist
@@ -1,19 +1,22 @@
bin/columns
-share/columns/applause.wav
-share/columns/bg.bmp
-share/columns/big.ofn
-share/columns/bye.wav
-share/columns/drop.wav
-share/columns/gameover.wav
-share/columns/hello.wav
-share/columns/laugh.wav
-share/columns/level.wav
-share/columns/move.wav
-share/columns/perfect.wav
-share/columns/remove.wav
-share/columns/rotate.wav
-share/columns/small.ofn
-share/columns/tiles.bmp
+share/Columns/applause.wav
+share/Columns/bg.bmp
+share/Columns/big.fnt
+share/Columns/bye.wav
+@mode 0666
+share/Columns/columns.hsc
+@mode
+share/Columns/drop.wav
+share/Columns/hello.wav
+share/Columns/laugh.wav
+share/Columns/level.wav
+share/Columns/magic.wav
+share/Columns/move.wav
+share/Columns/perfect.wav
+share/Columns/remove.wav
+share/Columns/rotate.wav
+share/Columns/small.fnt
+share/Columns/tiles.bmp
share/doc/columns/README
-@dirrm share/columns
@dirrm share/doc/columns
+@dirrm share/Columns