aboutsummaryrefslogtreecommitdiff
path: root/games/columns
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-09-09 01:42:05 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-09-09 01:42:05 +0000
commit473b4251587ab0bfa9e0b35be73bc6e01647f183 (patch)
treed7c4c71210232b8679e2202f1de86defea697611 /games/columns
parentfc9a16af6c7b5cbc04904bb762ae03577828b3bd (diff)
downloadports-473b4251587ab0bfa9e0b35be73bc6e01647f183.tar.gz
ports-473b4251587ab0bfa9e0b35be73bc6e01647f183.zip
Nice little implementation of columns game for X Window System
PR: 13392 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Notes
Notes: svn path=/head/; revision=21460
Diffstat (limited to 'games/columns')
-rw-r--r--games/columns/Makefile34
-rw-r--r--games/columns/distinfo1
-rw-r--r--games/columns/files/patch-ab71
-rw-r--r--games/columns/pkg-comment1
-rw-r--r--games/columns/pkg-descr11
-rw-r--r--games/columns/pkg-plist19
6 files changed, 137 insertions, 0 deletions
diff --git a/games/columns/Makefile b/games/columns/Makefile
new file mode 100644
index 000000000000..9fe6f24ef602
--- /dev/null
+++ b/games/columns/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: columns
+# Version required: 1.1
+# Date created: 26 August 1999
+# Whom: Andrey Zakhvatov
+#
+# $FreeBSD$
+#
+
+DISTNAME= columns-1.1
+CATEGORIES= games
+MASTER_SITES= ftp://ftp.phreax.net/
+
+MAINTAINER= andy@icc.surw.chel.su
+
+LIB_DEPENDS= SDL.0:${PORTSDIR}/devel/sdl
+
+ALL_TARGET=
+
+USE_X_PREFIX= yes
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/columns ${PREFIX}/bin
+ @ ${MKDIR} ${PREFIX}/share/columns
+ @ ${INSTALL_DATA} ${WRKSRC}/*.bmp ${PREFIX}/share/columns
+ @ ${INSTALL_DATA} ${WRKSRC}/*.ofn ${PREFIX}/share/columns
+ @ ${INSTALL_DATA} ${WRKSRC}/*.wav ${PREFIX}/share/columns
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/columns
+ @ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/columns
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/columns/distinfo b/games/columns/distinfo
new file mode 100644
index 000000000000..6e462d3eb3b3
--- /dev/null
+++ b/games/columns/distinfo
@@ -0,0 +1 @@
+MD5 (columns-1.1.tar.gz) = 0fda1a083e15def49e727e57c5e3ea20
diff --git a/games/columns/files/patch-ab b/games/columns/files/patch-ab
new file mode 100644
index 000000000000..3f9d920d3c2b
--- /dev/null
+++ b/games/columns/files/patch-ab
@@ -0,0 +1,71 @@
+--- columns.cc Thu Aug 5 15:19:15 1999
++++ /home/andy/tmp/wrk/columns.cc Thu Aug 26 12:05:16 1999
+@@ -2,7 +2,9 @@
+
+ #include <stdio.h>
+ #include <string.h>
++#ifndef __FreeBSD__
+ #include <malloc.h>
++#endif
+ #include <stdlib.h>
+ #include <sys/time.h>
+ #include <SDL/SDL.h>
+@@ -924,22 +926,22 @@
+ void init_sound ()
+ {
+ audio_init ();
+- drop_wav = audio_load ("drop.wav");
+- rotate_wav = audio_load ("rotate.wav");
+- move_wav = audio_load ("move.wav");
+- gameover_wav = audio_load ("gameover.wav");
+- hello_wav = audio_load ("hello.wav");
+- perfect_wav = audio_load ("perfect.wav");
+- applause_wav = audio_load ("applause.wav");
+- remove_wav = audio_load ("remove.wav");
+- level_wav = audio_load ("level.wav");
+- bye_wav = audio_load ("bye.wav");
++ drop_wav = audio_load (PREFIX "/share/columns/drop.wav");
++ rotate_wav = audio_load (PREFIX "/share/columns/rotate.wav");
++ move_wav = audio_load (PREFIX "/share/columns/move.wav");
++ gameover_wav = audio_load (PREFIX "/share/columns/gameover.wav");
++ hello_wav = audio_load (PREFIX "/share/columns/hello.wav");
++ perfect_wav = audio_load (PREFIX "/share/columns/perfect.wav");
++ applause_wav = audio_load (PREFIX "/share/columns/applause.wav");
++ remove_wav = audio_load (PREFIX "/share/columns/remove.wav");
++ level_wav = audio_load (PREFIX "/share/columns/level.wav");
++ bye_wav = audio_load (PREFIX "/share/columns/bye.wav");
+ }
+
+ /* load bitmaps */
+ void init_gfx ()
+ {
+- SDL_Surface *img = SDL_LoadBMP ("tiles.bmp");
++ SDL_Surface *img = SDL_LoadBMP (PREFIX "/share/columns/tiles.bmp");
+ if (img == NULL) {
+ fprintf (stderr, "couldn't load 'tiles.bmp'\n");
+ exit (1);
+@@ -950,11 +952,11 @@
+ SDL_SetColorKey (tiles, SDL_SRCCOLORKEY, 0);
+
+ {
+- FILE *fp = fopen("bg.bmp", "rb");
++ FILE *fp = fopen(PREFIX "/share/columns/bg.bmp", "rb");
+ background = NULL;
+ if (fp != NULL) {
+ fclose (fp);
+- img = SDL_LoadBMP ("bg.bmp");
++ img = SDL_LoadBMP (PREFIX "/share/columns/bg.bmp");
+ if (img == NULL) {
+ fprintf (stderr, "couldn't load `bg.bmp': %s\n", SDL_GetError ());
+ } else {
+@@ -979,8 +981,8 @@
+ void init_fonts ()
+ {
+ /* Load font data. */
+- small_font = load_font ("small.ofn");
+- big_font = load_font ("big.ofn");
++ small_font = load_font (PREFIX "/share/columns/small.ofn");
++ big_font = load_font (PREFIX "/share/columns/big.ofn");
+ if (small_font == NULL || big_font == NULL) {
+ fprintf (stderr, "couldn't load fonts\n");
+ exit (1);
diff --git a/games/columns/pkg-comment b/games/columns/pkg-comment
new file mode 100644
index 000000000000..aca0ecd58f47
--- /dev/null
+++ b/games/columns/pkg-comment
@@ -0,0 +1 @@
+Nice little implementation of columns game for X Window System
diff --git a/games/columns/pkg-descr b/games/columns/pkg-descr
new file mode 100644
index 000000000000..fa8fe017dad7
--- /dev/null
+++ b/games/columns/pkg-descr
@@ -0,0 +1,11 @@
+Columns is a nice little implementation of columns, the game we all
+used to play on our Game Gears... If you like it, play it. If you
+find any bugs, go ahead and fix them. If you have some nice ideas
+concerning the game, well, just implement them. The source is in
+the public domain, so you may do everything you like with it. If
+you have any questions or suggestions, don't hesitate to drop me a
+line.
+
+Author: Daniel (dheck@gmx.net, daniel@phreax.net)
+
+WWW: http://www.phreax.net/24h/
diff --git a/games/columns/pkg-plist b/games/columns/pkg-plist
new file mode 100644
index 000000000000..cdb19dbfa59e
--- /dev/null
+++ b/games/columns/pkg-plist
@@ -0,0 +1,19 @@
+bin/columns
+share/columns/applause.wav
+share/columns/bg.bmp
+share/columns/big.ofn
+share/columns/bye.wav
+share/columns/drop.wav
+share/columns/gameover.wav
+share/columns/hello.wav
+share/columns/laugh.wav
+share/columns/level.wav
+share/columns/move.wav
+share/columns/perfect.wav
+share/columns/remove.wav
+share/columns/rotate.wav
+share/columns/small.ofn
+share/columns/tiles.bmp
+share/doc/columns/README
+@dirrm share/columns
+@dirrm share/doc/columns