aboutsummaryrefslogtreecommitdiff
path: root/games/corewars
diff options
context:
space:
mode:
authorBill Fumerola <billf@FreeBSD.org>2000-03-07 04:38:43 +0000
committerBill Fumerola <billf@FreeBSD.org>2000-03-07 04:38:43 +0000
commit9a7718ef9fe317b09f53ef7a594badfba546eeb4 (patch)
treeb157631951e7b09fddbf78691a81008e760af4f6 /games/corewars
parent10610b6921319bea0e03a252aa9a38f2418253c0 (diff)
downloadports-9a7718ef9fe317b09f53ef7a594badfba546eeb4.tar.gz
ports-9a7718ef9fe317b09f53ef7a594badfba546eeb4.zip
Bruteforce bitchslap this port into respecting CFLAGS.
Approved by: jim
Notes
Notes: svn path=/head/; revision=26598
Diffstat (limited to 'games/corewars')
-rw-r--r--games/corewars/Makefile1
-rw-r--r--games/corewars/files/patch-aa13
2 files changed, 12 insertions, 2 deletions
diff --git a/games/corewars/Makefile b/games/corewars/Makefile
index 74ea196491d4..70be1e7365c4 100644
--- a/games/corewars/Makefile
+++ b/games/corewars/Makefile
@@ -22,6 +22,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" \
GLIB_CONFIG="${GLIB_CONFIG}"
+MAKE_ENV= FREEBSD_CFLAGS="${CFLAGS}"
post-install:
@strip ${PREFIX}/bin/corewars
diff --git a/games/corewars/files/patch-aa b/games/corewars/files/patch-aa
index 4dd6d4da56a9..a0b661a443a8 100644
--- a/games/corewars/files/patch-aa
+++ b/games/corewars/files/patch-aa
@@ -1,5 +1,5 @@
---- src/Makefile.in.orig Sat Mar 4 18:12:42 2000
-+++ src/Makefile.in Sat Mar 4 18:12:55 2000
+--- src/Makefile.in.orig Fri Mar 3 13:37:26 2000
++++ src/Makefile.in Mon Mar 6 23:29:17 2000
@@ -95,7 +95,7 @@
AM_YFLAGS = -d -t
@@ -9,3 +9,12 @@
DEFS = @DEFS@ -DDATADIR="\"${pkgdatadir}\""
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = config.h
+@@ -113,7 +113,7 @@
+ LEX_OUTPUT_ROOT = @LEX_OUTPUT_ROOT@
+ LEXLIB = @LEXLIB@
+ CFLAGS = @CFLAGS@
+-COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
++COMPILE = $(CC) $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) $(FREEBSD_CFLAGS)
+ CCLD = $(CC)
+ LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(LDFLAGS) -o $@
+ DIST_COMMON = ./stamp-h.in Makefile.am Makefile.in config.h.in lex.c \