aboutsummaryrefslogtreecommitdiff
path: root/games/corsix-th
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-10-21 16:07:53 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-10-21 16:07:53 +0000
commitbc3651b3cd533c81fd064f9531609aa73cfdee79 (patch)
treedd5c338305b99217f63e7c60ef8dc71557b01d2f /games/corsix-th
parentf4c56f4aa9e0e8035878450416f3c2745868d1c6 (diff)
downloadports-bc3651b3cd533c81fd064f9531609aa73cfdee79.tar.gz
ports-bc3651b3cd533c81fd064f9531609aa73cfdee79.zip
games/corsix-th: use ffmpeg instead of ffmpeg1
- Use ffmpeg instead of ffmpeg1 Approved by: portmgr (bapt, implicit)
Notes
Notes: svn path=/head/; revision=331152
Diffstat (limited to 'games/corsix-th')
-rw-r--r--games/corsix-th/Makefile4
-rw-r--r--games/corsix-th/files/patch-CMake-FindFFmpeg.cmake44
2 files changed, 2 insertions, 46 deletions
diff --git a/games/corsix-th/Makefile b/games/corsix-th/Makefile
index 015c2c2337a5..6e105bab4bad 100644
--- a/games/corsix-th/Makefile
+++ b/games/corsix-th/Makefile
@@ -3,7 +3,7 @@
PORTNAME= corsixth
PORTVERSION= 0.21
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= GOOGLE_CODE
PROJECTHOST= corsix-th
@@ -29,7 +29,7 @@ MOVIES_DESC= Play in-game movies
MOVIES_CMAKE_ON= -DWITH_MOVIES=ON
MOVIES_CMAKE_OFF= -DWITH_MOVIES=OFF
-MOVIES_LIB_DEPENDS= libswresample1.so:${PORTSDIR}/multimedia/ffmpeg1
+MOVIES_LIB_DEPENDS= libswresample.so:${PORTSDIR}/multimedia/ffmpeg
.include <bsd.port.options.mk>
diff --git a/games/corsix-th/files/patch-CMake-FindFFmpeg.cmake b/games/corsix-th/files/patch-CMake-FindFFmpeg.cmake
deleted file mode 100644
index 2ec3d6adb514..000000000000
--- a/games/corsix-th/files/patch-CMake-FindFFmpeg.cmake
+++ /dev/null
@@ -1,44 +0,0 @@
---- CMake/FindFFmpeg.cmake.orig 2013-03-24 17:28:47.675682879 +0100
-+++ CMake/FindFFmpeg.cmake 2013-03-24 17:29:04.915681918 +0100
-@@ -70,16 +70,16 @@
-
- find_path(${_component}_INCLUDE_DIRS ${_header}
- HINTS
-- ${PC_LIB${_component}_INCLUDEDIR}
-- ${PC_LIB${_component}_INCLUDE_DIRS}
-+ ${PC_${_component}_INCLUDEDIR}
-+ ${PC_${_component}_INCLUDE_DIRS}
- PATH_SUFFIXES
- ffmpeg
- )
-
- find_library(${_component}_LIBRARIES NAMES ${_library}
- HINTS
-- ${PC_LIB${_component}_LIBDIR}
-- ${PC_LIB${_component}_LIBRARY_DIRS}
-+ ${PC_${_component}_LIBDIR}
-+ ${PC_${_component}_LIBRARY_DIRS}
- )
-
- set(${_component}_DEFINITIONS ${PC_${_component}_CFLAGS_OTHER} CACHE STRING "The ${_component} CFLAGS.")
-@@ -94,13 +94,13 @@
- if (NOT FFMPEG_LIBRARIES)
-
- # Check for all possible component.
-- find_component(AVCODEC libavcodec avcodec libavcodec/avcodec.h)
-- find_component(AVFORMAT libavformat avformat libavformat/avformat.h)
-- find_component(AVDEVICE libavdevice avdevice libavdevice/avdevice.h)
-- find_component(AVUTIL libavutil avutil libavutil/avutil.h)
-- find_component(SWSCALE libswscale swscale libswscale/swscale.h)
-- find_component(POSTPROC libpostproc postproc libpostproc/postprocess.h)
-- find_component(SWRESAMPLE libswresample swresample libswresample/swresample.h)
-+ find_component(AVCODEC libavcodec1 avcodec1 libavcodec/avcodec.h)
-+ find_component(AVFORMAT libavformat1 avformat1 libavformat/avformat.h)
-+ find_component(AVDEVICE libavdevice1 avdevice1 libavdevice/avdevice.h)
-+ find_component(AVUTIL libavutil1 avutil1 libavutil/avutil.h)
-+ find_component(SWSCALE libswscale1 swscale1 libswscale/swscale.h)
-+ find_component(POSTPROC libpostproc1 postproc1 libpostproc/postprocess.h)
-+ find_component(SWRESAMPLE libswresample1 swresample1 libswresample/swresample.h)
-
- # Check if the required components were found and add their stuff to the FFMPEG_* vars.
- foreach (_component ${FFmpeg_FIND_COMPONENTS})