aboutsummaryrefslogtreecommitdiff
path: root/games/crafty
diff options
context:
space:
mode:
authorMatthew Hunt <mph@FreeBSD.org>2001-04-03 21:19:45 +0000
committerMatthew Hunt <mph@FreeBSD.org>2001-04-03 21:19:45 +0000
commitdae49830577aedfa0aa6337d18334ef345828781 (patch)
tree1c689a6d58388ca2686006ed357e74ff4ca2e609 /games/crafty
parentac91be5bdbc4b2a028bf40bc7b5e6891a290ccf3 (diff)
downloadports-dae49830577aedfa0aa6337d18334ef345828781.tar.gz
ports-dae49830577aedfa0aa6337d18334ef345828781.zip
Upgrade to 18.9.
Notes
Notes: svn path=/head/; revision=40816
Diffstat (limited to 'games/crafty')
-rw-r--r--games/crafty/Makefile12
-rw-r--r--games/crafty/distinfo2
-rw-r--r--games/crafty/files/patch-aa110
3 files changed, 43 insertions, 81 deletions
diff --git a/games/crafty/Makefile b/games/crafty/Makefile
index cad678e68638..721aac14471b 100644
--- a/games/crafty/Makefile
+++ b/games/crafty/Makefile
@@ -6,19 +6,23 @@
#
PORTNAME= crafty
-PORTVERSION= 17.9
+PORTVERSION= 18.9
CATEGORIES= games
MASTER_SITES= ftp://ftp.cis.uab.edu/pub/hyatt/ \
ftp://ftp.cis.uab.edu/pub/hyatt/common/ \
- ftp://ftp.cis.uab.edu/pub/hyatt/v17/ \
+ ftp://ftp.cis.uab.edu/pub/hyatt/v18/ \
ftp://ftp.jpunix.com/pub/hyatt/ \
ftp://ftp.jpunix.com/pub/hyatt/common/ \
- ftp://ftp.jpunix.com/pub/hyatt/v17/
+ ftp://ftp.jpunix.com/pub/hyatt/v18/
DISTFILES= crafty-${PORTVERSION}.tar.gz crafty.doc crafty.faq read.me start.zip
MAINTAINER= seggers@semyam.dinoco.de
-ALL_TARGET= crafty
+.if ${MACHINE_ARCH} == "i386"
+ALL_TARGET= freebsd-i386
+.else
+ALL_TARGET= freebsd-generic
+.endif
DIST_SUBDIR= crafty
EXTRACT_ONLY= crafty-${PORTVERSION}.tar.gz
IGNOREFILES= crafty.doc crafty.faq read.me
diff --git a/games/crafty/distinfo b/games/crafty/distinfo
index c264801fa7ed..2835465a3cdd 100644
--- a/games/crafty/distinfo
+++ b/games/crafty/distinfo
@@ -1,4 +1,4 @@
-MD5 (crafty/crafty-17.9.tar.gz) = 6ad77e195bd39b89179cd8ec34feb697
+MD5 (crafty/crafty-18.9.tar.gz) = 439b591eb48957ce50bfd31f9bada8fb
MD5 (crafty/start.zip) = 7a9faa5c4c0af5a2defa4dca942daf3d
MD5 (crafty/crafty.doc) = IGNORE
MD5 (crafty/crafty.faq) = IGNORE
diff --git a/games/crafty/files/patch-aa b/games/crafty/files/patch-aa
index 2c89d36fda05..79e77ce3194e 100644
--- a/games/crafty/files/patch-aa
+++ b/games/crafty/files/patch-aa
@@ -1,80 +1,38 @@
---- Makefile.orig Sun Jan 30 20:43:42 2000
-+++ Makefile Tue May 16 11:06:31 2000
-@@ -23,7 +23,7 @@
- # SGI {SGI Workstation running Irix (SYSV/R4) Unix}
- # SUN {Sun SparcStation running Solaris (SYSV/R4) Unix}
- # SUN_BSD {Sun SparcStation running SunOS (BSD) Unix}
--# FreeBSD {80X86 architecture running FreeBSD (unix)}
-+# FreeBSD {80X86/Alpha architecture running FreeBSD (unix)}
+--- Makefile.orig Tue Apr 3 12:43:10 2001
++++ Makefile Tue Apr 3 12:45:43 2001
+@@ -21,7 +21,7 @@
+ # SGI {SGI Workstation running Irix (SYSV/R4) Unix}
+ # SUN {Sun SparcStation running Solaris (SYSV/R4) Unix}
+ # SUN_GCC {Sun SparcStation running Solaris but using gcc
+-# FreeBSD {80X86 architecture running FreeBSD (Unix)}
++# FreeBSD {80X86/Alpha architecture running FreeBSD (Unix)}
+ # NetBSD {multi-architecture running NetBSD (Unix)}
+ # Cygwin {80X86 running Cygwin under Win32 (Unix)}
#
- # The next options are optimizations inside Crafty that you will have
- # test to see if they help. on some machines, these will slow things
-@@ -83,13 +83,17 @@
- # asm = X86.o
+@@ -142,14 +142,23 @@
+ asm='X86.o' \
+ crafty-make
- # FreeBSD (gcc 2.6.3)
--#target = FreeBSD
-+target = FreeBSD
- #CC = gcc
- #CFLAGS = -fomit-frame-pointer -m486 -O3 -Wall
--#CPP = $(CC)
--#LDFLAGS =
--#opt = -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
--# -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST
-+CPP = $(CXX)
-+LDFLAGS =
-+.if ${MACHINE_ARCH} == "i386"
-+opt = -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
-+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST
-+.else
-+opt = -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS -DFAST
-+.endif
-
- # FreeBSD (pgcc)
- #target = FreeBSD
-@@ -111,20 +115,27 @@
-
- # LINUX (gcc 2.95)
- # Note: You have to uncomment exactly ONE of the `asm' lines below.
--target = LINUX
--CC = gcc
--CPP = g++
--CFLAGS = -Wall -pipe -D_REENTRANT -march=i686 -O -fforce-mem \
-- -fomit-frame-pointer -mpreferred-stack-boundary=2
--LDFLAGS = -lpthread
--opt = -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
-- -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST -DSMP -DCPUS=4 -DDGT
-+#target = LINUX
-+#CC = gcc
-+#CPP = g++
-+#CFLAGS = -Wall -pipe -D_REENTRANT -march=i686 -O -fforce-mem \
-+# -fomit-frame-pointer -mpreferred-stack-boundary=2
-+#LDFLAGS = -lpthread
-+#opt = -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
-+# -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST -DSMP -DCPUS=4 -DDGT
-+
-
- # Uncomment the FIRST `asm' line for a.out systems.
- # Uncomment the SECOND `asm' line for ELF systems.
- #
--#asm = X86-aout.o
-+.if ${MACHINE_ARCH} == "i386"
-+.if ${PORTOBJFORMAT} == "aout"
-+asm = X86-aout.o
-+.else
- asm = X86-elf.o
-+.endif
-+.endif
+-freebsd:
++freebsd-i386:
+ $(MAKE) target=FreeBSD \
+- CC=gcc CXX='$$(CC)' \
+- CFLAGS='$(CFLAGS) -fomit-frame-pointer -m486 -O3 -Wall' \
++ CC='$(CC)' CXX='$(CXX)' \
++ CFLAGS='$(CFLAGS)' \
+ LDFLAGS='$(LDFLAGS)' \
+ opt='$(opt) -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST' \
+ asm=X86-elf.o \
++ crafty-make
+
-
- # NEXT
- #target = NEXT
-@@ -169,7 +180,7 @@
-
- # Do not change anything below this line!
-
--opts = $(opt) -D$(target)
-+CFLAGS += $(opt) -D$(target)
++# This should work for non-i386 FreeBSD (e.g. Alpha)
++freebsd-generic:
++ $(MAKE) target=FreeBSD \
++ CC='$(CC) CXX='$(CXX)' \
++ CFLAGS='$(CFLAGS)' \
++ LDFLAGS='$(LDFLAGS)' \
++ opt='$(opt) -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS -DFAST' \
+ crafty-make
- objects = searchr.o search.o thread.o searchmp.o repeat.o next.o nexte.o \
- nextr.o history.o quiesce.o evaluate.o movgen.o make.o unmake.o hash.o \
+ freebsd-pgcc: