aboutsummaryrefslogtreecommitdiff
path: root/games/crafty
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2005-04-11 08:04:41 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2005-04-11 08:04:41 +0000
commitf2fc2d60ae226a1b8d5411fb4aab91ea92be6f91 (patch)
treee9a77f53d4fe679665594e718ad34b49668507cc /games/crafty
parent063f8ca62467e4709e58c8bb6b67c85970fe28a1 (diff)
downloadports-f2fc2d60ae226a1b8d5411fb4aab91ea92be6f91.tar.gz
ports-f2fc2d60ae226a1b8d5411fb4aab91ea92be6f91.zip
Assist getting more ports working on AMD64 by obeying the
Ports Collection documentation and use 'ARCH' rather than 'MACHINE_ARCH'.
Notes
Notes: svn path=/head/; revision=132992
Diffstat (limited to 'games/crafty')
-rw-r--r--games/crafty/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/games/crafty/Makefile b/games/crafty/Makefile
index 2cd07e921b51..2662eaedd33c 100644
--- a/games/crafty/Makefile
+++ b/games/crafty/Makefile
@@ -25,11 +25,11 @@ DISTFILES+= ${DOCFILES:S/$/:doc/}
ALL_TARGET= crafty
OPT= -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS
-.if ${MACHINE_ARCH} == "i386"
+.if ${ARCH} == "i386"
MAKE_ENV+= asm=X86-elf.o
OPT+= -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST
# XXX Someone with ASM knowledge would have to fix the Sparc.S
-.elif ${MACHINE_ARCH} == "sparc64" && defined(CRAFTY_SPARC_ASM)
+.elif ${ARCH} == "sparc64" && defined(CRAFTY_SPARC_ASM)
MAKE_ENV+= asm=Sparc.o
OPT+= -DUSE_ASSEMBLY_A
.else