aboutsummaryrefslogtreecommitdiff
path: root/games/crafty
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-03-22 15:31:09 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-03-22 15:31:09 +0000
commit755c293dc37ac6a6538d47c4e79d2d397b151d8e (patch)
tree53c450325841c7ea4eb95a68564ec1a372dbec23 /games/crafty
parente5e16bf6f6c667b1ee2dfcf79134be057ea854e0 (diff)
downloadports-755c293dc37ac6a6538d47c4e79d2d397b151d8e.tar.gz
ports-755c293dc37ac6a6538d47c4e79d2d397b151d8e.zip
- Fix plist in ports depending on crafty
- Assign maintainership of crafty-open-* to submitter PR: 132935 Submitted by: Florian Smeets <flo at kasimir dot com> (crafty maintainer)
Notes
Notes: svn path=/head/; revision=230672
Diffstat (limited to 'games/crafty')
-rw-r--r--games/crafty/Makefile17
-rw-r--r--games/crafty/pkg-plist2
2 files changed, 17 insertions, 2 deletions
diff --git a/games/crafty/Makefile b/games/crafty/Makefile
index fb66c8e7c5fa..db3013fc46d6 100644
--- a/games/crafty/Makefile
+++ b/games/crafty/Makefile
@@ -7,6 +7,7 @@
PORTNAME= crafty
PORTVERSION= 22.10
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= ftp://ftp.cis.uab.edu/pub/hyatt/pgn/:data \
ftp://ftp.cis.uab.edu/pub/hyatt/documentation/:doc \
@@ -24,7 +25,7 @@ COMMENT= A chess programm for playing and analyzing games
USE_ZIP= yes
USE_GMAKE= yes
-BOOKS= book.bin books.bin
+BOOKS= books.bin
DISTFILES+= ${BOOKS:S/$/:books/}
.if !defined(NOPORTDOCS)
@@ -58,11 +59,23 @@ OPT+= -DINLINE32
BROKEN= Does not compile on sparc64
.endif
+.if defined(WITH_BOOK)
+BOOKS+= book.bin
+DISTFILES+= ${BOOKS:S/$/:books/}
+PKGNAMESUFFIX= -open-default
+CONFLICTS+= crafty-open-enormous-* crafty-open-large-* crafty-open-medium-*
+PLIST_SUB+= BOOK=""
+.else
+PLIST_SUB+= BOOK="@comment "
+.endif
+
MAKE_ENV+= opt="${OPT}" target=${OPSYS} CXFLAGS="${CXXFLAGS}"
post-extract:
${CP} ${DISTDIR}/${DIST_SUBDIR}/start.pgn ${WRKSRC}/start.pgn
+.if defined(WITH_BOOK)
${CP} ${DISTDIR}/${DIST_SUBDIR}/book.bin ${WRKSRC}/book.bin
+.endif
${CP} ${DISTDIR}/${DIST_SUBDIR}/books.bin ${WRKSRC}/books.bin
post-build:
@@ -75,7 +88,9 @@ do-install:
${MKDIR} ${PREFIX}/lib/crafty/cpf
${CHOWN} -R root:nogroup ${PREFIX}/lib/crafty
${CHMOD} 775 ${PREFIX}/lib/crafty ${PREFIX}/lib/crafty/cpf
+.if defined(WITH_BOOK)
${INSTALL_DATA} ${WRKSRC}/book.bin ${PREFIX}/lib/crafty/book.bin
+.endif
${INSTALL_DATA} ${WRKSRC}/books.bin ${PREFIX}/lib/crafty/books.bin
${INSTALL_DATA} ${WRKSRC}/crafty.hlp ${PREFIX}/lib/crafty/crafty.hlp
${CHOWN} root:nogroup ${PREFIX}/lib/crafty/book*
diff --git a/games/crafty/pkg-plist b/games/crafty/pkg-plist
index 9f4701ff5209..90289a6e013d 100644
--- a/games/crafty/pkg-plist
+++ b/games/crafty/pkg-plist
@@ -1,5 +1,5 @@
bin/crafty
-lib/crafty/book.bin
+%%BOOK%%lib/crafty/book.bin
lib/crafty/books.bin
lib/crafty/crafty.hlp
%%PORTDOCS%%share/doc/crafty/crafty.doc.ascii