aboutsummaryrefslogtreecommitdiff
path: root/games/crossfire-client
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-11-16 14:41:56 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-11-16 14:41:56 +0000
commit561e2abb63e3d75769e5c4a2fdccc3fb3dc35adf (patch)
tree2fe7d1e3dfbe23548c6b8af987ff799552e82efe /games/crossfire-client
parenta187a307f551b42ce9815d2965ad89f829abc4f8 (diff)
downloadports-561e2abb63e3d75769e5c4a2fdccc3fb3dc35adf.tar.gz
ports-561e2abb63e3d75769e5c4a2fdccc3fb3dc35adf.zip
- Update to version 1.6.0
PR: 59331 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=94095
Diffstat (limited to 'games/crossfire-client')
-rw-r--r--games/crossfire-client/Makefile26
-rw-r--r--games/crossfire-client/distinfo2
-rw-r--r--games/crossfire-client/files/patch-configure11
-rw-r--r--games/crossfire-client/files/patch-configure.in11
-rw-r--r--games/crossfire-client/pkg-plist72
5 files changed, 65 insertions, 57 deletions
diff --git a/games/crossfire-client/Makefile b/games/crossfire-client/Makefile
index 28155295b4cd..542a63e2d03e 100644
--- a/games/crossfire-client/Makefile
+++ b/games/crossfire-client/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= crossfire-client
-PORTVERSION= 1.5.0
+PORTVERSION= 1.6.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.ifi.uio.no/pub/crossfire/ \
ftp://ftp.real-time.com/pub/games/crossfire/
MASTER_SITE_SUBDIR= ${PORTNAME:S/-client//}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- ${PORTNAME}-images-${PORTVERSION}${EXTRACT_SUFX} \
+ ${PORTNAME}-images-1.5.0${EXTRACT_SUFX} \
${PORTNAME}-sounds-1.4.0${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
@@ -22,23 +22,31 @@ COMMENT= Multiplayer graphical arcade and adventure game made for X11
USE_X_PREFIX= yes
USE_PERL5= yes
USE_XPM= yes
-USE_GNOME= gtk12
+WANT_GNOME= yes
+USE_GNOME= gnometarget
USE_GMAKE= yes
-USE_AUTOCONF_VER= 253
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
CONFIGURE_ARGS= --with-sound-dir=${DATADIR}/sounds \
--disable-gnome # Gnome client currently broken
-MAN1= cfclient.1 gcfclient.1
+MAN1= cfclient.1
+
+.include <bsd.port.pre.mk>
+
+.if ${HAVE_GNOME:Mgtk12}!=""
+USE_GNOME+= gtk12
+MAN1= gcfclient.1
+.else
+CONFIGURE_ARGS+= --disable-gtk
+.endif
.if defined(WITHOUT_SDL)
CONFIGURE_ARGS+= --disable-sdl
.else
LIB_DEPENDS+= SDL_image.10:${PORTSDIR}/graphics/sdl_image
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
-CONFIGURE_ENV+= SDL_CONFIG="${SDL_CONFIG}"
+USE_SDL= yes
.endif
post-install:
@@ -50,4 +58,4 @@ post-install:
${INSTALL_DATA} ${WRKDIR}/sounds/README ${DATADIR}/sounds
${INSTALL_DATA} ${WRKDIR}/sounds/*.raw ${DATADIR}/sounds
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/games/crossfire-client/distinfo b/games/crossfire-client/distinfo
index c96bf03daa14..471df214b4a7 100644
--- a/games/crossfire-client/distinfo
+++ b/games/crossfire-client/distinfo
@@ -1,3 +1,3 @@
-MD5 (crossfire-client-1.5.0.tar.gz) = 8f7e09f18cdbfbf45aea2fc06a6472cb
+MD5 (crossfire-client-1.6.0.tar.gz) = 90f46a9f74ab0d2b82ccfb2812e5d6cf
MD5 (crossfire-client-images-1.5.0.tar.gz) = 63cbfb00ff8000f2567880b72c8162bd
MD5 (crossfire-client-sounds-1.4.0.tar.gz) = 1b33401d9d2af0d391fee7ad04282cfd
diff --git a/games/crossfire-client/files/patch-configure b/games/crossfire-client/files/patch-configure
new file mode 100644
index 000000000000..0f7596ec4ea4
--- /dev/null
+++ b/games/crossfire-client/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.dist Fri Oct 10 15:32:37 2003
++++ configure Thu Nov 13 02:44:11 2003
+@@ -7810,6 +7810,8 @@
+
+ rm -f conf.sdltest
+
++ CPPFLAGS="$CPPFLAGS $SDL_CFLAGS"
++ LIBS="$LIBS $SDL_LIBS"
+ if eval "test x$no_sdl = x"; then
+ echo "$as_me:$LINENO: checking for IMG_LoadPNG_RW in -lSDL_image" >&5
+ echo $ECHO_N "checking for IMG_LoadPNG_RW in -lSDL_image... $ECHO_C" >&6
diff --git a/games/crossfire-client/files/patch-configure.in b/games/crossfire-client/files/patch-configure.in
deleted file mode 100644
index 0ba3a1dc01bc..000000000000
--- a/games/crossfire-client/files/patch-configure.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.in.orig Tue Jul 2 08:52:54 2002
-+++ configure.in Sat Jul 13 04:10:47 2002
-@@ -226,6 +226,8 @@
- dnl so I'll just assume it is in the same dir as SDL
- if eval "test x$use_sdl = xyes"; then
- AM_PATH_SDL(1.1.3)
-+ CPPFLAGS="$CPPFLAGS $SDL_CFLAGS"
-+ LIBS="$LIBS $SDL_LIBS"
- if eval "test x$no_sdl = x"; then
- AC_CHECK_LIB( SDL_image, IMG_LoadPNG_RW,
- have_sdlimage="yes", have_sdlimage="no", $SDL_CFLAGS)
diff --git a/games/crossfire-client/pkg-plist b/games/crossfire-client/pkg-plist
index 161a5d31594f..87c225147240 100644
--- a/games/crossfire-client/pkg-plist
+++ b/games/crossfire-client/pkg-plist
@@ -1,38 +1,38 @@
bin/cfclient
bin/cfsndserv
-bin/gcfclient
-share/crossfire-client/bmaps.client
-share/crossfire-client/crossfire.base
-share/crossfire-client/crossfire.clsc
-share/crossfire-client/sounds/Creaky-1.raw
-share/crossfire-client/sounds/Evil_Laugh.raw
-share/crossfire-client/sounds/Explosion.raw
-share/crossfire-client/sounds/FloorTom.raw
-share/crossfire-client/sounds/Gun-5.raw
-share/crossfire-client/sounds/MetalCrash.raw
-share/crossfire-client/sounds/Missed.raw
-share/crossfire-client/sounds/Missle1.raw
-share/crossfire-client/sounds/Puke.raw
-share/crossfire-client/sounds/README
-share/crossfire-client/sounds/Tear.raw
-share/crossfire-client/sounds/Teeswing.raw
-share/crossfire-client/sounds/TowerClock.raw
-share/crossfire-client/sounds/Whoosh.raw
-share/crossfire-client/sounds/blip.raw
-share/crossfire-client/sounds/boink2.raw
-share/crossfire-client/sounds/bugle_charge.raw
-share/crossfire-client/sounds/chord.raw
-share/crossfire-client/sounds/click1.raw
-share/crossfire-client/sounds/click2.raw
-share/crossfire-client/sounds/drip.raw
-share/crossfire-client/sounds/first_try.raw
-share/crossfire-client/sounds/gong.raw
-share/crossfire-client/sounds/lightning1.raw
-share/crossfire-client/sounds/magic.raw
-share/crossfire-client/sounds/ouch1.raw
-share/crossfire-client/sounds/phit2.raw
-share/crossfire-client/sounds/sci_fi_gun.raw
-share/crossfire-client/sounds/squish.raw
-share/crossfire-client/sounds/swish.raw
-@dirrm share/crossfire-client/sounds
-@dirrm share/crossfire-client
+%%GNOME:%%bin/gcfclient
+%%DATADIR%%/bmaps.client
+%%DATADIR%%/crossfire.base
+%%DATADIR%%/crossfire.clsc
+%%DATADIR%%/sounds/Creaky-1.raw
+%%DATADIR%%/sounds/Evil_Laugh.raw
+%%DATADIR%%/sounds/Explosion.raw
+%%DATADIR%%/sounds/FloorTom.raw
+%%DATADIR%%/sounds/Gun-5.raw
+%%DATADIR%%/sounds/MetalCrash.raw
+%%DATADIR%%/sounds/Missed.raw
+%%DATADIR%%/sounds/Missle1.raw
+%%DATADIR%%/sounds/Puke.raw
+%%DATADIR%%/sounds/README
+%%DATADIR%%/sounds/Tear.raw
+%%DATADIR%%/sounds/Teeswing.raw
+%%DATADIR%%/sounds/TowerClock.raw
+%%DATADIR%%/sounds/Whoosh.raw
+%%DATADIR%%/sounds/blip.raw
+%%DATADIR%%/sounds/boink2.raw
+%%DATADIR%%/sounds/bugle_charge.raw
+%%DATADIR%%/sounds/chord.raw
+%%DATADIR%%/sounds/click1.raw
+%%DATADIR%%/sounds/click2.raw
+%%DATADIR%%/sounds/drip.raw
+%%DATADIR%%/sounds/first_try.raw
+%%DATADIR%%/sounds/gong.raw
+%%DATADIR%%/sounds/lightning1.raw
+%%DATADIR%%/sounds/magic.raw
+%%DATADIR%%/sounds/ouch1.raw
+%%DATADIR%%/sounds/phit2.raw
+%%DATADIR%%/sounds/sci_fi_gun.raw
+%%DATADIR%%/sounds/squish.raw
+%%DATADIR%%/sounds/swish.raw
+@dirrm %%DATADIR%%/sounds
+@dirrm %%DATADIR%%