aboutsummaryrefslogtreecommitdiff
path: root/games/crossfire-client
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-07 07:49:10 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-07 07:49:10 +0000
commit90dedcd29f9d0b6f56ffd4a5e27b8dcfe1f60acb (patch)
treeb42ca28c32ed2a810012581e898f644d548d009e /games/crossfire-client
parent1dabc26fbc65e22f401b723f3f440eccaf80a9fd (diff)
downloadports-90dedcd29f9d0b6f56ffd4a5e27b8dcfe1f60acb.tar.gz
ports-90dedcd29f9d0b6f56ffd4a5e27b8dcfe1f60acb.zip
- Update to 1.7.0
- Give maintainership to submitter PR: ports/66347 Submitted by: Mark Daniel Reidel <ports@mark.reidel.info>
Notes
Notes: svn path=/head/; revision=108600
Diffstat (limited to 'games/crossfire-client')
-rw-r--r--games/crossfire-client/Makefile10
-rw-r--r--games/crossfire-client/distinfo4
-rw-r--r--games/crossfire-client/files/patch-common-script.c::signal.c11
-rw-r--r--games/crossfire-client/files/patch-configure11
4 files changed, 18 insertions, 18 deletions
diff --git a/games/crossfire-client/Makefile b/games/crossfire-client/Makefile
index fb68d4975c1e..9519cab4285e 100644
--- a/games/crossfire-client/Makefile
+++ b/games/crossfire-client/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= crossfire-client
-PORTVERSION= 1.6.0
-PORTREVISION= 2
+PORTVERSION= 1.7.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.ifi.uio.no/pub/crossfire/ \
@@ -17,7 +16,7 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
${PORTNAME}-images-1.5.0${EXTRACT_SUFX} \
${PORTNAME}-sounds-1.4.0${EXTRACT_SUFX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@mark.reidel.info
COMMENT= Multiplayer graphical arcade and adventure game made for X11
USE_X_PREFIX= yes
@@ -29,8 +28,9 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
-CONFIGURE_ARGS= --with-sound-dir=${DATADIR}/sounds \
- --disable-gnome # Gnome client currently broken
+CONFIGURE_ARGS= --with-sound-dir=${DATADIR}/sounds
+
+OPTIONS= SDL "Use SDL for images" on
MAN1= cfclient.1
diff --git a/games/crossfire-client/distinfo b/games/crossfire-client/distinfo
index ac18087c08b6..0f206ff4037d 100644
--- a/games/crossfire-client/distinfo
+++ b/games/crossfire-client/distinfo
@@ -1,5 +1,5 @@
-MD5 (crossfire-client-1.6.0.tar.gz) = 90f46a9f74ab0d2b82ccfb2812e5d6cf
-SIZE (crossfire-client-1.6.0.tar.gz) = 421159
+MD5 (crossfire-client-1.7.0.tar.gz) = ef405f78d54be0bf22feeef6b4fc0d73
+SIZE (crossfire-client-1.7.0.tar.gz) = 458940
MD5 (crossfire-client-images-1.5.0.tar.gz) = 63cbfb00ff8000f2567880b72c8162bd
SIZE (crossfire-client-images-1.5.0.tar.gz) = 1504405
MD5 (crossfire-client-sounds-1.4.0.tar.gz) = 1b33401d9d2af0d391fee7ad04282cfd
diff --git a/games/crossfire-client/files/patch-common-script.c::signal.c b/games/crossfire-client/files/patch-common-script.c::signal.c
new file mode 100644
index 000000000000..5cd2cb525f24
--- /dev/null
+++ b/games/crossfire-client/files/patch-common-script.c::signal.c
@@ -0,0 +1,11 @@
+--- common/script.c.orig Fri May 7 07:51:00 2004
++++ common/script.c Fri May 7 07:51:41 2004
+@@ -114,6 +114,8 @@
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <sys/wait.h>
++#include <sys/signal.h>
++#include <signal.h>
+ #endif
+
+ #include <client.h>
diff --git a/games/crossfire-client/files/patch-configure b/games/crossfire-client/files/patch-configure
deleted file mode 100644
index 0f7596ec4ea4..000000000000
--- a/games/crossfire-client/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.dist Fri Oct 10 15:32:37 2003
-+++ configure Thu Nov 13 02:44:11 2003
-@@ -7810,6 +7810,8 @@
-
- rm -f conf.sdltest
-
-+ CPPFLAGS="$CPPFLAGS $SDL_CFLAGS"
-+ LIBS="$LIBS $SDL_LIBS"
- if eval "test x$no_sdl = x"; then
- echo "$as_me:$LINENO: checking for IMG_LoadPNG_RW in -lSDL_image" >&5
- echo $ECHO_N "checking for IMG_LoadPNG_RW in -lSDL_image... $ECHO_C" >&6