aboutsummaryrefslogtreecommitdiff
path: root/games/crossfire-client
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2002-07-15 21:27:28 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2002-07-15 21:27:28 +0000
commitd8219ccbe398f3de606a2b8debed89bfb8c75ab1 (patch)
treefeb56c5bf1ae012e007ac6c61a0668a5650f42df /games/crossfire-client
parentb0ac884b2c861c350a5cbc97428e7d0bdf3bdd74 (diff)
downloadports-d8219ccbe398f3de606a2b8debed89bfb8c75ab1.tar.gz
ports-d8219ccbe398f3de606a2b8debed89bfb8c75ab1.zip
Update to version 1.3.0
PR: 40621 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Notes
Notes: svn path=/head/; revision=63032
Diffstat (limited to 'games/crossfire-client')
-rw-r--r--games/crossfire-client/Makefile31
-rw-r--r--games/crossfire-client/distinfo3
-rw-r--r--games/crossfire-client/files/patch-configure.in11
-rw-r--r--games/crossfire-client/files/patch-x11::Makefile.in11
-rw-r--r--games/crossfire-client/pkg-plist69
5 files changed, 71 insertions, 54 deletions
diff --git a/games/crossfire-client/Makefile b/games/crossfire-client/Makefile
index cceb050707f7..b57d60be98c7 100644
--- a/games/crossfire-client/Makefile
+++ b/games/crossfire-client/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= crossfire
-PORTVERSION= 1.1.0
+PORTVERSION= 1.3.0
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://ftp.ifi.uio.no/pub/crossfire/ \
@@ -14,32 +14,45 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
MASTER_SITE_SUBDIR= ${PORTNAME}
PKGNAMESUFFIX= -client
DISTFILES= ${PORTNAME}-client-${PORTVERSION}.tar.gz \
- ${PORTNAME}-client-sounds-${PORTVERSION}.tar.gz
+ ${PORTNAME}-client-images-${PORTVERSION}.tar.gz \
+ ${PORTNAME}-client-sounds-1.1.0.tar.gz
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= SDL-1.1.4:${PORTSDIR}/devel/sdl12 \
- png.5:${PORTSDIR}/graphics/png
+BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
+LIB_DEPENDS= SDL_image.10:${PORTSDIR}/graphics/sdl_image
SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
WRKSRC= ${WRKDIR}/${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+
+USE_X_PREFIX= yes
+USE_PERL5= yes
USE_XPM= yes
USE_GTK= yes
+USE_REINPLACE= yes
USE_GMAKE= yes
-USE_X_PREFIX= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
CONFIGURE_ARGS= --with-includes=-I${LOCALBASE}/include \
--with-ldflags=-L${LOCALBASE}/lib \
- --with-sound-dir=${PREFIX}/share/cfclient/sounds \
--disable-gnome # Gnome client currently broken
MAN1= cfclient.1 gcfclient.1
+DATADIR= ${PREFIX}/share/${PKGBASE}
+
+pre-configure:
+ @cd ${WRKSRC} && ${LOCALBASE}/bin/autoconf
+
post-install:
- @${MKDIR} ${PREFIX}/share/cfclient/sounds
- @${INSTALL_DATA} ${WRKDIR}/sounds/*.raw ${WRKDIR}/sounds/README \
- ${PREFIX}/share/cfclient/sounds
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKDIR}/bmaps.client ${DATADIR}
+ ${INSTALL_DATA} ${WRKDIR}/crossfire.base ${DATADIR}
+ ${INSTALL_DATA} ${WRKDIR}/crossfire.clsc ${DATADIR}
+ @${MKDIR} ${DATADIR}/sounds
+ ${INSTALL_DATA} ${WRKDIR}/sounds/README ${DATADIR}/sounds
+ ${INSTALL_DATA} ${WRKDIR}/sounds/*.raw ${DATADIR}/sounds
.include <bsd.port.mk>
diff --git a/games/crossfire-client/distinfo b/games/crossfire-client/distinfo
index bc32fffb2cc0..2c98ad4b714b 100644
--- a/games/crossfire-client/distinfo
+++ b/games/crossfire-client/distinfo
@@ -1,2 +1,3 @@
-MD5 (crossfire-client-1.1.0.tar.gz) = ee6785ad5a0cfa43f8a920528f2a94d4
+MD5 (crossfire-client-1.3.0.tar.gz) = fc4c91bcd66c53e8da8ef13ab9554b04
+MD5 (crossfire-client-images-1.3.0.tar.gz) = d0115d1e429116a42080b48ea8cdfae3
MD5 (crossfire-client-sounds-1.1.0.tar.gz) = f9390112a3cd1788b4c310fc5d53a609
diff --git a/games/crossfire-client/files/patch-configure.in b/games/crossfire-client/files/patch-configure.in
new file mode 100644
index 000000000000..0ba3a1dc01bc
--- /dev/null
+++ b/games/crossfire-client/files/patch-configure.in
@@ -0,0 +1,11 @@
+--- configure.in.orig Tue Jul 2 08:52:54 2002
++++ configure.in Sat Jul 13 04:10:47 2002
+@@ -226,6 +226,8 @@
+ dnl so I'll just assume it is in the same dir as SDL
+ if eval "test x$use_sdl = xyes"; then
+ AM_PATH_SDL(1.1.3)
++ CPPFLAGS="$CPPFLAGS $SDL_CFLAGS"
++ LIBS="$LIBS $SDL_LIBS"
+ if eval "test x$no_sdl = x"; then
+ AC_CHECK_LIB( SDL_image, IMG_LoadPNG_RW,
+ have_sdlimage="yes", have_sdlimage="no", $SDL_CFLAGS)
diff --git a/games/crossfire-client/files/patch-x11::Makefile.in b/games/crossfire-client/files/patch-x11::Makefile.in
deleted file mode 100644
index e601d58100c5..000000000000
--- a/games/crossfire-client/files/patch-x11::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- x11/Makefile.in.orig Wed Jan 30 02:27:36 2002
-+++ x11/Makefile.in Wed Jan 30 02:27:45 2002
-@@ -61,7 +61,7 @@
- install:
- $(INSTALL) -d ${bindir}
- $(INSTALL) -d ${mandir}
-- $(INSTALL) cfclient ${bindir}/gcfclient
-+ $(INSTALL) cfclient ${bindir}/cfclient
- $(INSTALL) cfclient.man ${mandir}/cfclient.1
-
- depend:
diff --git a/games/crossfire-client/pkg-plist b/games/crossfire-client/pkg-plist
index 67dfc1e6960d..161a5d31594f 100644
--- a/games/crossfire-client/pkg-plist
+++ b/games/crossfire-client/pkg-plist
@@ -1,35 +1,38 @@
-bin/cfsndserv
bin/cfclient
+bin/cfsndserv
bin/gcfclient
-share/cfclient/sounds/ouch1.raw
-share/cfclient/sounds/Evil_Laugh.raw
-share/cfclient/sounds/MetalCrash.raw
-share/cfclient/sounds/README
-share/cfclient/sounds/click1.raw
-share/cfclient/sounds/click2.raw
-share/cfclient/sounds/Missed.raw
-share/cfclient/sounds/boink2.raw
-share/cfclient/sounds/chord.raw
-share/cfclient/sounds/Missle1.raw
-share/cfclient/sounds/blip.raw
-share/cfclient/sounds/Explosion.raw
-share/cfclient/sounds/Whoosh.raw
-share/cfclient/sounds/drip.raw
-share/cfclient/sounds/bugle_charge.raw
-share/cfclient/sounds/magic.raw
-share/cfclient/sounds/squish.raw
-share/cfclient/sounds/Creaky-1.raw
-share/cfclient/sounds/TowerClock.raw
-share/cfclient/sounds/Teeswing.raw
-share/cfclient/sounds/swish.raw
-share/cfclient/sounds/Tear.raw
-share/cfclient/sounds/gong.raw
-share/cfclient/sounds/Puke.raw
-share/cfclient/sounds/sci_fi_gun.raw
-share/cfclient/sounds/lightning1.raw
-share/cfclient/sounds/FloorTom.raw
-share/cfclient/sounds/phit2.raw
-share/cfclient/sounds/Gun-5.raw
-share/cfclient/sounds/first_try.raw
-@dirrm share/cfclient/sounds
-@dirrm share/cfclient
+share/crossfire-client/bmaps.client
+share/crossfire-client/crossfire.base
+share/crossfire-client/crossfire.clsc
+share/crossfire-client/sounds/Creaky-1.raw
+share/crossfire-client/sounds/Evil_Laugh.raw
+share/crossfire-client/sounds/Explosion.raw
+share/crossfire-client/sounds/FloorTom.raw
+share/crossfire-client/sounds/Gun-5.raw
+share/crossfire-client/sounds/MetalCrash.raw
+share/crossfire-client/sounds/Missed.raw
+share/crossfire-client/sounds/Missle1.raw
+share/crossfire-client/sounds/Puke.raw
+share/crossfire-client/sounds/README
+share/crossfire-client/sounds/Tear.raw
+share/crossfire-client/sounds/Teeswing.raw
+share/crossfire-client/sounds/TowerClock.raw
+share/crossfire-client/sounds/Whoosh.raw
+share/crossfire-client/sounds/blip.raw
+share/crossfire-client/sounds/boink2.raw
+share/crossfire-client/sounds/bugle_charge.raw
+share/crossfire-client/sounds/chord.raw
+share/crossfire-client/sounds/click1.raw
+share/crossfire-client/sounds/click2.raw
+share/crossfire-client/sounds/drip.raw
+share/crossfire-client/sounds/first_try.raw
+share/crossfire-client/sounds/gong.raw
+share/crossfire-client/sounds/lightning1.raw
+share/crossfire-client/sounds/magic.raw
+share/crossfire-client/sounds/ouch1.raw
+share/crossfire-client/sounds/phit2.raw
+share/crossfire-client/sounds/sci_fi_gun.raw
+share/crossfire-client/sounds/squish.raw
+share/crossfire-client/sounds/swish.raw
+@dirrm share/crossfire-client/sounds
+@dirrm share/crossfire-client