aboutsummaryrefslogtreecommitdiff
path: root/games/ctris
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-09-02 11:56:01 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-09-02 11:56:01 +0000
commita95da093745245f70fb448b25bcb904c59721396 (patch)
treeca6ae0386a6308afe1d7e92d543e5197636932ef /games/ctris
parent4186a585f99833818b1fe398e772784bc013a4d6 (diff)
downloadports-a95da093745245f70fb448b25bcb904c59721396.tar.gz
ports-a95da093745245f70fb448b25bcb904c59721396.zip
Add ctetris, ncurses-bases tetris clone
PR: 70446 Submitted by: Travis Poppe <tlp@LiquidX.org>
Notes
Notes: svn path=/head/; revision=117927
Diffstat (limited to 'games/ctris')
-rw-r--r--games/ctris/Makefile31
-rw-r--r--games/ctris/distinfo2
-rw-r--r--games/ctris/pkg-descr8
3 files changed, 41 insertions, 0 deletions
diff --git a/games/ctris/Makefile b/games/ctris/Makefile
new file mode 100644
index 000000000000..b807e0a5cd9e
--- /dev/null
+++ b/games/ctris/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ctetris
+# Date created: 14 Aug 2004
+# Whom: Travis Poppe <tlp@liquidx.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ctetris
+PORTVERSION= 0.26
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= tlp@liquidx.org
+COMMENT= Beautiful tetris clone written in C using the ncurses library
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+
+MAN1= ctetris.1
+PLIST_FILES= bin/ctetris
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|termio.h|termios.h|' ${WRKSRC}/ctetris.h
+
+do-install:
+ ${INSTALL_MAN} ${WRKSRC}/ctetris.1 ${PREFIX}/man/man1/ctetris.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/ctetris ${PREFIX}/bin/ctetris
+
+.include <bsd.port.mk>
diff --git a/games/ctris/distinfo b/games/ctris/distinfo
new file mode 100644
index 000000000000..09822a8b4d5e
--- /dev/null
+++ b/games/ctris/distinfo
@@ -0,0 +1,2 @@
+MD5 (ctetris-0.26.tar.bz2) = 668db063b4e3aa45ce2e002ce38d38e6
+SIZE (ctetris-0.26.tar.bz2) = 13000
diff --git a/games/ctris/pkg-descr b/games/ctris/pkg-descr
new file mode 100644
index 000000000000..298e7502b1f5
--- /dev/null
+++ b/games/ctris/pkg-descr
@@ -0,0 +1,8 @@
+ctetris is a beautiful tetris clone, written in C using the ncurses
+library. It works very fast and efficient, so it should be possible to
+play it even over a slow remote terminal.
+
+WWW: http://www.sourceforge.com/projects/ctetris/
+
+- Travis Poppe
+tlp@liquidx.org