aboutsummaryrefslogtreecommitdiff
path: root/games/deng
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-09-24 20:10:31 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-09-24 20:10:31 +0000
commit92192c4cd97e3f16aad3b9b7187da523470b4a41 (patch)
tree4fe26fcf663f0459e3918bd29fe39159f1ac5a5f /games/deng
parent3f893dd28bc22cece6539888597ad7c92e01b3f3 (diff)
downloadports-92192c4cd97e3f16aad3b9b7187da523470b4a41.tar.gz
ports-92192c4cd97e3f16aad3b9b7187da523470b4a41.zip
Fix a dependency, do some cleaning, and unbreak.
PR: ports/72002 Submitted by: maintainer Approved by: portmgr (marcus).
Notes
Notes: svn path=/head/; revision=118378
Diffstat (limited to 'games/deng')
-rw-r--r--games/deng/Makefile15
-rw-r--r--games/deng/pkg-plist14
2 files changed, 6 insertions, 23 deletions
diff --git a/games/deng/Makefile b/games/deng/Makefile
index 6eb1bff5165f..b9179cfd7ef9 100644
--- a/games/deng/Makefile
+++ b/games/deng/Makefile
@@ -14,28 +14,25 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ip@doom.homeunix.org
COMMENT= An enhanced Doom, Heretic and Hexen source port
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
RUN_DEPENDS= ${LOCALBASE}/bin/timidity:${PORTSDIR}/audio/timidity
-BROKEN= Missing dependency
-
USE_REINPLACE= yes
REINPLACE_ARGS= -i ""
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER= 15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CFLAGS="${CFLAGS} `${SDL_CONFIG} --cflags` -I${LOCALBASE}/include -I${X11BASE}/include" \
CPPFLAGS="`${SDL_CONFIG} --cflags` -I${LOCALBASE}/include -I${X11BASE}/include"
USE_SDL= sdl mixer net
USE_GL= yes
INSTALLS_SHLIB= yes
+NOT_FOR_ARCHS= amd64
PKGMESSAGE= ${WRKDIR}/pkg-message
-.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/lib/libopenal.so.0)
+.if exists(${LOCALBASE}/lib/libopenal.so.0) || defined(WITH_OPENAL)
WITH_OPENAL= yes
-BUILD_DEPENDS= ${LOCALBASE}/lib/libopenal.so.0:${PORTSDIR}/audio/openal
-RUN_DEPENDS= ${LOCALBASE}/lib/libopenal.so.0:${PORTSDIR}/audio/openal
+LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal
.endif
.if !defined(WITH_OPENAL)
@@ -69,4 +66,4 @@ post-install:
@(${SED} -e 's|%%PREFIX%%|${PREFIX}|; s|%%DOCSDIR%%|${DOCSDIR}|' \
<pkg-message >${PKGMESSAGE} && ${CAT} ${PKGMESSAGE})
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/deng/pkg-plist b/games/deng/pkg-plist
index 6fa206bce103..e673d72b57e3 100644
--- a/games/deng/pkg-plist
+++ b/games/deng/pkg-plist
@@ -1,34 +1,20 @@
bin/doomsday
lib/libdpdehread.a
-lib/libdpdehread.la
lib/libdpdehread.so
lib/libdpdehread.so.0
lib/libdpmapload.a
-lib/libdpmapload.la
lib/libdpmapload.so
lib/libdpmapload.so.0
-lib/libdropengl.a
-lib/libdropengl.la
lib/libdropengl.so
lib/libdropengl.so.0
-%%WITH_OPENAL%%lib/libdsopenal.a
-%%WITH_OPENAL%%lib/libdsopenal.la
%%WITH_OPENAL%%lib/libdsopenal.so
%%WITH_OPENAL%%lib/libdsopenal.so.0
-lib/libdssdlmixer.a
-lib/libdssdlmixer.la
lib/libdssdlmixer.so
lib/libdssdlmixer.so.0
-lib/libjdoom.a
-lib/libjdoom.la
lib/libjdoom.so
lib/libjdoom.so.0
-lib/libjheretic.a
-lib/libjheretic.la
lib/libjheretic.so
lib/libjheretic.so.0
-lib/libjhexen.a
-lib/libjhexen.la
lib/libjhexen.so
lib/libjhexen.so.0
%%DATADIR%%/Data/Doomsday.wad