aboutsummaryrefslogtreecommitdiff
path: root/games/doom-data
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-12-09 11:19:52 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-12-09 11:19:52 +0000
commit342bb086da78036bd9a86265559c6686653abb6d (patch)
tree42969c4c5e71d3a78b6ff4061678ba2ec71a99d0 /games/doom-data
parent97f3c7b77643bc11665d46eed785facbb344b036 (diff)
downloadports-342bb086da78036bd9a86265559c6686653abb6d.tar.gz
ports-342bb086da78036bd9a86265559c6686653abb6d.zip
- Changed doom-data/Makefile.include to be more similar to bsd.*.mk files,
also it doesn't override port's variables. - Change dependant ports PR: ports/90123 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=150716
Diffstat (limited to 'games/doom-data')
-rw-r--r--games/doom-data/Makefile2
-rw-r--r--games/doom-data/Makefile.include51
2 files changed, 23 insertions, 30 deletions
diff --git a/games/doom-data/Makefile b/games/doom-data/Makefile
index 4a3e9c9b5042..521ae5554a4a 100644
--- a/games/doom-data/Makefile
+++ b/games/doom-data/Makefile
@@ -9,6 +9,7 @@ PORTNAME= data
PORTVERSION= 1.0
CATEGORIES= games
MASTER_SITES= http://www.ijs.si/~lesi/distfiles/doom/
+PKGNAMEPREFIX= ${DMPKGNAMEPREFIX}
EXTRACT_SUFX= .bz2
DISTFILES= #
DIST_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
@@ -29,6 +30,7 @@ SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}
+DATADIR= ${DMDIR}
LIST= DOOM HERETIC HEXEN STRIFE
diff --git a/games/doom-data/Makefile.include b/games/doom-data/Makefile.include
index 56fbf31b7dcc..9e40dcf3489f 100644
--- a/games/doom-data/Makefile.include
+++ b/games/doom-data/Makefile.include
@@ -1,42 +1,33 @@
# Makefile for defining variables used by other Doom related ports.
-# Determine if the port is a Doom engine.
+# Set variables.
-DMENGINES= deng doom doomlegacy prboom vavoom
+DMPKGNAMEPREFIX?=doom-
+DMDIR?= ${LOCALBASE}/share/doom
-.for f in ${DMENGINES}
-. if ${PORTNAME} == ${f}
-ENGINE= yes
-. endif
-.endfor
-
-# Package name prefix.
+# Add them to the environment.
-DMPKGNAMEPREFIX=doom-
-
-.if !defined(ENGINE)
-PKGNAMEPREFIX?= ${DMPKGNAMEPREFIX}
-.endif
+MAKE_ENV+= DMDIR="${DMDIR}"
+PLIST_SUB+= DMDIR="${DMDIR:S/${LOCALBASE}\///}"
+SUB_LIST+= DMDIR="${DMDIR}"
-# Dependency to "games/doom-data".
+# Add the dependency.
.if ${PORTNAME} != "data"
RUN_DEPENDS+= ${DMDIR}:${PORTSDIR}/games/doom-data
.endif
-# Installation directories.
-
-DMDIR= ${PREFIX}/share/doom
-
-.if ${PORTNAME} == "data"
-DATADIR?= ${DMDIR}
-.endif
-
-.if ${PORTNAME} != "data" && !defined(ENGINE)
-DATADIR?= ${DMDIR}/${PORTNAME}
+# DOS to Unix text conversion.
+
+.if defined(USE_CRLF)
+. if defined(USE_ZIP)
+EXTRACT_BEFORE_ARGS= -aqo
+. else
+USE_REINPLACE= yes
+pre-patch:
+ @${FIND} ${WRKDIR} -type f -print0 | \
+ ${XARGS} -0 ${FILE} | ${GREP} 'CRLF' | \
+ ${SED} -e "s/:.*//" | ${SED} -e 's/ /\\ /g' | \
+ ${XARGS} ${REINPLACE_CMD} -i "" -e "s/`${PRINTF} '\r'`$$//"
+. endif
.endif
-
-DOCSDIR?= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-
-PLIST_SUB+= DMDIR="${DMDIR:S/${PREFIX}\///}"
-SUB_LIST+= DMDIR="${DMDIR}"