aboutsummaryrefslogtreecommitdiff
path: root/games/dopewars
diff options
context:
space:
mode:
authorJim Mock <jim@FreeBSD.org>2001-06-18 18:52:52 +0000
committerJim Mock <jim@FreeBSD.org>2001-06-18 18:52:52 +0000
commit63f70b3c2b713ff9fdc25c33cfb0711566cd5d89 (patch)
tree10e0da7aa82b8c28528bad064f2bb49f06aac7a0 /games/dopewars
parent37058febef55145935df6d9d5044a86fb2d08b4f (diff)
downloadports-63f70b3c2b713ff9fdc25c33cfb0711566cd5d89.tar.gz
ports-63f70b3c2b713ff9fdc25c33cfb0711566cd5d89.zip
Update to version 1.5.0. This application now uses GTK (oh, happy joy).
Notes
Notes: svn path=/head/; revision=44184
Diffstat (limited to 'games/dopewars')
-rw-r--r--games/dopewars/Makefile13
-rw-r--r--games/dopewars/distinfo2
-rw-r--r--games/dopewars/files/patch-aa29
-rw-r--r--games/dopewars/files/patch-ab14
-rw-r--r--games/dopewars/files/patch-ac22
-rw-r--r--games/dopewars/pkg-install9
-rw-r--r--games/dopewars/pkg-plist28
7 files changed, 38 insertions, 79 deletions
diff --git a/games/dopewars/Makefile b/games/dopewars/Makefile
index b102e6f0c36b..261bf93b577e 100644
--- a/games/dopewars/Makefile
+++ b/games/dopewars/Makefile
@@ -6,20 +6,19 @@
#
PORTNAME= dopewars
-PORTVERSION= 1.4.8
-PORTREVISION= 1
+PORTVERSION= 1.5.0
CATEGORIES= games
-MASTER_SITES= http://bellatrix.pcl.ox.ac.uk/~ben/dopewars/
+MASTER_SITES= http://dopewars.sourceforge.net/ \
+ http://bellatrix.pcl.ox.ac.uk/~ben/dopewars/
MAINTAINER= jim@FreeBSD.org
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_GTK= yes
+USE_X_PREFIX= yes
-pre-fetch:
-.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
- ${SH} pkg-install
-.endif
+CONFIGURE_ARGS= --enable-nls
post-install:
@${ECHO} "===> Documentation is installed in ${PREFIX}/share/doc/dopewars"
diff --git a/games/dopewars/distinfo b/games/dopewars/distinfo
index b118ca655425..1356ecde5ccb 100644
--- a/games/dopewars/distinfo
+++ b/games/dopewars/distinfo
@@ -1 +1 @@
-MD5 (dopewars-1.4.8.tar.gz) = c88fa5475e05d2162661b5f3200b21e9
+MD5 (dopewars-1.5.0.tar.gz) = 0914387302dc7abee50f28715e9d7807
diff --git a/games/dopewars/files/patch-aa b/games/dopewars/files/patch-aa
index 97385084e805..e7dad8f8494e 100644
--- a/games/dopewars/files/patch-aa
+++ b/games/dopewars/files/patch-aa
@@ -1,20 +1,11 @@
---- Makefile.am.orig Mon Jan 10 18:07:57 2000
-+++ Makefile.am Fri Jan 14 16:30:09 2000
-@@ -2,7 +2,7 @@
- dopewars_SOURCES = AIPlayer.c serverside.c clientside.c dopewars.c message.c \
- dopeos.c
-
--DOCPATH=/usr/doc/${PACKAGE}-${VERSION}/
-+DOCPATH=${LOCALBASE}/share/doc/${PACKAGE}
- DOCS= aiplayer.html configfile.html index.html server.html clientplay.html \
- credits.html installation.html servercommands.html commandline.html \
- developer.html metaserver.html windows.html README
-@@ -15,6 +15,6 @@
- touch ${datadir}/dopewars.sco
- chown root.games ${datadir}/dopewars.sco
- chmod 0660 ${datadir}/dopewars.sco
-- ${INSTALL} -d -o root -g root -m 0755 $(DOCPATH)
-- ${INSTALL} -o root -g root -m 0644 $(DOCS) $(DOCPATH)
-+ ${INSTALL} -d -o root -g wheel -m 0755 $(DOCPATH)
-+ ${INSTALL} -o root -g wheel -m 0644 $(DOCS) $(DOCPATH)
+--- Makefile.am.orig Mon Jun 18 14:30:07 2001
++++ Makefile.am Mon Jun 18 14:30:59 2001
+@@ -5,7 +5,6 @@
+ install-data-local:
+ ${mkinstalldirs} ${DESTDIR}${datadir}
+ touch ${DESTDIR}${datadir}/dopewars.sco
+- chown root:games ${DESTDIR}${datadir}/dopewars.sco || \
+- chown root:wheel ${DESTDIR}${datadir}/dopewars.sco
++ chown root:wheel ${DESTDIR}${datadir}/dopewars.sco
+ chmod 0660 ${DESTDIR}${datadir}/dopewars.sco
diff --git a/games/dopewars/files/patch-ab b/games/dopewars/files/patch-ab
index 0d7a6364f3f8..cc53fcb1cad1 100644
--- a/games/dopewars/files/patch-ab
+++ b/games/dopewars/files/patch-ab
@@ -1,10 +1,10 @@
---- dopeos.h.orig Fri Jan 14 16:13:24 2000
-+++ dopeos.h Fri Jan 14 16:14:40 2000
-@@ -127,6 +127,7 @@
- #else /* Definitions for Unix build */
+--- src/dopeos.h.orig Mon Jun 18 14:31:50 2001
++++ src/dopeos.h Mon Jun 18 14:32:17 2001
+@@ -31,6 +31,7 @@
+ #include <string.h>
#if NETWORKING
+#include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
+ #include <winsock.h>
+ #endif
+
diff --git a/games/dopewars/files/patch-ac b/games/dopewars/files/patch-ac
deleted file mode 100644
index 1fd08c53153c..000000000000
--- a/games/dopewars/files/patch-ac
+++ /dev/null
@@ -1,22 +0,0 @@
---- Makefile.in.orig Thu Jan 13 15:58:16 2000
-+++ Makefile.in Fri Jan 28 00:24:48 2000
-@@ -66,7 +66,7 @@
- dopewars_SOURCES = AIPlayer.c serverside.c clientside.c dopewars.c message.c dopeos.c
-
-
--DOCPATH = /usr/doc/${PACKAGE}-${VERSION}/
-+DOCPATH = ${PREFIX}/share/doc/${PACKAGE}/
- DOCS = aiplayer.html configfile.html index.html server.html clientplay.html credits.html installation.html servercommands.html commandline.html developer.html metaserver.html windows.html README
-
- ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
-@@ -400,8 +400,8 @@
- touch ${datadir}/dopewars.sco
- chown root.games ${datadir}/dopewars.sco
- chmod 0660 ${datadir}/dopewars.sco
-- ${INSTALL} -d -o root -g root -m 0755 $(DOCPATH)
-- ${INSTALL} -o root -g root -m 0644 $(DOCS) $(DOCPATH)
-+ ${INSTALL} -d -m 0755 $(DOCPATH)
-+ ${INSTALL} -m 0644 $(DOCS) $(DOCPATH)
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/games/dopewars/pkg-install b/games/dopewars/pkg-install
deleted file mode 100644
index 47b307353295..000000000000
--- a/games/dopewars/pkg-install
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-
-if [ "$2" = "POST-INSTALL" -o -n "${PACKAGE_BUILDING}" ]; then
- exit 0
-fi
-
-/usr/bin/dialog --yesno "SECURITY NOTE: This software contains known locally-exploitable buffer overflows. However since the binaries in question are setgid to the games group, the impact of this vulnerability is believed to be limited to the ability for local users to overwrite score files, saved games, and certain other game data for this and other installed game packages. The wider system security is not believed to be compromised by this problem. Do you wish to install the software anyway?" 12 70 || /usr/bin/false
-
-
diff --git a/games/dopewars/pkg-plist b/games/dopewars/pkg-plist
index 40da08c49cbd..33797ecac07e 100644
--- a/games/dopewars/pkg-plist
+++ b/games/dopewars/pkg-plist
@@ -1,16 +1,16 @@
bin/dopewars
-share/doc/dopewars/README
-share/doc/dopewars/aiplayer.html
-share/doc/dopewars/clientplay.html
-share/doc/dopewars/commandline.html
-share/doc/dopewars/configfile.html
-share/doc/dopewars/credits.html
-share/doc/dopewars/developer.html
-share/doc/dopewars/index.html
-share/doc/dopewars/installation.html
-share/doc/dopewars/metaserver.html
-share/doc/dopewars/server.html
-share/doc/dopewars/servercommands.html
-share/doc/dopewars/windows.html
+share/doc/dopewars-1.5.0/aiplayer.html
+share/doc/dopewars-1.5.0/clientplay.html
+share/doc/dopewars-1.5.0/commandline.html
+share/doc/dopewars-1.5.0/configfile.html
+share/doc/dopewars-1.5.0/credits.html
+share/doc/dopewars-1.5.0/developer.html
+share/doc/dopewars-1.5.0/i18n.html
+share/doc/dopewars-1.5.0/index.html
+share/doc/dopewars-1.5.0/installation.html
+share/doc/dopewars-1.5.0/metaserver.html
+share/doc/dopewars-1.5.0/server.html
+share/doc/dopewars-1.5.0/servercommands.html
+share/doc/dopewars-1.5.0/windows.html
share/dopewars.sco
-@dirrm share/doc/dopewars
+@dirrm share/doc/dopewars-1.5.0