aboutsummaryrefslogtreecommitdiff
path: root/games/dopewars
diff options
context:
space:
mode:
authorJim Mock <jim@FreeBSD.org>2000-01-15 00:55:06 +0000
committerJim Mock <jim@FreeBSD.org>2000-01-15 00:55:06 +0000
commit913a8a7ca35a532d235b6da28bda9de16e27b434 (patch)
treea4e48ff6411c0ff23bd2af1b58ca532af894f495 /games/dopewars
parent49214767b76f3f7751c601a35092e96a345317dc (diff)
downloadports-913a8a7ca35a532d235b6da28bda9de16e27b434.tar.gz
ports-913a8a7ca35a532d235b6da28bda9de16e27b434.zip
Update to version 1.4.7
Notes
Notes: svn path=/head/; revision=24752
Diffstat (limited to 'games/dopewars')
-rw-r--r--games/dopewars/Makefile16
-rw-r--r--games/dopewars/distinfo2
-rw-r--r--games/dopewars/files/patch-aa47
-rw-r--r--games/dopewars/files/patch-ab10
4 files changed, 28 insertions, 47 deletions
diff --git a/games/dopewars/Makefile b/games/dopewars/Makefile
index ce244f383977..0430ccd28f91 100644
--- a/games/dopewars/Makefile
+++ b/games/dopewars/Makefile
@@ -1,30 +1,22 @@
# New ports collection makefile for: dopewars
-# Version required: 1.4.6
+# Version required: 1.4.7
# Date created: 16 May 1999
# Whom: Jim Mock <jim@FreeBSD.org>
#
# $FreeBSD$
#
-DISTNAME= dopewars-1.4.6
+DISTNAME= dopewars-1.4.7
CATEGORIES= games
MASTER_SITES= http://bellatrix.pcl.ox.ac.uk/~ben/dopewars/
MAINTAINER= jim@FreeBSD.org
USE_GMAKE= yes
-
-do-build:
- @(cd ${WRKSRC} && ${GMAKE})
-
-do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/dopewars ${PREFIX}/bin
+GNU_CONFIGURE= yes
post-install:
- @${ECHO} "===> Installing documentation into ${PREFIX}/share/doc/dopewars"
- @${MKDIR} ${PREFIX}/share/doc/dopewars && ${CHMOD} a+rx ${PREFIX}/share/doc/dopewars
- @${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/dopewars
- @${INSTALL_DATA} ${WRKSRC}/*.html ${PREFIX}/share/doc/dopewars
+ @${ECHO} "===> Documentation is installed in ${PREFIX}/share/doc/dopewars"
@${ECHO} "===> Run 'dopewars -h' for usage options."
.include <bsd.port.mk>
diff --git a/games/dopewars/distinfo b/games/dopewars/distinfo
index 49c70cccbfad..5d536142b46d 100644
--- a/games/dopewars/distinfo
+++ b/games/dopewars/distinfo
@@ -1 +1 @@
-MD5 (dopewars-1.4.6.tar.gz) = 6c839b1001eb0d7ccb748e481827f70a
+MD5 (dopewars-1.4.7.tar.gz) = 6d5af1e1093158608f1f0895e77a4ccd
diff --git a/games/dopewars/files/patch-aa b/games/dopewars/files/patch-aa
index 755a0f11a579..97385084e805 100644
--- a/games/dopewars/files/patch-aa
+++ b/games/dopewars/files/patch-aa
@@ -1,31 +1,20 @@
---- Makefile.orig Thu Nov 11 15:54:12 1999
-+++ Makefile Fri Dec 3 12:22:35 1999
-@@ -1,10 +1,10 @@
--CFLAGS = -Wall
--CC = gcc
-+iCFLAGS ?= -Wall
-+CC ?= gcc
- HEADERS = message.h dopewars.h serverside.h clientside.h AIPlayer.h dopeos.h
- OBJS = message.o dopewars.o serverside.o clientside.o AIPlayer.o dopeos.o
- LIBS = -lncurses
- VERSION = 1.4.6
--DOCPATH = /usr/doc/dopewars-$(VERSION)
-+DOCPATH = ${LOCALBASE}/share/doc/dopewars-$(VERSION)
- DOCS = index.html installation.html clientplay.html server.html credits.html \
- aiplayer.html configfile.html commandline.html developer.html \
- metaserver.html servercommands.html \
-@@ -32,14 +32,6 @@
+--- Makefile.am.orig Mon Jan 10 18:07:57 2000
++++ Makefile.am Fri Jan 14 16:30:09 2000
+@@ -2,7 +2,7 @@
+ dopewars_SOURCES = AIPlayer.c serverside.c clientside.c dopewars.c message.c \
+ dopeos.c
- dopeos.o : dopeos.c $(HEADERS)
- $(CC) $(CFLAGS) -c dopeos.c
--
--install : all
-- install -o root -g games -m 2755 dopewars /usr/bin/dopewars
-- touch /var/lib/games/dopewars.sco
-- chown root.games /var/lib/games/dopewars.sco
-- chmod 0660 /var/lib/games/dopewars.sco
-- install -d -o root -g root -m 0755 $(DOCPATH)
-- install -o root -g root -m 0644 $(DOCS) $(DOCPATH)
+-DOCPATH=/usr/doc/${PACKAGE}-${VERSION}/
++DOCPATH=${LOCALBASE}/share/doc/${PACKAGE}
+ DOCS= aiplayer.html configfile.html index.html server.html clientplay.html \
+ credits.html installation.html servercommands.html commandline.html \
+ developer.html metaserver.html windows.html README
+@@ -15,6 +15,6 @@
+ touch ${datadir}/dopewars.sco
+ chown root.games ${datadir}/dopewars.sco
+ chmod 0660 ${datadir}/dopewars.sco
+- ${INSTALL} -d -o root -g root -m 0755 $(DOCPATH)
+- ${INSTALL} -o root -g root -m 0644 $(DOCS) $(DOCPATH)
++ ${INSTALL} -d -o root -g wheel -m 0755 $(DOCPATH)
++ ${INSTALL} -o root -g wheel -m 0644 $(DOCS) $(DOCPATH)
- clean :
- rm -f $(OBJS)
diff --git a/games/dopewars/files/patch-ab b/games/dopewars/files/patch-ab
index 4e19e1d76d54..0d7a6364f3f8 100644
--- a/games/dopewars/files/patch-ab
+++ b/games/dopewars/files/patch-ab
@@ -1,9 +1,9 @@
---- dopeunix.h.orig Fri Dec 3 12:19:36 1999
-+++ dopeunix.h Fri Dec 3 12:19:54 1999
-@@ -22,6 +22,7 @@
+--- dopeos.h.orig Fri Jan 14 16:13:24 2000
++++ dopeos.h Fri Jan 14 16:14:40 2000
+@@ -127,6 +127,7 @@
+ #else /* Definitions for Unix build */
- #ifndef __DOPEOS_H__
- #define __DOPEOS_H__
+ #if NETWORKING
+#include <sys/types.h>
#include <sys/socket.h>
#include <netinet/in.h>