aboutsummaryrefslogtreecommitdiff
path: root/games/easyrpg-player
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-11 15:45:03 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-09-11 15:45:03 +0000
commit9d150766ec65036acb7b8a7f11d72de54e8058de (patch)
treef1bf42aafbfce446bdc1945d0d6b3a5126b85032 /games/easyrpg-player
parente3b403395fc97784ab14fc42a4e0f572a515cd92 (diff)
downloadports-9d150766ec65036acb7b8a7f11d72de54e8058de.tar.gz
ports-9d150766ec65036acb7b8a7f11d72de54e8058de.zip
EasyRPG Player is a game interpreter to play RPG Maker 2000, 2003
and EasyRPG games. It uses the LCF parser library (liblcf) to read RPG Maker game data. EasyRPG Player is part of the EasyRPG Project. WWW: https://easyrpg.org/
Notes
Notes: svn path=/head/; revision=421828
Diffstat (limited to 'games/easyrpg-player')
-rw-r--r--games/easyrpg-player/Makefile41
-rw-r--r--games/easyrpg-player/distinfo5
-rw-r--r--games/easyrpg-player/files/patch-src_font.cpp20
-rw-r--r--games/easyrpg-player/pkg-descr7
-rw-r--r--games/easyrpg-player/pkg-plist2
5 files changed, 75 insertions, 0 deletions
diff --git a/games/easyrpg-player/Makefile b/games/easyrpg-player/Makefile
new file mode 100644
index 000000000000..9122cdb9bb4b
--- /dev/null
+++ b/games/easyrpg-player/Makefile
@@ -0,0 +1,41 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= easyrpg-player
+PORTVERSION= 0.3.2
+CATEGORIES= games
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= RPG Maker 2000/2003 and EasyRPG games interpreter
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libfreetype.so:print/freetype2 \
+ libpng.so:graphics/png \
+ liblcf.so:games/liblcf
+BUILD_DEPENDS= asciidoc:textproc/asciidoc \
+ ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
+
+BROKEN_FreeBSD_9= does not build
+
+USE_GITHUB= yes
+GH_ACCOUNT= EasyRPG
+GH_PROJECT= Player
+
+USES= autoreconf gmake libtool localbase pkgconfig
+GNU_CONFIGURE= yes
+USE_XORG= pixman
+USE_SDL= sdl2 mixer2
+
+PORTDOCS= AUTHORS README
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
+.endfor
+
+.include <bsd.port.mk>
diff --git a/games/easyrpg-player/distinfo b/games/easyrpg-player/distinfo
new file mode 100644
index 000000000000..4a82f0dcf66d
--- /dev/null
+++ b/games/easyrpg-player/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1471883564
+SHA256 (EasyRPG-Player-0.3.2_GH0.tar.gz) = ef9c751521930890eb8dab9f7fa40b6614c47ec3aa2e72b7bd4d6c4e162b9449
+SIZE (EasyRPG-Player-0.3.2_GH0.tar.gz) = 1349856
+SHA256 (EasyRPG-liblcf-0.3.2_GH0.tar.gz) = cf98a43f3f10047bf51e92a472bae2904eb61eb7d9495130e17857324047f529
+SIZE (EasyRPG-liblcf-0.3.2_GH0.tar.gz) = 141239
diff --git a/games/easyrpg-player/files/patch-src_font.cpp b/games/easyrpg-player/files/patch-src_font.cpp
new file mode 100644
index 000000000000..508f1c616feb
--- /dev/null
+++ b/games/easyrpg-player/files/patch-src_font.cpp
@@ -0,0 +1,20 @@
+--- src/font.cpp.orig 2015-09-14 09:52:35 UTC
++++ src/font.cpp
+@@ -145,7 +145,7 @@ BitmapRef ShinonomeFont::Glyph(unsigned
+ assert(glyph);
+ size_t const width = glyph->is_full? FULL_WIDTH : HALF_WIDTH;
+
+- BitmapRef bm = Bitmap::Create(reinterpret_cast<void*>(NULL), width, HEIGHT, 0, DynamicFormat(8,8,0,8,0,8,0,8,0,PF::Alpha));
++ BitmapRef bm = Bitmap::Create(nullptr, width, HEIGHT, 0, DynamicFormat(8,8,0,8,0,8,0,8,0,PF::Alpha));
+ uint8_t* data = reinterpret_cast<uint8_t*>(bm->pixels());
+ int pitch = bm->pitch();
+ for(size_t y_ = 0; y_ < HEIGHT; ++y_)
+@@ -194,7 +194,7 @@ BitmapRef FTFont::Glyph(unsigned glyph)
+ int const width = ft_bitmap.width;
+ int const height = ft_bitmap.rows;
+
+- BitmapRef bm = Bitmap::Create(reinterpret_cast<void*>(NULL), width, height, 0, DynamicFormat(8,8,0,8,0,8,0,8,0,PF::Alpha));
++ BitmapRef bm = Bitmap::Create(nullptr, width, height, 0, DynamicFormat(8,8,0,8,0,8,0,8,0,PF::Alpha));
+ uint8_t* data = reinterpret_cast<uint8_t*>(bm->pixels());
+ int dst_pitch = bm->pitch();
+
diff --git a/games/easyrpg-player/pkg-descr b/games/easyrpg-player/pkg-descr
new file mode 100644
index 000000000000..177f33cfa6f2
--- /dev/null
+++ b/games/easyrpg-player/pkg-descr
@@ -0,0 +1,7 @@
+EasyRPG Player is a game interpreter to play RPG Maker 2000, 2003
+and EasyRPG games. It uses the LCF parser library (liblcf) to read
+RPG Maker game data.
+
+EasyRPG Player is part of the EasyRPG Project.
+
+WWW: https://easyrpg.org/
diff --git a/games/easyrpg-player/pkg-plist b/games/easyrpg-player/pkg-plist
new file mode 100644
index 000000000000..4a84760d2030
--- /dev/null
+++ b/games/easyrpg-player/pkg-plist
@@ -0,0 +1,2 @@
+bin/easyrpg-player
+man/man6/easyrpg-player.6.gz