aboutsummaryrefslogtreecommitdiff
path: root/games/eboard/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-02-11 02:00:35 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-02-11 02:00:35 +0000
commit9390a0bd481c907f61fd02e8cf234224bb0feae9 (patch)
tree0d816d54a129d8402e99c017f962a2914ce1a3e3 /games/eboard/Makefile
parentc84f8e8dd0c02a68d40bc680318c4bff5f78cec1 (diff)
downloadports-9390a0bd481c907f61fd02e8cf234224bb0feae9.tar.gz
ports-9390a0bd481c907f61fd02e8cf234224bb0feae9.zip
- Add a desktop entry
- Fix configure script; we have TCP_NODELAY - Remove useless patch PR: ports/92025 Submitted by: jylefort Approved by: maintainer timeout (23 days)
Notes
Notes: svn path=/head/; revision=155688
Diffstat (limited to 'games/eboard/Makefile')
-rw-r--r--games/eboard/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/games/eboard/Makefile b/games/eboard/Makefile
index e4635d1c3af3..efb2578d1e72 100644
--- a/games/eboard/Makefile
+++ b/games/eboard/Makefile
@@ -7,7 +7,7 @@
PORTNAME= eboard
PORTVERSION= 0.9.5
-PORTREVISION= 1
+PORTREVISION= 2
EXTRAS= 1pl2 2
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -29,6 +29,13 @@ INSTALL_TARGET= install install-man
MAN1= eboard-config.1 eboard-addtheme.1
MAN6= eboard.6
+DESKTOP_ENTRIES="eboard" \
+ "Play chess" \
+ "eboard.xpm" \
+ "eboard" \
+ "Application;Game;" \
+ false
+
post-patch:
@${REINPLACE_CMD} -e 's,g++,${CXX},' -e 's,-O6,${CXXFLAGS},' \
${WRKSRC}/configure
@@ -46,5 +53,7 @@ post-install:
@cd ${WRKDIR}/eboard-extras-${extra} && ./${CONFIGURE_SCRIPT} --prefix=${PREFIX}
@cd ${WRKDIR}/eboard-extras-${extra} && ${SETENV} ${MAKE_ENV} ${MAKE} install
.endfor
+ ${MKDIR} ${PREFIX}/share/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/icon-eboard.xpm ${PREFIX}/share/pixmaps/eboard.xpm
.include <bsd.port.mk>