aboutsummaryrefslogtreecommitdiff
path: root/games/eduke32
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-03 12:16:42 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-03 12:16:42 +0000
commitf954d1aba37618f793fc112fc566ab7df916f5c1 (patch)
treea0f6e3c784cab13407f439b9d8d6be68b4a90807 /games/eduke32
parent6090a2829b3e371fb9845189ba9a81c1e1a911d9 (diff)
downloadports-f954d1aba37618f793fc112fc566ab7df916f5c1.tar.gz
ports-f954d1aba37618f793fc112fc566ab7df916f5c1.zip
- Update to 20080602
- Replace files/patch-Makefile with REINPLACE_CMD - Fix build without libvorbis and co - Add an option to depend on timidity++ instead of timidity, to be in sync with OPTIONS of audio/sdl_mixer PR: 124231 Submitted by: Olivier Smedts <olivier@gid0.org> (maintainer)
Notes
Notes: svn path=/head/; revision=214236
Diffstat (limited to 'games/eduke32')
-rw-r--r--games/eduke32/Makefile21
-rw-r--r--games/eduke32/distinfo6
-rw-r--r--games/eduke32/files/patch-Makefile31
3 files changed, 20 insertions, 38 deletions
diff --git a/games/eduke32/Makefile b/games/eduke32/Makefile
index bd2298cc4f89..7bd448de2fc9 100644
--- a/games/eduke32/Makefile
+++ b/games/eduke32/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= eduke32
-PORTVERSION= 20080206
-PORTREVISION= 1
+PORTVERSION= 20080602
CATEGORIES= games
MASTER_SITES= http://wiki.eduke32.com/stuff/
DISTFILES= ${PORTNAME}_src_${PORTVERSION}${EXTRACT_SUFX}
@@ -21,7 +20,9 @@ USE_GNOME= gtk20
USE_SDL= mixer sdl
WRKSRC= ${WRKDIR}/${PORTNAME}_src_${PORTVERSION}/${PORTNAME}
-OPTIONS= MIDI "Enable MIDI support" on
+OPTIONS= MIDI "Enable MIDI support" On \
+ TIMIDITYPLUS "Use Timidity++ instead of Timidity" Off \
+ VORBIS "Enable Ogg Vorbis support" On
.include "${.CURDIR}/../duke3d-data/Makefile.include"
@@ -31,11 +32,22 @@ OPTIONS= MIDI "Enable MIDI support" on
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
.endif
-.if !defined(WITHOUT_MIDI)
+.if defined(WITH_MIDI)
+.if defined(WITH_TIMIDITYPLUS)
+RUN_DEPENDS+= timidity:${PORTSDIR}/audio/timidity++
+.else
RUN_DEPENDS+= timidity:${PORTSDIR}/audio/timidity
.endif
+.endif
+
+.if defined(WITH_VORBIS)
+LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+.endif
post-patch:
+.if defined(WITHOUT_VORBIS)
+ @${REINPLACE_CMD} -e '/LIBS+= -lvorbis/d' ${WRKSRC}/Makefile
+.endif
.if ${ARCH} != "i386"
@${REINPLACE_CMD} -Ee 's|^(NOASM =).*|\1 1|' ${WRKSRC}/Makefile
.endif
@@ -47,6 +59,7 @@ post-patch:
${WRKSRC}/Makefile \
${WRKSRC}/../build/Makefile \
${WRKSRC}/../build/Makefile.shared
+ @${REINPLACE_CMD} -e 's|LINUX|BSD|' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|/usr/share/games/eduke32|${DN3DDIR}|' \
${WRKSRC}/source/game.c ${WRKSRC}/source/astub.c
diff --git a/games/eduke32/distinfo b/games/eduke32/distinfo
index e39f31399941..28784a727476 100644
--- a/games/eduke32/distinfo
+++ b/games/eduke32/distinfo
@@ -1,3 +1,3 @@
-MD5 (eduke32_src_20080206.zip) = 2706f66ea5a043e5020a6b5960c72594
-SHA256 (eduke32_src_20080206.zip) = a1d0d3fb47cb1eb21f5a299bc257ca0edb0ae91c6b7491690017418220825027
-SIZE (eduke32_src_20080206.zip) = 1523615
+MD5 (eduke32_src_20080602.zip) = c478f1f98c1ac57844604a1ba8c98997
+SHA256 (eduke32_src_20080602.zip) = 0b98ef85548015f199a4253521f1bc82d80f63977b5b94fbaf55924b912950ab
+SIZE (eduke32_src_20080602.zip) = 1629666
diff --git a/games/eduke32/files/patch-Makefile b/games/eduke32/files/patch-Makefile
deleted file mode 100644
index 6f2852307785..000000000000
--- a/games/eduke32/files/patch-Makefile
+++ /dev/null
@@ -1,31 +0,0 @@
---- Makefile.orig 2007-10-10 23:28:16.000000000 +0200
-+++ Makefile 2007-10-10 23:30:35.000000000 +0200
-@@ -51,18 +51,18 @@
-
- include $(EROOT)/Makefile.shared
-
--ifeq ($(PLATFORM),LINUX)
-+ifeq ($(PLATFORM),WINDOWS)
-+ OBJ=obj_win
-+ EOBJ=eobj_win
-+else
- OBJ=obj
- EOBJ=eobj
-- NASMFLAGS+= -f elf
--else
-- ifeq ($(PLATFORM),WINDOWS)
-- OBJ=obj_win
-- EOBJ=eobj_win
-- else
-- OBJ=obj
-- EOBJ=eobj
-- endif
-+ ifeq ($(PLATFORM),LINUX)
-+ NASMFLAGS+= -f elf
-+ endif
-+ ifeq ($(PLATFORM),BSD)
-+ NASMFLAGS+= -f elf
-+ endif
- endif
-
- JMACTOBJ=$(OBJ)/util_lib.$o \