aboutsummaryrefslogtreecommitdiff
path: root/games/ember
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2006-09-18 17:31:39 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2006-09-18 17:31:39 +0000
commitfe8896ea52fa0ff5edf88b99b2e5ce86b85960e7 (patch)
treeccfa242c2c3e4793ffe074f10549bceab88fe02a /games/ember
parent0851ff5721b7be4487d00ab4c6186782f661c8ff (diff)
downloadports-fe8896ea52fa0ff5edf88b99b2e5ce86b85960e7.tar.gz
ports-fe8896ea52fa0ff5edf88b99b2e5ce86b85960e7.zip
update ogre3d to 1.2.3
Notes
Notes: svn path=/head/; revision=173342
Diffstat (limited to 'games/ember')
-rw-r--r--games/ember/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/games/ember/Makefile b/games/ember/Makefile
index 9dc2a1b43704..7a686b7c27ff 100644
--- a/games/ember/Makefile
+++ b/games/ember/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= oliver@FreeBSD.org
COMMENT= Ember is a WorldForge 3d client using the OGRE 3d library
LIB_DEPENDS= sigc-2.0:${PORTSDIR}/devel/libsigc++20 \
- OgreMain.11:${PORTSDIR}/graphics/ogre3d \
+ OgreMain.12:${PORTSDIR}/graphics/ogre3d \
eris-1.3:${PORTSDIR}/devel/eris \
varconf-1.0.6:${PORTSDIR}/devel/varconf \
mercator-0.2.4:${PORTSDIR}/devel/mercator \
@@ -31,13 +31,14 @@ USE_GCC= 3.4
USE_X_PREFIX= YES
USE_GNOME= gnomehack
USE_BZIP2= YES
+USE_DOS2UNIX= YES
CPPFLAGS= -DBR_NO_MACROS
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600000
-IGNORE= Does not compile because of inlining error
-.endif
+#.if ${OSVERSION} < 600000
+#IGNORE= Does not compile because of inlining error
+#.endif
post-patch:
@${REINPLACE_CMD} -e '\
@@ -68,6 +69,8 @@ post-patch:
${WRKSRC}/src/services/sound/SoundService.h
@${REINPLACE_CMD} -e 's|@LDFLAGS@|& -lopenal -lalut|' \
${WRKSRC}/src/components/ogre/Makefile.in
+ @${REINPLACE_CMD} '/^[ ]*\*[ ]/d' ${WRKSRC}/src/components/ogre/ogreopcode/opcode/*.cpp ${WRKSRC}/src/components/ogre/ogreopcode/opcode/*.h
+ @${REINPLACE_CMD} -e 's|^[ ]*//.*||g' ${WRKSRC}/src/components/ogre/ogreopcode/opcode/*.cpp ${WRKSRC}/src/components/ogre/ogreopcode/opcode/*.h
.if ${OSVERSION} < 500000
@${REINPLACE_CMD} -e 's|lrintf|(long int)rintf|g' \
${WRKSRC}/src/components/ogre/environment/meshtree/TStem.cpp \