aboutsummaryrefslogtreecommitdiff
path: root/games/empire
diff options
context:
space:
mode:
authorJohn-Mark Gurney <jmg@FreeBSD.org>1997-06-27 09:59:32 +0000
committerJohn-Mark Gurney <jmg@FreeBSD.org>1997-06-27 09:59:32 +0000
commit84b4e15e252e5c7ad0e7937720c3e0acd406b626 (patch)
tree15f19786777ee0f01ceb5cd968418c753d3e4662 /games/empire
parent46f842181b063b46da2d4d6445270da9d12c67c0 (diff)
downloadports-84b4e15e252e5c7ad0e7937720c3e0acd406b626.tar.gz
ports-84b4e15e252e5c7ad0e7937720c3e0acd406b626.zip
import of VMS Empire, a good old strategy game.
Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
Notes
Notes: svn path=/head/; revision=7097
Diffstat (limited to 'games/empire')
-rw-r--r--games/empire/Makefile27
-rw-r--r--games/empire/distinfo1
-rw-r--r--games/empire/files/patch-aa56
-rw-r--r--games/empire/pkg-comment1
-rw-r--r--games/empire/pkg-descr8
-rw-r--r--games/empire/pkg-plist5
6 files changed, 98 insertions, 0 deletions
diff --git a/games/empire/Makefile b/games/empire/Makefile
new file mode 100644
index 000000000000..c5026b7ad63f
--- /dev/null
+++ b/games/empire/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: empire
+# Version required: 1.1
+# Date created: 13 May 1997
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= empire
+PKGNAME= empire-1.1
+CATEGORIES= games
+MASTER_SITES= ftp://locke.ccil.org/pub/esr/
+
+MAINTAINER= andy@icc.surw.chel.su
+
+WRKSRC= ${WRKDIR}/empire-1.1
+MAN6= empire.6
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/empire ${PREFIX}/bin/empire
+ @ ${INSTALL_MAN} ${WRKSRC}/empire.6 ${PREFIX}/man/man6
+ @ ${MKDIR} ${PREFIX}/share/doc/empire
+.for file in BUGS COPYING READ.ME
+ @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/empire/${file}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/games/empire/distinfo b/games/empire/distinfo
new file mode 100644
index 000000000000..62f106eebb0a
--- /dev/null
+++ b/games/empire/distinfo
@@ -0,0 +1 @@
+MD5 (empire.tar.gz) = ab4ef2b7403f184979a5ee164cd90069
diff --git a/games/empire/files/patch-aa b/games/empire/files/patch-aa
new file mode 100644
index 000000000000..80448677d733
--- /dev/null
+++ b/games/empire/files/patch-aa
@@ -0,0 +1,56 @@
+*** ../empire-1.1.orig/Makefile Fri Jun 28 06:27:39 1996
+--- Makefile Fri Jun 27 02:31:13 1997
+***************
+*** 14,25 ****
+ # Change the line below for your system. If you are on a Sun or Vax,
+ # you may want BSD.
+
+! #SYS = BSD
+! SYS = SYSV
+
+ # Use -g to compile the program for debugging.
+
+! DEBUG = -g -DDEBUG
+ #DEBUG = -O
+
+ # Use -p to profile the program.
+--- 14,25 ----
+ # Change the line below for your system. If you are on a Sun or Vax,
+ # you may want BSD.
+
+! SYS = BSD
+! #SYS = SYSV
+
+ # Use -g to compile the program for debugging.
+
+! #DEBUG = -g -DDEBUG
+ #DEBUG = -O
+
+ # Use -p to profile the program.
+***************
+*** 28,39 ****
+
+ # Define all necessary libraries. 'curses' is necessary. 'termcap'
+ # is needed on BSD systems.
+! LIBS = -lncurses
+! #LIBS = -lcurses -ltermcap
+
+ # You shouldn't have to modify anything below this line.
+
+! CFLAGS = $(DEBUG) $(PROFILE) -D$(SYS)
+
+ FILES = \
+ attack.c \
+--- 28,39 ----
+
+ # Define all necessary libraries. 'curses' is necessary. 'termcap'
+ # is needed on BSD systems.
+! #LIBS = -lncurses
+! LIBS = -lcurses
+
+ # You shouldn't have to modify anything below this line.
+
+! CFLAGS+= $(DEBUG) $(PROFILE) -D$(SYS)
+
+ FILES = \
+ attack.c \
diff --git a/games/empire/pkg-comment b/games/empire/pkg-comment
new file mode 100644
index 000000000000..3ca3ca91f69d
--- /dev/null
+++ b/games/empire/pkg-comment
@@ -0,0 +1 @@
+Solitaire empire game `VMS Empire'
diff --git a/games/empire/pkg-descr b/games/empire/pkg-descr
new file mode 100644
index 000000000000..552bd0e949c7
--- /dev/null
+++ b/games/empire/pkg-descr
@@ -0,0 +1,8 @@
+ Apparently, this game was originally written outside of Digital,
+ probably at a university. The game was ported to DEC's VAX/VMS
+ from the TOPS-10/20 FORTRAN sources available around fall 1979.
+ Ed James got hold of the sources at Berkeley and converted
+ portions of the code to C, mostly to use curses for the screen
+ handling. He published his modified sources on the net in
+ December 1986. Because this game ran on VMS machines for so
+ long, a previous version is known as VMS Empire.
diff --git a/games/empire/pkg-plist b/games/empire/pkg-plist
new file mode 100644
index 000000000000..9f2d35255bc0
--- /dev/null
+++ b/games/empire/pkg-plist
@@ -0,0 +1,5 @@
+bin/empire
+man/man6/empire.6.gz
+share/doc/empire/BUGS
+share/doc/empire/COPYING
+share/doc/empire/READ.ME