aboutsummaryrefslogtreecommitdiff
path: root/games/ensemblist
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-09-09 00:04:11 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-09-09 00:04:11 +0000
commitd37587dbc0c91c82a1e71bebda208671c56fb4fd (patch)
treee7481250afdd1a62b0dcac69f22a4a133bd317b7 /games/ensemblist
parent89f1f7b647d23f9189a2027c33c1ad0e3a601bdc (diff)
downloadports-d37587dbc0c91c82a1e71bebda208671c56fb4fd.tar.gz
ports-d37587dbc0c91c82a1e71bebda208671c56fb4fd.zip
Add ensemblist.
Ensemblist is a unique reflexion game created for the video game coding compo held in March 2003 in Paris. In this game, you have to put together several simple geometric primitives to build a given shape. For this, you can move, rotate and compose the primitives with the boolean operators union, intersection and minus. This is building what is called a C.S.G, for Constructive Solid Geometry. WWW: http://www.nongnu.org/ensemblist/index_en.html PR: ports/85805 Submitted by: Igor Pokrovsky <ip@doom.homeunix.org>
Notes
Notes: svn path=/head/; revision=142252
Diffstat (limited to 'games/ensemblist')
-rw-r--r--games/ensemblist/Makefile50
-rw-r--r--games/ensemblist/distinfo2
-rw-r--r--games/ensemblist/files/patch-Makefile26
-rw-r--r--games/ensemblist/pkg-descr12
4 files changed, 90 insertions, 0 deletions
diff --git a/games/ensemblist/Makefile b/games/ensemblist/Makefile
new file mode 100644
index 000000000000..723be53a91e8
--- /dev/null
+++ b/games/ensemblist/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: ensemblist
+# Date created: 06 Sep 2005
+# Whom: Igor Pokrovsky <ip@doom.homeunix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ensemblist
+PORTVERSION= 040126
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ip@doom.homeunix.org
+COMMENT= Assemble given shapes from primitives
+
+LIB_DEPENDS= glut.3:${PORTSDIR}/graphics/libglut \
+ mikmod.2:${PORTSDIR}/audio/libmikmod \
+ png.5:${PORTSDIR}/graphics/png
+
+USE_GMAKE= yes
+USE_GL= yes
+USE_X_PREFIX= yes
+MAKE_ARGS= CC="${CC}" DATADIR="${DATADIR}"
+
+PLIST= ${WRKDIR}/pkg-plist
+
+PLIST_FILES= bin/ensemblist
+PLIST_DIRS= %%DATADIR%%
+MAN6= ensemblist.6
+PORTDOCS= *
+
+pre-install:
+ @${RM} -f ${PLIST}
+ @${FIND} ${WRKSRC}/datas -type f | ${SORT} \
+ | ${SED} -e 's|^${WRKSRC}/datas|%%DATADIR%%|' >> ${PLIST}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/datas/* ${DATADIR}
+
+.ifndef (NOPORTDOCS)
+ cd ${WRKSRC}/html && \
+ ${FIND} * -type d -exec ${MKDIR} "${DOCSDIR}/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DOCSDIR}/{}" \;
+ ${INSTALL_MAN} ${WRKSRC}/ensemblist.6 ${MAN6PREFIX}/man/man6
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/ensemblist/distinfo b/games/ensemblist/distinfo
new file mode 100644
index 000000000000..8d4f4390a271
--- /dev/null
+++ b/games/ensemblist/distinfo
@@ -0,0 +1,2 @@
+MD5 (ensemblist-040126.tar.gz) = 67f42488b7b502bb5f4840ad130bcd72
+SIZE (ensemblist-040126.tar.gz) = 1312095
diff --git a/games/ensemblist/files/patch-Makefile b/games/ensemblist/files/patch-Makefile
new file mode 100644
index 000000000000..16bb158866ac
--- /dev/null
+++ b/games/ensemblist/files/patch-Makefile
@@ -0,0 +1,26 @@
+--- Makefile.orig Mon Jan 26 16:37:05 2004
++++ Makefile Fri Sep 9 01:38:30 2005
+@@ -6,8 +6,8 @@
+ LINK_FLAGS=-g -lm -L /usr/X11R6/lib -lXmu -lGL -lglut -lGLU -lpng `libmikmod-config --libs` -lefence -lpthread
+ else
+ DATADIR=$(DESTDIR)/usr/share/$(NAME)
+-COMPILE_FLAGS=-Wall -O3 -fomit-frame-pointer `libmikmod-config --cflags` -DNDEBUG -DDATADIR=$(DATADIR)
+-LINK_FLAGS=-lm -L /usr/X11R6/lib -lXmu -lGL -lglut -lGLU -lpng `libmikmod-config --libs` -lpthread
++COMPILE_FLAGS=$(CFLAGS) -Wall -I$(LOCALBASE)/include -I$(X11BASE)/include `$(LOCALBASE)/bin/libmikmod-config --cflags` -DNDEBUG -DDATADIR=$(DATADIR) $(PTHREAD_CFLAGS)
++LINK_FLAGS=-lm -L$(LOCALBASE)/lib -L$(X11BASE)/lib -lXmu -lGL -lglut -lGLU -lpng `$(LOCALBASE)/bin/libmikmod-config --libs` $(PTHREAD_LIBS)
+ endif
+ APPLE_FRAMEWORKS=-framework GLUT -framework Cocoa -framework OpenGL
+ #uncomment the following if you want to compile on MacOS/X
+@@ -25,7 +25,6 @@
+ @echo '$(COL)$@$(NORM)'
+ $(CC) $(COMPILE_FLAGS) $(LINK_FLAGS) $^ -o $@
+ ifndef DEBUG
+- strip $(NAME)
+ endif
+
+ .c.o:
+@@ -54,4 +53,3 @@
+ @install -m755 $(NAME) $(DESTDIR)/usr/games
+ @find datas/ -\( -name CVS -prune -\) -o -type f -exec install -m644 \{\} $(DATADIR) \;
+
+-include depends
diff --git a/games/ensemblist/pkg-descr b/games/ensemblist/pkg-descr
new file mode 100644
index 000000000000..4014cf3abb78
--- /dev/null
+++ b/games/ensemblist/pkg-descr
@@ -0,0 +1,12 @@
+Ensemblist is a unique reflexion game created for the video game coding
+compo held in March 2003 in Paris.
+In this game, you have to put together several simple geometric
+primitives to build a given shape. For this, you can move, rotate and
+compose the primitives with the boolean operators union, intersection
+and minus. This is building what is called a C.S.G, for Constructive
+Solid Geometry.
+
+WWW: http://www.nongnu.org/ensemblist/index_en.html
+
+- Igor Pokrovsky
+ip@doom.homeunix.org