aboutsummaryrefslogtreecommitdiff
path: root/games/flightgear
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-12-11 18:04:49 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-12-11 18:04:49 +0000
commit02290c68233bf1b58bbe7e36f5cbc0c66ea8b28f (patch)
tree1c7755779c1afe8757d4221cbc0ea8bf4c9d54ca /games/flightgear
parent3e8a71e6d46db1c48f085f92bb5fb7c99a85f6f0 (diff)
downloadports-02290c68233bf1b58bbe7e36f5cbc0c66ea8b28f.tar.gz
ports-02290c68233bf1b58bbe7e36f5cbc0c66ea8b28f.zip
Accommodate the flightgear-l410 slave port.
Notes
Notes: svn path=/head/; revision=150898
Diffstat (limited to 'games/flightgear')
-rw-r--r--games/flightgear/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index c0cf2ba76893..417f4cc54ab1 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -5,15 +5,16 @@
# $FreeBSD$
#
-PORTNAME= FlightGear
-PORTVERSION= 0.9.9
-PORTREVISION= 1
+PORTNAME?= FlightGear
+PORTVERSION?= ${FGVERSION}
+PORTREVISION?= 1
CATEGORIES= games
-MASTER_SITES= ftp://ftp.flightgear.org/pub/fgfs/Source/ \
- ftp://ftp.de.flightgear.org/pub/fgfs/Source/
+MASTER_SITES+= ftp://ftp.flightgear.org/pub/fgfs/Source/:fg \
+ ftp://ftp.de.flightgear.org/pub/fgfs/Source/:fg
+DISTFILES+= ${DISTNAME}${EXTRACT_SUFX}:fg
-MAINTAINER= jylefort@FreeBSD.org
-COMMENT= The FlightGear flight simulator
+MAINTAINER?= jylefort@FreeBSD.org
+COMMENT?= The FlightGear flight simulator
LIB_DEPENDS= glut:${PORTSDIR}/graphics/libglut \
openal.0:${PORTSDIR}/audio/openal
@@ -23,6 +24,8 @@ RUN_DEPENDS= ${X11BASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${X11BASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear \
${X11BASE}/share/FlightGear/version:${PORTSDIR}/games/fgfs-base
+FGVERSION= 0.9.9
+
USE_X_PREFIX= yes
USE_GL= yes
USE_REINPLACE= yes
@@ -33,7 +36,9 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
CONFIGURE_ARGS= --datadir=${X11BASE}/share # location of fgfs-base
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+.if ${PORTNAME} == FlightGear
MAN1= est-epsilon.1 fgfs.1 fgjs.1 gl-info.1 js_demo.1 pstest.1
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|-D_REENTRANT|${PTHREAD_CFLAGS}|' \