aboutsummaryrefslogtreecommitdiff
path: root/games/freesci
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2006-05-12 11:44:19 +0000
committerVolker Stolz <vs@FreeBSD.org>2006-05-12 11:44:19 +0000
commitbc3314dc50bb7cbbfde4c066e007b961788a5755 (patch)
tree87cce767ebae634006a6426abffe6f81086e675b /games/freesci
parenta29cae365a90df4ac0efc84ecb0c4461619c1b3d (diff)
downloadports-bc3314dc50bb7cbbfde4c066e007b961788a5755.tar.gz
ports-bc3314dc50bb7cbbfde4c066e007b961788a5755.zip
- Update freesci to 0.3.5
- Remove Savannah mirror(s), add one that works - Convert to OPTIONS - All patches have been integrated by vendor PR: ports/96932 Submitted by: Shaun Amott
Notes
Notes: svn path=/head/; revision=162165
Diffstat (limited to 'games/freesci')
-rw-r--r--games/freesci/Makefile27
-rw-r--r--games/freesci/distinfo6
-rw-r--r--games/freesci/files/patch-configure11
-rw-r--r--games/freesci/files/patch-src::gdx::drivers::directfb_driver.c11
-rw-r--r--games/freesci/files/patch-src::sound::pcmout_oss.c18
-rw-r--r--games/freesci/files/patch-src::sound::pcmout_sdl.c35
6 files changed, 11 insertions, 97 deletions
diff --git a/games/freesci/Makefile b/games/freesci/Makefile
index 87d697e54134..5043dae91bb1 100644
--- a/games/freesci/Makefile
+++ b/games/freesci/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= freesci
-PORTVERSION= 0.3.4c
+PORTVERSION= 0.3.5
CATEGORIES= games emulators
-MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
+MASTER_SITES= http://www-plan.cs.colorado.edu/creichen/${PORTNAME}/ \
http://teksolv.de/~jameson/
MASTER_SITE_SUBDIR=${PORTNAME}/stable.pkg/${PORTVERSION}
@@ -25,6 +25,12 @@ CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}"
MAN6= freesci-tools.6 freesci.6
+OPTIONS= CONSOLE "With console support" off \
+ SDL "With SDL support" off \
+ GGI "With GGI support" off \
+ DIRECTFB "With DirectFB support" off \
+ OPTIMIZED_CFLAGS "Build with code optimizations" off
+
.include <bsd.port.pre.mk>
.if defined(WITH_OPTIMIZED_CFLAGS)
@@ -71,23 +77,6 @@ CONFIGURE_ARGS+= --with-ggi-dir=${LOCALBASE}
CONFIGURE_ARGS+= --without-ggi
.endif
-pre-everything::
-.if !defined(WITH_CONSOLE)
- @${ECHO_MSG} "Define WITH_CONSOLE to build console support"
-.endif
-.if !defined(WITH_SDL)
- @${ECHO_MSG} "Define WITH_SDL to build with SDL support"
-.endif
-.if !defined(WITH_GGI)
- @${ECHO_MSG} "Define WITH_GGI to build with GGI support"
-.endif
-.if !defined(WITH_DIRECTFB)
- @${ECHO_MSG} "Define WITH_DIRECTFB to build with DirectFB support"
-.endif
-.if !defined(WITH_OPTIMIZED_CFLAGS)
- @${ECHO_MSG} "Define WITH_OPTIMIZED_CFLAGS to build with extra optimizations"
-.endif
-
pre-configure:
@${REINPLACE_CMD} -e 's/-lpthread/${PTHREAD_LIBS}/g' ${WRKSRC}/configure
diff --git a/games/freesci/distinfo b/games/freesci/distinfo
index 342e5fecea96..6687f4ba2332 100644
--- a/games/freesci/distinfo
+++ b/games/freesci/distinfo
@@ -1,3 +1,3 @@
-MD5 (freesci-0.3.4c.tar.bz2) = 2ec3240460316cb2901371d07662b1c4
-SHA256 (freesci-0.3.4c.tar.bz2) = fc277727e3779d2caa7cb93118e11648e8de62b5cdd52f1ae14c3b6968e47ebe
-SIZE (freesci-0.3.4c.tar.bz2) = 953374
+MD5 (freesci-0.3.5.tar.bz2) = e18cd3366bd2a2773cecb5d20619807e
+SHA256 (freesci-0.3.5.tar.bz2) = 46bb779cd8881f9126e0296ffe43cbb44a407f5b0d98846cc2321db323e76303
+SIZE (freesci-0.3.5.tar.bz2) = 1022657
diff --git a/games/freesci/files/patch-configure b/games/freesci/files/patch-configure
deleted file mode 100644
index d759c95d2849..000000000000
--- a/games/freesci/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Thu Apr 8 04:19:41 2004
-+++ configure Sat Jun 12 16:07:07 2004
-@@ -9619,6 +9619,8 @@
-
- fi
-
-+CFLAGS="$X_CFLAGS $CFLAGS"
-+CPPFLAGS="$X_CFLAGS $CPPFLAGS"
-
- if test x"$have_x" = xyes; then
-
diff --git a/games/freesci/files/patch-src::gdx::drivers::directfb_driver.c b/games/freesci/files/patch-src::gdx::drivers::directfb_driver.c
deleted file mode 100644
index bd2109f29518..000000000000
--- a/games/freesci/files/patch-src::gdx::drivers::directfb_driver.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/gfx/drivers/directfb_driver.c.orig Thu Feb 20 17:37:19 2003
-+++ src/gfx/drivers/directfb_driver.c Thu Feb 20 17:37:46 2003
-@@ -611,7 +611,7 @@
-
- switch (pixel_format) {
-
-- case DSPF_RGB15:
-+ case DSPF_ARGB1555:
- *bytespp = 2;
- *rm = 5; _rs = 10;
- *gm = 5; _gs = 5;
diff --git a/games/freesci/files/patch-src::sound::pcmout_oss.c b/games/freesci/files/patch-src::sound::pcmout_oss.c
deleted file mode 100644
index 41333d03d40b..000000000000
--- a/games/freesci/files/patch-src::sound::pcmout_oss.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/sound/pcmout_oss.c.orig Thu Feb 20 20:52:48 2003
-+++ src/sound/pcmout_oss.c Thu Feb 20 21:02:06 2003
-@@ -75,6 +75,15 @@
- return -1;
- }
-
-+/* Some OSS don't define the native endian */
-+#ifndef AFMT_S16_NE
-+ #if defined __i386__ || defined __alpha__
-+ #define AFMT_S16_NE AFMT_S16_LE
-+ #elif defined __mips__
-+ #define AFMT_S16_NE AFMT_S16_BE
-+ #endif
-+ /* FIXME are these correct? */
-+#endif
- i = AFMT_S16_NE; /* Use NATIVE endian format... */
- if (ioctl (oss_fd, SNDCTL_DSP_SETFMT, &i)) {
- fprintf(stderr, "[PCM-OSS] Failed to set device output format\n");
diff --git a/games/freesci/files/patch-src::sound::pcmout_sdl.c b/games/freesci/files/patch-src::sound::pcmout_sdl.c
deleted file mode 100644
index eb10e313d6a6..000000000000
--- a/games/freesci/files/patch-src::sound::pcmout_sdl.c
+++ /dev/null
@@ -1,35 +0,0 @@
---- src/gfx/drivers/sdl_driver.c.orig Tue Feb 4 21:12:10 2003
-+++ src/gfx/drivers/sdl_driver.c Tue Feb 4 21:16:42 2003
-@@ -45,7 +45,7 @@
-
- #ifndef _MSC_VER
- # include <sys/time.h>
--# include <SDL/SDL.h>
-+# include <SDL11/SDL.h>
- #else
- # include <SDL.h>
- #endif
---- src/sound/thread_ss_sdl.c.orig Tue Feb 4 21:15:31 2003
-+++ src/sound/thread_ss_sdl.c Tue Feb 4 21:16:25 2003
-@@ -32,8 +32,8 @@
- #ifdef HAVE_SDL
-
- #ifndef _MSC_VER
--# include <SDL/SDL.h>
--# include <SDL/SDL_thread.h>
-+# include <SDL11/SDL.h>
-+# include <SDL11/SDL_thread.h>
- # include <sys/timeb.h>
- #else
- # include <SDL.h>
---- src/sound/pcmout_sdl.c.orig Tue Feb 4 21:15:37 2003
-+++ src/sound/pcmout_sdl.c Tue Feb 4 21:16:32 2003
-@@ -23,7 +23,7 @@
-
- #ifndef _MSC_VER
- # include <sys/time.h>
--# include <SDL/SDL.h>
-+# include <SDL11/SDL.h>
- #else
- # include <SDL.h>
- #endif