aboutsummaryrefslogtreecommitdiff
path: root/games/garith
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-08-04 16:02:50 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-08-04 16:02:50 +0000
commite4a7e34250f1e1c9f97fd22f37199efa51cb5084 (patch)
treebe8c053db331d80f890915f0d1fa6a8385a4bd90 /games/garith
parent08004f17e6dae2e6b616986495c512450c667f0d (diff)
downloadports-e4a7e34250f1e1c9f97fd22f37199efa51cb5084.tar.gz
ports-e4a7e34250f1e1c9f97fd22f37199efa51cb5084.zip
- More mirrors
- General clean-up
Notes
Notes: svn path=/head/; revision=197083
Diffstat (limited to 'games/garith')
-rw-r--r--games/garith/Makefile28
-rw-r--r--games/garith/files/patch-aa26
-rw-r--r--games/garith/files/patch-ab29
-rw-r--r--games/garith/pkg-descr1
-rw-r--r--games/garith/pkg-plist7
5 files changed, 19 insertions, 72 deletions
diff --git a/games/garith/Makefile b/games/garith/Makefile
index c426de674370..caf795420447 100644
--- a/games/garith/Makefile
+++ b/games/garith/Makefile
@@ -7,25 +7,33 @@
PORTNAME= garith
PORTVERSION= 2.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
-MASTER_SITES= http://www.cnm-vra.com/micah/garith/
+MASTER_SITES= http://www.cnm-vra.com/micah/garith/ CENKES
+# Latest version (2.3.1) does not build with gtk 1.2.10
MAINTAINER= ports@FreeBSD.org
COMMENT= Arithmetic quiz program for X Window System
-ALL_TARGET= # empty
-USE_X_PREFIX= yes
USE_GNOME= gtk12
WRKSRC= ${WRKDIR}/garith
+CFLAGS+= `${GTK_CONFIG} --cflags`
+LDFLAGS= `${GTK_CONFIG} --libs`
+PORTDOCS= BUGS HISTORY README TODO
+PLIST_FILES= bin/garith
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|gldouble|double|;/gnome/d;/all.*apps/d'\
+ ${WRKSRC}/garith.c
+
+do-build:
+ cd ${WRKSRC}&&${CC} ${CFLAGS} -o garith garith.c ${LDFLAGS}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/garith ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/garith
-.for file in BUGS COPYING HISTORY README TODO
- ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/garith
-.endfor
+ ${INSTALL_PROGRAM} ${WRKSRC}/garith ${PREFIX}/bin/
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @cd ${WRKSRC}&&${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
.endif
.include <bsd.port.mk>
diff --git a/games/garith/files/patch-aa b/games/garith/files/patch-aa
deleted file mode 100644
index 19fb332dadd4..000000000000
--- a/games/garith/files/patch-aa
+++ /dev/null
@@ -1,26 +0,0 @@
---- Makefile.orig Thu Sep 18 13:03:00 1997
-+++ Makefile Wed Mar 29 21:49:16 2000
-@@ -1,16 +1,16 @@
- # Makefile adapted from that in the GMix distribution, thanks.
--CC=gcc
--LINK=gcc
--INCDIR=
--LIBDIR=-L/usr/X11R6/lib
--LDLIBS=-lgnome -lgnomeui -lgdk -lgtk -lglib -lm
--OPTFLAGS= -m486 -O2 -Wall
-+CC?=gcc
-+LINK=$(CC)
-+INCDIR=`${GTK_CONFIG} --cflags`
-+LIBDIR=`${GTK_CONFIG} --libs`
-+#LDLIBS=-lgnome -lgnomeui -lgdk -lgtk -lglib -lm
-+#OPTFLAGS= -m486 -O2 -Wall
- DEST=garith
-
- OBJS=garith.o
- SRCS=garith.c
-
--CFLAGS= $(OPTFLAGS) $(DEFINES) $(INCDIR)
-+CFLAGS+= $(OPTFLAGS) $(DEFINES) $(INCDIR)
- LFLAGS= $(LIBDIR) $(LDLIBS)
-
- $(DEST) : $(OBJS)
diff --git a/games/garith/files/patch-ab b/games/garith/files/patch-ab
deleted file mode 100644
index 8571b9ee232f..000000000000
--- a/games/garith/files/patch-ab
+++ /dev/null
@@ -1,29 +0,0 @@
---- garith.c Wed Sep 17 23:47:03 1997
-+++ /home/andy/tmp/wrk/garith.c Wed Aug 5 13:55:44 1998
-@@ -24,7 +24,7 @@
- */
-
- #include <gtk/gtk.h> /* GTK stuff */
--#include <gnome.h> /* GNOME stuff */
-+/* #include <gnome.h> /* GNOME stuff */
- #include <stdlib.h>
- #include <time.h> /* we use time as seed for rand() */
-
-@@ -76,7 +76,7 @@
-
- gulong num1, num2;
- guint right = 0, done = 0;
--gldouble less_than;
-+double less_than;
- gchar op;
- time_t starttime;
-
-@@ -643,7 +643,7 @@
- gnome_init() is called by all gnome apps. */
-
- gtk_init(&argc, &argv);
-- gnome_init(&argc, &argv);
-+ /* gnome_init(&argc, &argv); */
-
- /* Make the windows */
-
diff --git a/games/garith/pkg-descr b/games/garith/pkg-descr
index 862f5bfab06c..2cddff4c53e5 100644
--- a/games/garith/pkg-descr
+++ b/games/garith/pkg-descr
@@ -3,3 +3,4 @@ It is fairly self-explanatory, so there is no documentation about
program usage much at all.
WWW: http://www.cnm-vra.com/micah/garith/
+Author: Micah Stetson
diff --git a/games/garith/pkg-plist b/games/garith/pkg-plist
deleted file mode 100644
index 7579e6f1c5d6..000000000000
--- a/games/garith/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-bin/garith
-%%PORTDOCS%%share/doc/garith/BUGS
-%%PORTDOCS%%share/doc/garith/COPYING
-%%PORTDOCS%%share/doc/garith/HISTORY
-%%PORTDOCS%%share/doc/garith/README
-%%PORTDOCS%%share/doc/garith/TODO
-%%PORTDOCS%%@dirrm share/doc/garith