aboutsummaryrefslogtreecommitdiff
path: root/games/glasteroids
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2000-08-17 06:25:03 +0000
committerKris Kennaway <kris@FreeBSD.org>2000-08-17 06:25:03 +0000
commit64c614c46cb1d0e471bdcdfb30cb7c52ff078434 (patch)
tree9ea66e4d52664cf30c4509910d01a920c86d06bd /games/glasteroids
parent4e04ff0f8a596c70f7b90eefb8bc49c3d1332597 (diff)
downloadports-64c614c46cb1d0e471bdcdfb30cb7c52ff078434.tar.gz
ports-64c614c46cb1d0e471bdcdfb30cb7c52ff078434.zip
Make this setgid games to avoid a world-writable file
Notes
Notes: svn path=/head/; revision=31697
Diffstat (limited to 'games/glasteroids')
-rw-r--r--games/glasteroids/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/games/glasteroids/Makefile b/games/glasteroids/Makefile
index 67345f7bbd3a..7cca6c77e7d4 100644
--- a/games/glasteroids/Makefile
+++ b/games/glasteroids/Makefile
@@ -24,13 +24,14 @@ pre-build:
@ ${CP} ${FILESDIR}/Makefile.FreeBSD ${WRKSRC}
do-install:
- @ ${INSTALL_PROGRAM} ${WRKSRC}/Glasteroids ${PREFIX}/bin/glasteroids
+ @ ${INSTALL_PROGRAM} -m 2755 -o root -g games ${WRKSRC}/Glasteroids ${PREFIX}/bin/glasteroids
@ ${MKDIR} ${PREFIX}/share/glasteroids
@ ${INSTALL_DATA} ${WRKSRC}/gameText.txf ${PREFIX}/share/glasteroids
@ cd ${WRKSRC}; tar -cf - scores.txt textures | \
( cd ${PREFIX}/share/glasteroids; tar -xf - )
@ ${CHMOD} a+rx ${PREFIX}/share/glasteroids/textures
- @ ${CHMOD} a+rw ${PREFIX}/share/glasteroids/scores.txt
+ @ ${CHMOD} g+rw,a-x ${PREFIX}/share/glasteroids/scores.txt
+ @ ${CHOWN} root:games ${PREFIX}/share/glasteroids/scores.txt
post-install:
.if !defined(NOPORTDOCS)