aboutsummaryrefslogtreecommitdiff
path: root/games/gnudoku
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-02-13 12:36:22 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-02-13 12:36:22 +0000
commit733d35bf97b2715c4cdd7a531e0c991c1ca65613 (patch)
treefc7cf6d3528c2b5ea1ec67085409ba6de7872b31 /games/gnudoku
parentae8be5ee1313e854054d40fc1d922899db9591c2 (diff)
downloadports-733d35bf97b2715c4cdd7a531e0c991c1ca65613.tar.gz
ports-733d35bf97b2715c4cdd7a531e0c991c1ca65613.zip
A free program for creating and solving Su Doku puzzles.
You can use GNUDoku to challenge yourself, to compute solutions, or to verify your own solutions. A Su Doku puzzle is a 9x9 grid which must be filled with numbers between 1 and 9 such that each row, column, and 3x3 square contains all 9 numbers. WWW: http://icculus.org/~jcspray/GNUDoku/ PR: ports/92733 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Notes
Notes: svn path=/head/; revision=155928
Diffstat (limited to 'games/gnudoku')
-rw-r--r--games/gnudoku/Makefile27
-rw-r--r--games/gnudoku/distinfo3
-rw-r--r--games/gnudoku/pkg-descr10
-rw-r--r--games/gnudoku/pkg-plist5
4 files changed, 45 insertions, 0 deletions
diff --git a/games/gnudoku/Makefile b/games/gnudoku/Makefile
new file mode 100644
index 000000000000..b10de0f153f7
--- /dev/null
+++ b/games/gnudoku/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: GNUDoku
+# Date created: 12 Jan 2006
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GNUDoku
+PORTVERSION= 0.93
+CATEGORIES= games
+MASTER_SITES= http://offload1.icculus.org/~jcspray/GNUDoku/ \
+ http://icculus.org/~jcspray/GNUDoku/
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= A free program for creating and solving Su Doku puzzles
+
+LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
+
+USE_GMAKE= yes
+MAKE_ENV= CXX="${CXX}" CXXLAGS="${CXXFLAGS}"
+USE_GCC= 3.4+
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|PREFIX=|PREFIX?=|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|CXXFLAGS=|CXXFLAGS+=|' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/games/gnudoku/distinfo b/games/gnudoku/distinfo
new file mode 100644
index 000000000000..e69f3c7c28d0
--- /dev/null
+++ b/games/gnudoku/distinfo
@@ -0,0 +1,3 @@
+MD5 (GNUDoku-0.93.tar.gz) = 4025682e434da2f1972b309f63660235
+SHA256 (GNUDoku-0.93.tar.gz) = 409b18d525c37660a117d786fe537672c7f58b7f01e2c37dbc1cdf339661075d
+SIZE (GNUDoku-0.93.tar.gz) = 26212
diff --git a/games/gnudoku/pkg-descr b/games/gnudoku/pkg-descr
new file mode 100644
index 000000000000..5812bd059c32
--- /dev/null
+++ b/games/gnudoku/pkg-descr
@@ -0,0 +1,10 @@
+A free program for creating and solving Su Doku puzzles.
+
+You can use GNUDoku to challenge yourself, to compute solutions,
+or to verify your own solutions.
+
+A Su Doku puzzle is a 9x9 grid which must be filled with numbers
+between 1 and 9 such that each row, column, and 3x3 square contains
+all 9 numbers.
+
+WWW: http://icculus.org/~jcspray/GNUDoku/
diff --git a/games/gnudoku/pkg-plist b/games/gnudoku/pkg-plist
new file mode 100644
index 000000000000..614920d0855e
--- /dev/null
+++ b/games/gnudoku/pkg-plist
@@ -0,0 +1,5 @@
+bin/GNUDoku
+share/applications/GNUDoku.desktop
+share/pixmaps/GNUDoku.png
+@dirrmtry share/applications
+@dirrmtry share/pixmaps