aboutsummaryrefslogtreecommitdiff
path: root/games/greed
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-08-03 06:42:12 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-08-03 06:42:12 +0000
commita0e0a9110af83c9ee109a1a529003e240d544296 (patch)
treeb8330b6933847f4ca7446d09e483cb9de94dff5b /games/greed
parentaab23405a59b3ee0ae5c3e79684caf9c87443784 (diff)
downloadports-a0e0a9110af83c9ee109a1a529003e240d544296.tar.gz
ports-a0e0a9110af83c9ee109a1a529003e240d544296.zip
- Update to 3.6
- Add mirrors - Remove empty scorefile at deinstall - Minor tweaks
Notes
Notes: svn path=/head/; revision=197002
Diffstat (limited to 'games/greed')
-rw-r--r--games/greed/Makefile22
-rw-r--r--games/greed/distinfo6
-rw-r--r--games/greed/files/patch-Makefile18
-rw-r--r--games/greed/pkg-descr3
-rw-r--r--games/greed/pkg-install9
5 files changed, 20 insertions, 38 deletions
diff --git a/games/greed/Makefile b/games/greed/Makefile
index 6f264d8f170e..a2f48ace19db 100644
--- a/games/greed/Makefile
+++ b/games/greed/Makefile
@@ -1,26 +1,34 @@
# New ports collection makefile for: greed
# Date created: Apr 2, 2001
-# Whom: Mark Pulford Ğmark@kyne.com.au>
+# Whom: Mark Pulford <mark@kyne.com.au>
#
# $FreeBSD$
#
PORTNAME= greed
-PORTVERSION= 3.5
+PORTVERSION= 3.6
CATEGORIES= games
-MASTER_SITES= http://catb.org/~esr/greed/
+MASTER_SITES= http://catb.org/~esr/greed/ CENKES
PKGNAMESUFFIX= -game
MAINTAINER= ports@FreeBSD.org
COMMENT= A text puzzle game with the aim of clearing the game field
-ALL_TARGET= greed
MAN6= greed.6
PLIST_FILES= bin/greed
+SCOREFILE?= /var/games/greed.hs
+CFLAGS+= -DSCOREFILE=\"${SCOREFILE}\" -DNOTBSD -DRELEASE=\"${PORTVERSION}\"
+LDFLAGS= -lcurses
+
+do-build:
+ @cd ${WRKSRC}&&${CC} ${CFLAGS} -o greed greed.c ${LDFLAGS}
do-install:
- ${INSTALL_PROGRAM} -m 2555 -o root -g games ${WRKSRC}/greed ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/greed.6 ${PREFIX}/man/man6
- ${SH} pkg-install ${PKGNAME} POST-INSTALL
+ ${INSTALL_PROGRAM} -m 2555 -o root -g games ${WRKSRC}/greed ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/greed.6 ${MAN6PREFIX}/man/man6/
+ @a=${SCOREFILE};[ -f $$a ]||:>$$a&&${CHOWN} root:games $$a&&${CHMOD} 664 $$a
+ @${ECHO_CMD} '@exec a=${SCOREFILE};[ -f $$a ]||:>$$a&&\
+ ${CHOWN} root:games $$a&&${CHMOD} 664 $$a' >> ${TMPPLIST}
+ @${ECHO_CMD} '@unexec a=${SCOREFILE};[ -s $$a ]||${RM} -f $$a' >> ${TMPPLIST}
.include <bsd.port.mk>
diff --git a/games/greed/distinfo b/games/greed/distinfo
index 1d44efc22991..4224e9e6ee88 100644
--- a/games/greed/distinfo
+++ b/games/greed/distinfo
@@ -1,3 +1,3 @@
-MD5 (greed-3.5.tar.gz) = 874cbf69320c423f7eb8cd7ecf83695b
-SHA256 (greed-3.5.tar.gz) = 06a6896102610557a0692d1c6ebebc417644001da1eb3655c2244c568021932c
-SIZE (greed-3.5.tar.gz) = 11203
+MD5 (greed-3.6.tar.gz) = 502106bda564e0e7ce48f590a2555cf9
+SHA256 (greed-3.6.tar.gz) = d31279a558a3065cdff4576d32c90d69c87c8ad79c6da1cab80384d132f00e84
+SIZE (greed-3.6.tar.gz) = 18009
diff --git a/games/greed/files/patch-Makefile b/games/greed/files/patch-Makefile
deleted file mode 100644
index 098a193371b1..000000000000
--- a/games/greed/files/patch-Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
---- Makefile.orig Mon Apr 2 21:52:50 2001
-+++ Makefile Mon Apr 2 21:54:08 2001
-@@ -13,14 +13,12 @@
-
- # Prepend "c:" (or whatever drive you use) to the following paths for MSDOS
- # Location of high score file
--SFILE=/usr/games/lib/greed.hs
-+SFILE=/var/games/greed.hs
- # Location of game executable
- BIN=/usr/games
-
- # Flags for use with the Linux ncurses package (recommended)
--CFLAGS = -O -s -DNOTBSD
- TERMLIB = -lncurses
--CC = gcc
-
- # Flags for use with stock curses
- # CFLAGS = -O -s
diff --git a/games/greed/pkg-descr b/games/greed/pkg-descr
index 04c00a170649..7d84de12c51a 100644
--- a/games/greed/pkg-descr
+++ b/games/greed/pkg-descr
@@ -1,4 +1,5 @@
Greed is a unique text puzzle game where the object is to move around
the game field clearing the most numbers.
-WWW: http://catb.org/~esr/software.html
+WWW: http://catb.org/~esr/greed/
+Author: Eric S. Raymond <esr@snark.thyrsus.com>
diff --git a/games/greed/pkg-install b/games/greed/pkg-install
deleted file mode 100644
index 2a413b4c513c..000000000000
--- a/games/greed/pkg-install
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-
-FILE="/var/games/greed.hs"
-[ "$2" != "POST-INSTALL" -o -f "$FILE" ] && exit 0
-
-echo "===> Creating initial high score file $FILE"
-touch $FILE
-chown root:games $FILE
-chmod 664 $FILE