aboutsummaryrefslogtreecommitdiff
path: root/games/gretools
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2004-01-16 18:54:58 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2004-01-16 18:54:58 +0000
commit8b5b910499d5ac2815476bd8cce743417e949a96 (patch)
tree165ea4355951d5156089919f366e83d171537d43 /games/gretools
parent25c3af242a203b11e3bfadd830c6f9b2f75bdead (diff)
downloadports-8b5b910499d5ac2815476bd8cce743417e949a96.tar.gz
ports-8b5b910499d5ac2815476bd8cce743417e949a96.zip
Add gretools, a GTK2 English vocabulary tutor.
"My favourite part is 'How to Increase your Word Power!' That thing is really...... really........ good." -Homer Simpson
Notes
Notes: svn path=/head/; revision=98325
Diffstat (limited to 'games/gretools')
-rw-r--r--games/gretools/Makefile26
-rw-r--r--games/gretools/distinfo1
-rw-r--r--games/gretools/files/patch-gretools.in15
-rw-r--r--games/gretools/pkg-descr4
-rw-r--r--games/gretools/pkg-plist24
5 files changed, 70 insertions, 0 deletions
diff --git a/games/gretools/Makefile b/games/gretools/Makefile
new file mode 100644
index 000000000000..69832e8faca1
--- /dev/null
+++ b/games/gretools/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: gretools
+# Date created: 2004 January 15
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gretools
+PORTVERSION= 1.1
+CATEGORIES= games
+MASTER_SITES= http://theory.cs.iitm.ernet.in/~arvindn/gretools/${PORTVERSION}/
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= GTK2 vocabulary builder
+
+USE_X_PREFIX= yes
+USE_PYTHON= yes
+USE_GNOME= gnomehack gnometarget gnomeprefix pygtk2
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|/usr/bin/python|${PYTHON_CMD}|" \
+ ${WRKSRC}/${PORTNAME}.in
+
+.include <bsd.port.mk>
diff --git a/games/gretools/distinfo b/games/gretools/distinfo
new file mode 100644
index 000000000000..3bda1b50f672
--- /dev/null
+++ b/games/gretools/distinfo
@@ -0,0 +1 @@
+MD5 (gretools-1.1.tar.gz) = 43210ec1d0f6e502b921baa40a2be927
diff --git a/games/gretools/files/patch-gretools.in b/games/gretools/files/patch-gretools.in
new file mode 100644
index 000000000000..c0fc5a0f1aad
--- /dev/null
+++ b/games/gretools/files/patch-gretools.in
@@ -0,0 +1,15 @@
+--- gretools.in.orig Fri Jan 16 13:41:40 2004
++++ gretools.in Fri Jan 16 13:42:23 2004
+@@ -10,9 +10,9 @@
+ gretools.prefix_dir = "@prefix@"
+ gretools.package_name = "@PACKAGE@"
+ gretools.package_version = "@VERSION@"
+-gretools.glade_dir = "@prefix@/share/gretools/glade"
+-gretools.wordlist_dir = "@prefix@/share/gretools/lists"
+-gretools.image_dir = "@prefix@/share/pixmaps"
++gretools.glade_dir = "@prefix@/share/gnome/gretools/glade"
++gretools.wordlist_dir = "@prefix@/share/gnome/gretools/lists"
++gretools.image_dir = "@prefix@/share/gnome/pixmaps"
+
+
+ gretools.Gui()
diff --git a/games/gretools/pkg-descr b/games/gretools/pkg-descr
new file mode 100644
index 000000000000..adb74c578f33
--- /dev/null
+++ b/games/gretools/pkg-descr
@@ -0,0 +1,4 @@
+Gretools is a GTK2 vocabulary tutor. Its wordlist is comprised of about
+4000 words, and it has a synonym quiz and a word-guessing game.
+
+WWW: http://theory.cs.iitm.ernet.in/~arvindn/gretools/
diff --git a/games/gretools/pkg-plist b/games/gretools/pkg-plist
new file mode 100644
index 000000000000..c42f94722e57
--- /dev/null
+++ b/games/gretools/pkg-plist
@@ -0,0 +1,24 @@
+bin/gretools
+%%PYTHON_SITELIBDIR%%/gretools/gretools
+%%PYTHON_SITELIBDIR%%/gretools/gretools.py
+%%PYTHON_SITELIBDIR%%/gretools/gretools.pyc
+%%PYTHON_SITELIBDIR%%/gretools/gretools.pyo
+share/gnome/applications/gretools.desktop
+share/gnome/help/gretools/C/figures/gretools_start_window.png
+share/gnome/help/gretools/C/figures/synonym.png
+share/gnome/help/gretools/C/gretools.xml
+share/gnome/help/gretools/C/legal.xml
+share/gnome/gretools/glade/gretools.glade
+share/gnome/gretools/lists/default.wl
+share/gnome/omf/gretools/gretools-C.omf
+@exec scrollkeeper-install -q %D/share/gnome/omf/gretools/gretools-C.omf 2>/dev/null || /usr/bin/true
+share/gnome/pixmaps/gretools.png
+@dirrm share/gnome/omf/gretools
+@dirrm share/gnome/help/gretools/C/figures
+@dirrm share/gnome/help/gretools/C
+@dirrm share/gnome/help/gretools
+@dirrm share/gnome/gretools/lists
+@dirrm share/gnome/gretools/glade
+@dirrm share/gnome/gretools
+@dirrm %%PYTHON_SITELIBDIR%%/gretools
+@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/gretools/gretools-C.omf 2>/dev/null || /usr/bin/true