aboutsummaryrefslogtreecommitdiff
path: root/games/gturing
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-21 01:22:23 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-21 01:22:23 +0000
commit555a4e2a70fb482f34c4931f73292a9d6ccec19f (patch)
tree0c82fef6a9933e5c538d283a72170acb930f08de /games/gturing
parent9e8b88f9f16a093f2d6d3a95228c71685dbc6b47 (diff)
downloadports-555a4e2a70fb482f34c4931f73292a9d6ccec19f.tar.gz
ports-555a4e2a70fb482f34c4931f73292a9d6ccec19f.zip
New port: games/gturing - A simple Turing machine for gnome2
Gturing is a simple turing machine simulator with graphical interface. A Turing machine is the simplest possible computing device which can only perform very simple operations. However, almost everything in programming languages can be written as a program for the Turing machine. It's a nice complement for students who likes to practice with theory and a nice toy to play with. PR: ports/40368 Submitted by: Juan Salaverria <rael@vectorstar.net>
Notes
Notes: svn path=/head/; revision=73694
Diffstat (limited to 'games/gturing')
-rw-r--r--games/gturing/Makefile56
-rw-r--r--games/gturing/distinfo1
-rw-r--r--games/gturing/files/patch-Makefile.in11
-rw-r--r--games/gturing/files/patch-gturing.desktop.in7
-rw-r--r--games/gturing/files/patch-pixmaps-Makefile.in11
-rw-r--r--games/gturing/pkg-comment1
-rw-r--r--games/gturing/pkg-descr16
-rw-r--r--games/gturing/pkg-plist67
8 files changed, 170 insertions, 0 deletions
diff --git a/games/gturing/Makefile b/games/gturing/Makefile
new file mode 100644
index 000000000000..2d3b1770b3cb
--- /dev/null
+++ b/games/gturing/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: games/gturing
+# Date created: 08 Jul 2002
+# Whom: Juan Salaverria <rael@vectorstar.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gturing
+PORTVERSION= 0.1.1
+CATEGORIES= games gnome
+MASTER_SITES= ftp://ftp.gnome.org/pub/gnome/sources/gturing/0.1/
+
+MAINTAINER= rael@vectorstar.net
+
+LIB_DEPENDS= gnomeui-2.0:${PORTSDIR}/x11-toolkits/libgnomeui \
+ gnomeprintui-2.0:${PORTSDIR}/x11-toolkits/libgnomeprintui
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+DOCS= AUTHORS COPYING NEWS ChangeLog TODO README INSTALL
+
+EXAMPLEDIR= ${PREFIX}/share/examples/gturing
+
+EXAMPLES= 3ones2zeroes.tur add.tur bb3.tur dashnumbers.tur addbin.tur \
+ bb5.tur dec2bin.tur dec2bin_shift.tur bb2.tur bin2dec.tur \
+ bin2dec_shift.tur sort.tur subst.tur
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -e \
+ 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
+ s|[(]datadir[)]/locale|(prefix)/share/locale|g'
+
+post-install:
+ ${INSTALL} -d -o root -g wheel -m 0755 ${EXAMPLEDIR}
+.for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${WRKSRC}/tapes/${f} ${EXAMPLEDIR}
+.endfor
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/games/gturing/distinfo b/games/gturing/distinfo
new file mode 100644
index 000000000000..56cf7f235c67
--- /dev/null
+++ b/games/gturing/distinfo
@@ -0,0 +1 @@
+MD5 (gturing-0.1.1.tar.gz) = 69f2ae5afd8dd2e13a224f6b768e45eb
diff --git a/games/gturing/files/patch-Makefile.in b/games/gturing/files/patch-Makefile.in
new file mode 100644
index 000000000000..255d4a6a5933
--- /dev/null
+++ b/games/gturing/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Mon Jul 8 02:09:09 2002
++++ Makefile.in Mon Jul 8 02:52:04 2002
+@@ -116,7 +116,7 @@
+
+ SUBDIRS = pixmaps tapes po src help
+
+-desktopdir = $(datadir)/apps/Applications
++desktopdir = $(datadir)/applications
+ desktop_in_files = gturing.desktop.in
+ desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+
diff --git a/games/gturing/files/patch-gturing.desktop.in b/games/gturing/files/patch-gturing.desktop.in
new file mode 100644
index 000000000000..21e6149e412e
--- /dev/null
+++ b/games/gturing/files/patch-gturing.desktop.in
@@ -0,0 +1,7 @@
+--- gturing.desktop.in.orig Sat Jul 14 07:15:50 2001
++++ gturing.desktop.in Mon Jul 8 22:51:47 2002
+@@ -5,3 +5,4 @@
+ Icon=gnome-gturing.png
+ Terminal=0
+ Type=Application
++Categories=Application;Game;
diff --git a/games/gturing/files/patch-pixmaps-Makefile.in b/games/gturing/files/patch-pixmaps-Makefile.in
new file mode 100644
index 000000000000..f928b2c7bf41
--- /dev/null
+++ b/games/gturing/files/patch-pixmaps-Makefile.in
@@ -0,0 +1,11 @@
+--- pixmaps/Makefile.in.orig Tue Jul 9 01:09:00 2002
++++ pixmaps/Makefile.in Tue Jul 9 01:22:36 2002
+@@ -114,7 +114,7 @@
+ WARN_CFLAGS = @WARN_CFLAGS@
+ cxxflags_set = @cxxflags_set@
+
+-pixmapsdir = $(datadir)/$(PACKAGE)/pixmaps
++pixmapsdir = $(datadir)/pixmaps
+
+ pixmaps_DATA = gnome-gturing.png play.xpm power.xpm step.xpm stop.xpm
+
diff --git a/games/gturing/pkg-comment b/games/gturing/pkg-comment
new file mode 100644
index 000000000000..90aab86312bd
--- /dev/null
+++ b/games/gturing/pkg-comment
@@ -0,0 +1 @@
+A simple turing machine simulator for gnome 2
diff --git a/games/gturing/pkg-descr b/games/gturing/pkg-descr
new file mode 100644
index 000000000000..c16a8b65674d
--- /dev/null
+++ b/games/gturing/pkg-descr
@@ -0,0 +1,16 @@
+gturing is a simple turing machine simulator with
+graphical interface. A Turing machine is the simplest possible
+computing device which can only perform very simple operations.
+However, almost everything in programming languages can be
+written as a program for the Turing machine.
+
+Of course, no one uses the Turing machine for actual computing
+work, but it is very useful in theoretical computer science and
+mathematical logic.
+
+It's a nice complement for students who likes to practice with
+theory and a nice toy to play with.
+
+WWW: http://www.gnome.org/softwaremap/projects/gturing
+
+gpoo@ubiobio.cl
diff --git a/games/gturing/pkg-plist b/games/gturing/pkg-plist
new file mode 100644
index 000000000000..3d0538521f00
--- /dev/null
+++ b/games/gturing/pkg-plist
@@ -0,0 +1,67 @@
+share/locale/zh_TW/LC_MESSAGES/gturing-2.0.mo
+share/locale/zh_CN/LC_MESSAGES/gturing-2.0.mo
+share/locale/wa/LC_MESSAGES/gturing-2.0.mo
+share/locale/vi/LC_MESSAGES/gturing-2.0.mo
+share/locale/uk/LC_MESSAGES/gturing-2.0.mo
+share/locale/tr/LC_MESSAGES/gturing-2.0.mo
+share/locale/sv/LC_MESSAGES/gturing-2.0.mo
+share/locale/sl/LC_MESSAGES/gturing-2.0.mo
+share/locale/sk/LC_MESSAGES/gturing-2.0.mo
+share/locale/ru/LC_MESSAGES/gturing-2.0.mo
+share/locale/ro/LC_MESSAGES/gturing-2.0.mo
+share/locale/pt_BR/LC_MESSAGES/gturing-2.0.mo
+share/locale/pt/LC_MESSAGES/gturing-2.0.mo
+share/locale/pl/LC_MESSAGES/gturing-2.0.mo
+share/locale/no/LC_MESSAGES/gturing-2.0.mo
+share/locale/nl/LC_MESSAGES/gturing-2.0.mo
+share/locale/lt/LC_MESSAGES/gturing-2.0.mo
+share/locale/ko/LC_MESSAGES/gturing-2.0.mo
+share/locale/ja/LC_MESSAGES/gturing-2.0.mo
+share/locale/it/LC_MESSAGES/gturing-2.0.mo
+share/locale/hu/LC_MESSAGES/gturing-2.0.mo
+share/locale/gl/LC_MESSAGES/gturing-2.0.mo
+share/locale/ga/LC_MESSAGES/gturing-2.0.mo
+share/locale/fr/LC_MESSAGES/gturing-2.0.mo
+share/locale/fi/LC_MESSAGES/gturing-2.0.mo
+share/locale/et/LC_MESSAGES/gturing-2.0.mo
+share/locale/es/LC_MESSAGES/gturing-2.0.mo
+share/locale/el/LC_MESSAGES/gturing-2.0.mo
+share/locale/de/LC_MESSAGES/gturing-2.0.mo
+share/locale/da/LC_MESSAGES/gturing-2.0.mo
+share/locale/cs/LC_MESSAGES/gturing-2.0.mo
+share/locale/az/LC_MESSAGES/gturing-2.0.mo
+share/gnome/pixmaps/stop.xpm
+share/gnome/pixmaps/step.xpm
+share/gnome/pixmaps/power.xpm
+share/gnome/pixmaps/play.xpm
+share/gnome/pixmaps/gnome-gturing.png
+share/gnome/omf/gturing/gturing-C.omf
+share/gnome/help/gturing/C/legal.xml
+share/gnome/help/gturing/C/gturing.xml
+share/gnome/help/gturing/C/figures/mainwin.png
+share/gnome/applications/gturing.desktop
+bin/gturing
+@unexec rmdir %D/share/locale/*/LC_MESSAGES 2>/dev/null || true
+@unexec rmdir %D/share/locale/* 2>/dev/null || true
+%%PORTDOCS%%share/examples/gturing/subst.tur
+%%PORTDOCS%%share/examples/gturing/sort.tur
+%%PORTDOCS%%share/examples/gturing/dec2bin_shift.tur
+%%PORTDOCS%%share/examples/gturing/dec2bin.tur
+%%PORTDOCS%%share/examples/gturing/dashnumbers.tur
+%%PORTDOCS%%share/examples/gturing/bin2dec_shift.tur
+%%PORTDOCS%%share/examples/gturing/bin2dec.tur
+%%PORTDOCS%%share/examples/gturing/bb5.tur
+%%PORTDOCS%%share/examples/gturing/bb3.tur
+%%PORTDOCS%%share/examples/gturing/bb2.tur
+%%PORTDOCS%%share/examples/gturing/addbin.tur
+%%PORTDOCS%%share/examples/gturing/add.tur
+%%PORTDOCS%%share/examples/gturing/3ones2zeroes.tur
+%%PORTDOCS%%share/doc/gturing/TODO
+%%PORTDOCS%%share/doc/gturing/README
+%%PORTDOCS%%share/doc/gturing/NEWS
+%%PORTDOCS%%share/doc/gturing/INSTALL
+%%PORTDOCS%%share/doc/gturing/ChangeLog
+%%PORTDOCS%%share/doc/gturing/COPYING
+%%PORTDOCS%%share/doc/gturing/AUTHORS
+%%PORTDOCS%%@dirrm share/examples/gturing
+%%PORTDOCS%%@dirrm share/doc/gturing