aboutsummaryrefslogtreecommitdiff
path: root/games/heroes
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-03-13 05:36:23 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-03-13 05:36:23 +0000
commitc47e27d5d651bcdddc59c4e10edbcef76ffd7bd6 (patch)
tree3627af52828c8395fc2cb13ffb9c983e8ed31ec7 /games/heroes
parentf97ea1d9b82624a608567fb53fe167c1db1ecd20 (diff)
downloadports-c47e27d5d651bcdddc59c4e10edbcef76ffd7bd6.tar.gz
ports-c47e27d5d651bcdddc59c4e10edbcef76ffd7bd6.zip
- Unbreak on alpha (avoid -ffast-math)
- Bumped PORTREVISION, check if you want WITH_OPTIMIZED_CFLAGS on recompilation PR: ports/63866 (with addition of pre-everything:) Submitted by: maintainer/bento Approved by: linimon (mentor)
Notes
Notes: svn path=/head/; revision=103839
Diffstat (limited to 'games/heroes')
-rw-r--r--games/heroes/Makefile20
1 files changed, 14 insertions, 6 deletions
diff --git a/games/heroes/Makefile b/games/heroes/Makefile
index 004a565695e9..a675fbdfa74f 100644
--- a/games/heroes/Makefile
+++ b/games/heroes/Makefile
@@ -7,7 +7,7 @@
PORTNAME= heroes
PORTVERSION= 0.21
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -43,16 +43,24 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --with-sdl_mixer=${LOCALBASE} --without-gii --without-ggi
+.if defined(WITH_OPTIMIZED_CFLAGS)
+CONFIGURE_ARGS+=--enable-optimizations
+.else
+CONFIGURE_ARGS+=--disable-optimizations
+.endif
+
MAN6= heroes.6 heroeslvl.6
INFO= heroes
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib -lsmpeg ${PTHREAD_LIBS}
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102
-BROKEN= "Does not compile on alpha >=5.x"
+pre-everything::
+.ifndef(WITH_OPTIMIZED_CFLAGS)
+ @${ECHO_MSG} '>>>'
+ @${ECHO_MSG} '>>> You can enable extra optimizations by defining WITH_OPTIMIZED_CFLAGS'
+ @${ECHO_MSG} ">>> For example, 'make WITH_OPTIMIZED_CFLAGS=yes'"
+ @${ECHO_MSG} '>>>'
.endif
post-patch:
@@ -72,4 +80,4 @@ post-install:
${MKDIR} ${DATADIR}/mod
${INSTALL_DATA} ${MUSICSRC}/*.xm ${MUSICSRC}/sound.conf ${DATADIR}/mod
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>