aboutsummaryrefslogtreecommitdiff
path: root/games/icebreaker
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-03-08 14:14:49 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-03-08 14:14:49 +0000
commit68aa81b9bd50c5a5f8cca180fec5ed6f868a3666 (patch)
treee9ebed5e3d1c4e3734ed60bcd953360a9ab55c58 /games/icebreaker
parenta157fe7f746f21760360d8d83eb82a5ebb18ce08 (diff)
downloadports-68aa81b9bd50c5a5f8cca180fec5ed6f868a3666.tar.gz
ports-68aa81b9bd50c5a5f8cca180fec5ed6f868a3666.zip
- This is now fetchable again and
- respects CFLAGS and CC (self), therefor - bump PORTREVISION (self) PR: 94208 Submitted by: Ion-Mihai "IOnut" Tetcu <itetcu@people.tecnik93.com> Approved by: portmgr (erwin)
Notes
Notes: svn path=/head/; revision=157042
Diffstat (limited to 'games/icebreaker')
-rw-r--r--games/icebreaker/Makefile10
-rw-r--r--games/icebreaker/files/patch-aa30
-rw-r--r--games/icebreaker/pkg-plist16
3 files changed, 28 insertions, 28 deletions
diff --git a/games/icebreaker/Makefile b/games/icebreaker/Makefile
index 9968dc05044a..727aad9c3d71 100644
--- a/games/icebreaker/Makefile
+++ b/games/icebreaker/Makefile
@@ -7,23 +7,23 @@
PORTNAME= icebreaker
PORTVERSION= 1.2.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= games
-MASTER_SITES= http://www.mattdm.org/icebreaker/1.2.x/
+MASTER_SITES= http://mattdm.org/icebreaker/1.2.x/
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A game similar to Jezzball or Barrack
-
USE_SDL= mixer sdl
USE_GMAKE= yes
-MAKE_ENV= prefix="${PREFIX}" \
+MAKE_ENV+= prefix="${PREFIX}" \
highscoredir="${PREFIX}/share/icebreaker/scores" \
mandir="${PREFIX}/man" \
CHMOD="${CHMOD}" \
CHOWN="${CHOWN}" \
- MKDIR="${MKDIR}"
+ MKDIR="${MKDIR}" \
+ CC="${CC}"
MAN6= ${PORTNAME}.6
diff --git a/games/icebreaker/files/patch-aa b/games/icebreaker/files/patch-aa
index 4f011eec8abe..4c23262989f8 100644
--- a/games/icebreaker/files/patch-aa
+++ b/games/icebreaker/files/patch-aa
@@ -1,18 +1,15 @@
-
-$FreeBSD$
-
---- Makefile.orig Fri Jul 27 05:45:10 2001
-+++ Makefile Mon Jul 30 14:25:37 2001
-@@ -1,6 +1,7 @@
- CC=gcc
+--- Makefile.orig Wed Mar 8 15:04:42 2006
++++ Makefile Wed Mar 8 15:04:46 2006
+@@ -1,6 +1,6 @@
+-CC=gcc
-SDLCONFIG=sdl-config
+SDLCONFIG=$(SDL_CONFIG)
+CC?=gcc
ifndef prefix
- #prefix=/usr/local
-@@ -17,7 +18,7 @@
+ prefix=/usr/local
+@@ -21,16 +21,16 @@
endif
ifndef OPTIMIZE
@@ -20,8 +17,10 @@ $FreeBSD$
+ OPTIMIZE=
endif
- CFLAGS=-Wall $(OPTIMIZE) $(SDL_CFLAGS) -DDATAPREFIX=\"$(prefix)/share/icebreaker\" -DHISCOREPREFIX=\"$(highscoredir)\"
-@@ -26,7 +27,7 @@
+-CFLAGS=-Wall $(OPTIMIZE) $(SDL_CFLAGS) -DDATAPREFIX=\"$(datadir)/icebreaker\" -DHISCOREPREFIX=\"$(highscoredir)\"
++CFLAGS+=-Wall $(OPTIMIZE) $(SDL_CFLAGS) -DDATAPREFIX=\"$(datadir)/icebreaker\" -DHISCOREPREFIX=\"$(highscoredir)\"
+
+ SRC=icebreaker.c cursor.c grid.c laundry.c line.c penguin.c sound.c \
level.c intro.c text.c status.c transition.c hiscore.c dialog.c \
options.c fullscreen.c
@@ -30,7 +29,7 @@ $FreeBSD$
SDL_LIB=$(SDL_LDFLAGS) $(SDL_MIXER)
SDL_CFLAGS := $(shell $(SDLCONFIG) --cflags)
SDL_LDFLAGS := $(shell $(SDLCONFIG) --libs)
-@@ -100,17 +101,17 @@
+@@ -103,17 +103,17 @@
sed 's/\$$VERDATE/$(VERDATE)/' > $@
install: all
@@ -38,12 +37,13 @@ $FreeBSD$
- mkdir -p $(prefix)/share/icebreaker
- mkdir -p $(highscoredir)
- mkdir -p $(mandir)/man6
-+ $(MKDIR) $(prefix)/share/icebreaker
-+ $(MKDIR) $(highscoredir)
-
+-
- install -m 644 *.wav *.bmp $(prefix)/share/icebreaker
- install -g games -s -m 2755 icebreaker $(prefix)/bin
- install -m 644 icebreaker.6 $(mandir)/man6
++ $(MKDIR) $(prefix)/share/icebreaker
++ $(MKDIR) $(highscoredir)
++
+ $(BSD_INSTALL_DATA) *.wav *.bmp $(prefix)/share/icebreaker
+ $(BSD_INSTALL_PROGRAM) icebreaker $(prefix)/bin
+ $(BSD_INSTALL_MAN) icebreaker.6 $(mandir)/man6
diff --git a/games/icebreaker/pkg-plist b/games/icebreaker/pkg-plist
index e01925ca8511..ddca40fdd281 100644
--- a/games/icebreaker/pkg-plist
+++ b/games/icebreaker/pkg-plist
@@ -1,9 +1,9 @@
bin/icebreaker
-share/icebreaker/crash.wav
-share/icebreaker/icebreaker_48.bmp
-share/icebreaker/ouch.wav
-share/icebreaker/penguin.bmp
-share/icebreaker/penguinicon_32.bmp
-share/icebreaker/scores/icebreaker.scores
-@dirrm share/icebreaker/scores
-@dirrm share/icebreaker
+%%DATADIR%%/crash.wav
+%%DATADIR%%/icebreaker_48.bmp
+%%DATADIR%%/ouch.wav
+%%DATADIR%%/penguin.bmp
+%%DATADIR%%/penguinicon_32.bmp
+%%DATADIR%%/scores/icebreaker.scores
+@dirrm %%DATADIR%%/scores
+@dirrm %%DATADIR%%