aboutsummaryrefslogtreecommitdiff
path: root/games/imaze
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1996-11-26 08:42:23 +0000
committerSatoshi Asami <asami@FreeBSD.org>1996-11-26 08:42:23 +0000
commit416dd56f2937d8b0ff606dad85d4363dd64ff66c (patch)
treef9982775fe540d8b4095004a2e13afdb10e6908e /games/imaze
parentd50a37100a44a046c3fc18594d5beee1b6e2a281 (diff)
downloadports-416dd56f2937d8b0ff606dad85d4363dd64ff66c.tar.gz
ports-416dd56f2937d8b0ff606dad85d4363dd64ff66c.zip
Make this thing actually compile without Motif.
Notes
Notes: svn path=/head/; revision=4678
Diffstat (limited to 'games/imaze')
-rw-r--r--games/imaze/Makefile10
-rw-r--r--games/imaze/files/patch-aa2
2 files changed, 4 insertions, 8 deletions
diff --git a/games/imaze/Makefile b/games/imaze/Makefile
index 82615b0df617..3a96785f7567 100644
--- a/games/imaze/Makefile
+++ b/games/imaze/Makefile
@@ -14,21 +14,17 @@ DISTFILES= imaze1.3.tar.Z imaze.tar
MAINTAINER= kuehn@rz.tu-clausthal.de
-.if defined(HAVE_MOTIF) && defined(FORCE_MOTIF)
-.if !defined(MOTIFLIB)
-MOTIFLIB= -L${X11BASE}/lib -lXm
-.endif
-MAKE_ENV+= FORCE_MOTIF=${FORCE_MOTIF}
+.if defined(HAVE_MOTIF) && !defined(PACKAGE_BUILDING)
+MAKE_ENV+= FORCE_MOTIF=yes
.else
LIB_DEPENDS= xview\\.3\\.2:${PORTSDIR}/x11/xview-lib
.endif
EXTRACT_ONLY= imaze1.3.tar.Z
-NO_CONFIGURE= yes
USE_X11= yes
post-extract:
- @cp ${FILESDIR}/Makefile ${WRKDIR}/imaze/Makefile
+ @${CP} ${FILESDIR}/Makefile ${WRKDIR}/imaze/Makefile
@tar xf ${DISTDIR}/imaze.tar -C ${WRKDIR}/imaze
.include <bsd.port.mk>
diff --git a/games/imaze/files/patch-aa b/games/imaze/files/patch-aa
index 62a22fff91d7..4921671a2563 100644
--- a/games/imaze/files/patch-aa
+++ b/games/imaze/files/patch-aa
@@ -19,7 +19,7 @@
all
freebsd:
-+ .if defined(HAVE_MOTIF) && defined(FORCE_MOTIF)
++ .if defined(HAVE_MOTIF) && defined(FORCE_MOTIF) && ${FORCE_MOTIF} == "yes"
+ $(MAKE) \
+ GRAF=MOTIF \
+ GRAFLIBS='$$(MOTIFLIB) $$(MOTIFLIBS)' \