aboutsummaryrefslogtreecommitdiff
path: root/games/ioquake3
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-01-15 03:03:45 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-01-15 03:03:45 +0000
commitc212d657af6fef9399ba9f3a3a1e91ee730b7352 (patch)
tree5ed924427e7174197ad59fd7054ec3b5d52fc6fe /games/ioquake3
parentb50137ab85326afd769f2fecc2f1ffd18c9fc8bb (diff)
downloadports-c212d657af6fef9399ba9f3a3a1e91ee730b7352.tar.gz
ports-c212d657af6fef9399ba9f3a3a1e91ee730b7352.zip
games/ioquake3:
OPTIONS+= CURL "Enable cURL for http/ftp download" on \ OPENAL "Enable OpenAL audio output" on \ MUMBLE "Enable Mumble support (no dependencies)" on \ VORBIS "Enable Ogg Vorbis support" on games/ioquake3-devel: Update to r1771 PR: ports/142712 Submitted by: Dominic Fandrey <kamikaze@bsdforen.de> (maintainer)
Notes
Notes: svn path=/head/; revision=247909
Diffstat (limited to 'games/ioquake3')
-rw-r--r--games/ioquake3/Makefile30
-rw-r--r--games/ioquake3/pkg-descr12
2 files changed, 35 insertions, 7 deletions
diff --git a/games/ioquake3/Makefile b/games/ioquake3/Makefile
index 0c86a277433e..9ff06eadb05b 100644
--- a/games/ioquake3/Makefile
+++ b/games/ioquake3/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= ioquake3
DISTVERSION?= 1.36
+PORTREVISION?= 1
CATEGORIES= games
MASTER_SITES?= http://ioquake3.org/files/${DISTVERSION}/
@@ -20,16 +21,20 @@ USE_ZIP?= yes
.endif
USE_GMAKE= yes
-OPTIONS= CLIENT "Build client" on \
+OPTIONS+= CLIENT "Build client" on \
GAMELIBS "Build game libraries (when not mandatory)" off \
DEDICATED "Build dedicated server" on \
+ CURL "Enable cURL for http/ftp download" on \
+ OPENAL "Enable OpenAL audio output" on \
+ MUMBLE "Enable Mumble support (no dependencies)" on \
VORBIS "Enable Ogg Vorbis support" on
MAKE_ARGS+= DEFAULT_BASEDIR="${Q3DIR}" \
DEFAULT_LIBDIR="${LIBDIR}" \
HOMEPATH="/.${PORTNAME}" \
+ VERSION="${DISTVERSION}" \
ARCH="${ARCH}"
-PLIST_SUB= LIBDIR="${LIBDIR:S/${PREFIX}\///}" \
+PLIST_SUB+= LIBDIR="${LIBDIR:S/${PREFIX}\///}" \
ARCH="${ARCH}" \
BINSUFFIX="${BINSUFFIX}"
ALL_TARGET= release
@@ -45,7 +50,7 @@ ONLY_FOR_ARCHS= amd64 i386
MACHINE_ARCH= ${ARCH}
.include <bsd.cpu.mk>
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITHOUT_CLIENT) && defined(WITHOUT_DEDICATED) && \
defined(WITHOUT_SMP)
@@ -53,8 +58,19 @@ IGNORE= needs at least one of CLIENT, DEDICATED and SMP options
.endif
.if defined(WITH_CLIENT) || defined(WITH_SMP)
+# cURL
+.if defined(WITH_CURL)
+LIB_DEPENDS+= curl.5:${PORTSDIR}/ftp/curl
+#MAKE_ARGS+= USE_CURL_DLOPEN=0
+.else
+MAKE_ARGS+= USE_CURL=0
+.endif
# OpenAL
+.if defined(WITH_OPENAL)
LIB_DEPENDS+= openal.0:${PORTSDIR}/audio/openal
+.else
+MAKE_ARGS+= USE_OPENAL=0
+.endif
# SDL
USE_SDL= sdl
# Vorbis
@@ -62,6 +78,12 @@ USE_SDL= sdl
LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
MAKE_ARGS+= USE_CODEC_VORBIS=1
.endif
+# Mumble
+.if defined(WITH_MUMBLE)
+MAKE_ARGS+= USE_MUMBLE=1
+.else
+MAKE_ARGS+= USE_MUMBLE=0
+.endif
.endif
# SMP is only built with CLIENT.
@@ -119,4 +141,4 @@ post-install:
@${ECHO_CMD}
.include "${.CURDIR}/../quake3-data/Makefile.include"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/games/ioquake3/pkg-descr b/games/ioquake3/pkg-descr
index 1e21a579ceb5..d49d4c07954b 100644
--- a/games/ioquake3/pkg-descr
+++ b/games/ioquake3/pkg-descr
@@ -1,5 +1,11 @@
-This port creates development snapshots of icculus.org/quake3. The project is
-known to seldomly produce releases. Due to the conservative development goals
-of the project, development snapshots are generally considered reliable.
+This project, icculus.org/quake3 (sometimes referred to ioquake3, or ioq3 for
+short) aims to build upon id Software's Quake 3 source code release. The
+source code was released on August 20, 2005 under the GPL. Since then, we have
+been cleaning up, fixing bugs, and adding features. Our permanent goal is to
+create the open source Quake 3 distribution upon which people base their games
+and projects. We also seek to have the perfect version of the engine for
+playing Quake 3: Arena, Team Arena, and all popular mods. This distribution of
+the engine has been ported to many new platforms and has had a slew of new
+features added, along with massive bug extermination.
WWW: http://ioquake3.org/