aboutsummaryrefslogtreecommitdiff
path: root/games/iourbanterror
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-11-08 20:49:58 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-11-08 20:49:58 +0000
commit42afdbf81374ca551b328e017ca1c0a7abde5917 (patch)
treed17a58d1d2cd8d36769234c79f345332a48b8389 /games/iourbanterror
parent9b97d69d6b88bd5429edb6c583e9484c6ee82869 (diff)
downloadports-42afdbf81374ca551b328e017ca1c0a7abde5917.tar.gz
ports-42afdbf81374ca551b328e017ca1c0a7abde5917.zip
- Update to version 1.34-rc2.
- Use official SVN snapshot.
Notes
Notes: svn path=/head/; revision=176864
Diffstat (limited to 'games/iourbanterror')
-rw-r--r--games/iourbanterror/Makefile10
-rw-r--r--games/iourbanterror/distinfo6
-rw-r--r--games/iourbanterror/files/patch-Makefile84
3 files changed, 51 insertions, 49 deletions
diff --git a/games/iourbanterror/Makefile b/games/iourbanterror/Makefile
index fd80ee2aa988..aa39e6b6f1e4 100644
--- a/games/iourbanterror/Makefile
+++ b/games/iourbanterror/Makefile
@@ -6,19 +6,17 @@
#
PORTNAME= ioquake3
-PORTVERSION= 1.33.${SVN_REV}
-PORTREVISION= 1
+DISTVERSION= 1.34-rc2
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= alepulver
+MASTER_SITES= http://offload1.icculus.org/quake3/files/
+DISTNAME= ${PORTNAME}_${DISTVERSION}
MAINTAINER= alepulver@FreeBSD.org
COMMENT= Cleaned-up and enhaced version of Quake 3
USE_BZIP2= yes
-USE_GCC= 3.2+
+USE_GCC= 3.4+
USE_GMAKE= yes
-WRKSRC= ${WRKDIR}/quake3
OPTIONS= CLIENT "Build client" on \
GAMELIBS "Build game libraries (when not mandatory)" off \
diff --git a/games/iourbanterror/distinfo b/games/iourbanterror/distinfo
index 8b439d85f147..f185a9d1d1d1 100644
--- a/games/iourbanterror/distinfo
+++ b/games/iourbanterror/distinfo
@@ -1,3 +1,3 @@
-MD5 (ioquake3-1.33.797.tar.bz2) = 2bc968c6b73835657c7d2b4bf100c491
-SHA256 (ioquake3-1.33.797.tar.bz2) = 99cba27413bf5bc0b51f0ce4e55f51321ffe17ab5ca3bbd15837c85020c481c7
-SIZE (ioquake3-1.33.797.tar.bz2) = 2423661
+MD5 (ioquake3_1.34-rc2.tar.bz2) = 95b8e829e066bf81019f369bc9f0aae0
+SHA256 (ioquake3_1.34-rc2.tar.bz2) = 8990959e6f175669e4d9f338a176debc03456ddecd9f32319fea4b4831107552
+SIZE (ioquake3_1.34-rc2.tar.bz2) = 3126480
diff --git a/games/iourbanterror/files/patch-Makefile b/games/iourbanterror/files/patch-Makefile
index 44f7516d43b2..c939a5d95801 100644
--- a/games/iourbanterror/files/patch-Makefile
+++ b/games/iourbanterror/files/patch-Makefile
@@ -1,5 +1,5 @@
---- ./Makefile.orig Mon May 29 00:02:54 2006
-+++ ./Makefile Sun Jun 11 17:26:26 2006
+--- ./Makefile.orig Thu Oct 19 17:49:40 2006
++++ ./Makefile Sun Nov 5 19:55:44 2006
@@ -26,11 +26,19 @@
endif
endif
@@ -57,7 +57,7 @@
CDIR=$(MOUNT_DIR)/client
SDIR=$(MOUNT_DIR)/server
RDIR=$(MOUNT_DIR)/renderer
-@@ -407,18 +395,12 @@
+@@ -444,18 +432,12 @@
ifeq ($(PLATFORM),freebsd)
@@ -79,7 +79,7 @@
ifeq ($(USE_OPENAL),1)
BASE_CFLAGS += -DUSE_OPENAL=1
-@@ -431,46 +413,61 @@
+@@ -468,47 +450,61 @@
BASE_CFLAGS += -DUSE_CODEC_VORBIS=1
endif
@@ -105,15 +105,16 @@
- -march=pentium -fomit-frame-pointer -pipe -ffast-math \
- -falign-loops=2 -falign-jumps=2 -falign-functions=2 \
- -funroll-loops -fstrength-reduce
+- HAVE_VM_COMPILED=true
- else
- BASE_CFLAGS += -DNO_VM_COMPILED
+ ifeq ($(USE_SDL_AUDIO),1)
+ BASE_CFLAGS += -DUSE_SDL_SOUND=1
-+ endif
+ endif
+
+ ifeq ($(USE_SDL_VIDEO),1)
+ BASE_CFLAGS += -DUSE_SDL_VIDEO=1
- endif
++ endif
+
+ ifeq ($(USE_OPTIMIZED_CFLAGS),1)
+ RELEASE_CFLAGS+=-O3 -ffast-math -funroll-loops -fomit-frame-pointer \
@@ -163,7 +164,7 @@
endif
endif
-@@ -478,7 +475,6 @@
+@@ -516,7 +512,6 @@
CLIENT_LDFLAGS += -lvorbisfile -lvorbis -logg
endif
@@ -171,7 +172,7 @@
else # ifeq freebsd
#############################################################################
-@@ -632,24 +628,24 @@
+@@ -670,24 +665,24 @@
TARGETS =
ifneq ($(BUILD_SERVER),0)
@@ -205,7 +206,7 @@
endif
ifneq ($(BUILD_GAME_QVM),0)
-@@ -707,11 +703,11 @@
+@@ -749,11 +744,11 @@
$(MAKE) targets B=$(BD) CFLAGS="$(CFLAGS) $(DEBUG_CFLAGS) $(DEPEND_CFLAGS)"
build_release: B=$(BR)
@@ -219,21 +220,23 @@
targets: $(TARGETS)
-@@ -919,11 +915,11 @@
- $(B)/client/ftola.o \
- $(B)/client/snapvectora.o
- endif
--ifeq ($(ARCH),x86_64)
-+ifeq ($(ARCH),amd64)
- Q3OBJ += $(B)/client/vm_x86_64.o
- endif
-
--ifeq ($(ARCH),ppc)
-+ifeq ($(ARCH),powerpc)
- ifneq ($(VM_PPC),)
+@@ -964,13 +959,10 @@
+ ifeq ($(ARCH),i386)
+ Q3OBJ += $(B)/client/vm_x86.o
+ endif
+- ifeq ($(ARCH),x86)
+- Q3OBJ += $(B)/client/vm_x86.o
+- endif
+- ifeq ($(ARCH),x86_64)
++ ifeq ($(ARCH),amd64)
+ Q3OBJ += $(B)/client/vm_x86_64.o
+ endif
+- ifeq ($(ARCH),ppc)
++ ifeq ($(ARCH),powerpc)
Q3OBJ += $(B)/client/$(VM_PPC).o
endif
-@@ -971,10 +967,10 @@
+ endif
+@@ -1017,10 +1009,10 @@
$(B)/client/sdl_glimp_smp.o
endif
@@ -246,18 +249,19 @@
$(CC) -o $@ $(Q3OBJ) $(Q3POBJ_SMP) $(CLIENT_LDFLAGS) \
$(THREAD_LDFLAGS) $(LDFLAGS) $(LIBSDLMAIN)
-@@ -1253,17 +1249,17 @@
- $(B)/ded/snapvectora.o $(B)/ded/matha.o
- endif
-
--ifeq ($(ARCH),x86_64)
-+ifeq ($(ARCH),amd64)
- Q3DOBJ += $(B)/ded/vm_x86_64.o
- endif
-
--ifeq ($(ARCH),ppc)
-+ifeq ($(ARCH),powerpc)
- ifneq ($(VM_PPC),)
+@@ -1317,18 +1309,15 @@
+ ifeq ($(ARCH),i386)
+ Q3DOBJ += $(B)/ded/vm_x86.o
+ endif
+- ifeq ($(ARCH),x86)
+- Q3DOBJ += $(B)/ded/vm_x86.o
+- endif
+- ifeq ($(ARCH),x86_64)
++ ifeq ($(ARCH),amd64)
+ Q3DOBJ += $(B)/ded/vm_x86_64.o
+ endif
+- ifeq ($(ARCH),ppc)
++ ifeq ($(ARCH),powerpc)
Q3DOBJ += $(B)/ded/$(VM_PPC).o
endif
endif
@@ -267,7 +271,7 @@
$(CC) -o $@ $(Q3DOBJ) $(LDFLAGS)
$(B)/ded/sv_bot.o : $(SDIR)/sv_bot.c; $(DO_DED_CC)
-@@ -1377,7 +1373,7 @@
+@@ -1445,7 +1434,7 @@
Q3CGOBJ = $(Q3CGOBJ_) $(B)/baseq3/cgame/cg_syscalls.o
Q3CGVMOBJ = $(Q3CGOBJ_:%.o=%.asm) $(B)/baseq3/game/bg_lib.asm
@@ -276,7 +280,7 @@
$(CC) $(SHLIBLDFLAGS) -o $@ $(Q3CGOBJ)
$(B)/baseq3/vm/cgame.qvm: $(Q3CGVMOBJ) $(CGDIR)/cg_syscalls.asm
-@@ -1418,7 +1414,7 @@
+@@ -1486,7 +1475,7 @@
MPCGOBJ = $(MPCGOBJ_) $(B)/missionpack/cgame/cg_syscalls.o
MPCGVMOBJ = $(MPCGOBJ_:%.o=%.asm) $(B)/missionpack/game/bg_lib.asm
@@ -285,7 +289,7 @@
$(CC) $(SHLIBLDFLAGS) -o $@ $(MPCGOBJ)
$(B)/missionpack/vm/cgame.qvm: $(MPCGVMOBJ) $(CGDIR)/cg_syscalls.asm
-@@ -1468,7 +1464,7 @@
+@@ -1536,7 +1525,7 @@
Q3GOBJ = $(Q3GOBJ_) $(B)/baseq3/game/g_syscalls.o
Q3GVMOBJ = $(Q3GOBJ_:%.o=%.asm) $(B)/baseq3/game/bg_lib.asm
@@ -294,7 +298,7 @@
$(CC) $(SHLIBLDFLAGS) -o $@ $(Q3GOBJ)
$(B)/baseq3/vm/qagame.qvm: $(Q3GVMOBJ) $(GDIR)/g_syscalls.asm
-@@ -1516,7 +1512,7 @@
+@@ -1584,7 +1573,7 @@
MPGOBJ = $(MPGOBJ_) $(B)/missionpack/game/g_syscalls.o
MPGVMOBJ = $(MPGOBJ_:%.o=%.asm) $(B)/missionpack/game/bg_lib.asm
@@ -303,7 +307,7 @@
$(CC) $(SHLIBLDFLAGS) -o $@ $(MPGOBJ)
$(B)/missionpack/vm/qagame.qvm: $(MPGVMOBJ) $(GDIR)/g_syscalls.asm
-@@ -1576,7 +1572,7 @@
+@@ -1644,7 +1633,7 @@
Q3UIOBJ = $(Q3UIOBJ_) $(B)/missionpack/ui/ui_syscalls.o
Q3UIVMOBJ = $(Q3UIOBJ_:%.o=%.asm) $(B)/baseq3/game/bg_lib.asm
@@ -312,7 +316,7 @@
$(CC) $(CFLAGS) $(SHLIBLDFLAGS) -o $@ $(Q3UIOBJ)
$(B)/baseq3/vm/ui.qvm: $(Q3UIVMOBJ) $(UIDIR)/ui_syscalls.asm
-@@ -1601,7 +1597,7 @@
+@@ -1669,7 +1658,7 @@
MPUIOBJ = $(MPUIOBJ_) $(B)/missionpack/ui/ui_syscalls.o
MPUIVMOBJ = $(MPUIOBJ_:%.o=%.asm) $(B)/baseq3/game/bg_lib.asm