aboutsummaryrefslogtreecommitdiff
path: root/games/jetpack
diff options
context:
space:
mode:
authorJordan K. Hubbard <jkh@FreeBSD.org>1994-09-23 00:38:42 +0000
committerJordan K. Hubbard <jkh@FreeBSD.org>1994-09-23 00:38:42 +0000
commitb8f7195a5243a79a47d728734e7adfae459a2ce2 (patch)
treeef724aa28c7648e1c4464dd598fe8350473ede72 /games/jetpack
parent2ba7ab8b215c7b72a37e3def15fc2ca08a5e6aa6 (diff)
downloadports-b8f7195a5243a79a47d728734e7adfae459a2ce2.tar.gz
ports-b8f7195a5243a79a47d728734e7adfae459a2ce2.zip
Latest changes from Jean-Marc
Submitted by: Jean-Marc Zucconi
Notes
Notes: svn path=/head/; revision=112
Diffstat (limited to 'games/jetpack')
-rw-r--r--games/jetpack/files/patch-ac73
-rw-r--r--games/jetpack/files/patch-ae9
-rw-r--r--games/jetpack/pkg-plist2
3 files changed, 54 insertions, 30 deletions
diff --git a/games/jetpack/files/patch-ac b/games/jetpack/files/patch-ac
index 446b23711a8e..b8fd5e9bc2c4 100644
--- a/games/jetpack/files/patch-ac
+++ b/games/jetpack/files/patch-ac
@@ -1,9 +1,15 @@
*** Imakefile.orig Mon Nov 8 15:16:05 1993
---- Imakefile Wed Sep 21 00:55:52 1994
+--- Imakefile Thu Sep 22 16:30:18 1994
***************
-*** 7,22 ****
+*** 1,44 ****
+! SRCS = bitmap.c bonus.c collision.c demo.c draw.c erase.c events.c\
+ gameover.c initx.c main.c maze.c message.c normal.c quitx.c scores.c\
+ setinmaze.c setup.c special.c time.c update.c windowx.c
+! OBJS = bitmap.o bonus.o collision.o demo.o draw.o erase.o events.o\
+ gameover.o initx.o main.o maze.o message.o normal.o quitx.o scores.o\
+ setinmaze.o setup.o special.o time.o update.o windowx.o
- PROGRAMS = jetpack
+! PROGRAMS = jetpack
! DESTDIR = /usrd/s/m/meb2
@@ -15,28 +21,16 @@
! MANDIR = $(MANSOURCEPATH)1
! TOP_INCLUDES =
! DEPXLIB =
- EXTRA_LIBRARIES = $(XLIB)
+! EXTRA_LIBRARIES = $(XLIB)
# I like my programs optimized, stripped, and setuid. Do what you like.
---- 7,22 ----
+! INSTPGMFLAGS = $(INSTUIDFLAGS) -s
+! CDEBUGFLAGS = -O4
- PROGRAMS = jetpack
+ # Since my programs are setuid, I make the data files readable only by me.
+! INSTDATFLAGS = -m 0600
-! BINDIR = /usr/local/bin
-! LIBDIR = /usr/local/lib/jetpack
-! MANDIR = /usr/local/man/man6
-
- # These defines override the template defaults. Trash em if you want to
- # use the template locations
-! # LIBDIR = $(DESTDIR)/lib/jetpack
-! # BINDIR = $(DESTDIR)/bin
-! # MANPATH = $(DESTDIR)/man
-! # MANDIR = $(MANSOURCEPATH)1
- EXTRA_LIBRARIES = $(XLIB)
-
- # I like my programs optimized, stripped, and setuid. Do what you like.
-***************
-*** 30,44 ****
+ # These defines are needed by jetpack. Delete the -DBLIT if you don't want
# the game to do all the drawing to an offscreen pixmap. (This is good for
# machines that don't have hardware blitting -- if you have an xterm or a
# graphics workhorse, leave it in, there will be no flicker)
@@ -52,20 +46,49 @@
ComplexProgramTarget(jetpack)
---- 30,45 ----
+--- 1,45 ----
+! SRCS = bitmap.c bonus.c collision.c demo.c draw.c erase.c events.c\
+ gameover.c initx.c main.c maze.c message.c normal.c quitx.c scores.c\
+ setinmaze.c setup.c special.c time.c update.c windowx.c
+! OBJS = bitmap.o bonus.o collision.o demo.o draw.o erase.o events.o\
+ gameover.o initx.o main.o maze.o message.o normal.o quitx.o scores.o\
+ setinmaze.o setup.o special.o time.o update.o windowx.o
+
+! PROGRAMS = jetpack
+
+! BINDIR = /usr/local/bin
+! LIBDIR = /usr/local/lib/jetpack
+! MANDIR = /usr/local/man/man6
+
+ # These defines override the template defaults. Trash em if you want to
+ # use the template locations
+! # LIBDIR = $(DESTDIR)/lib/jetpack
+! # BINDIR = $(DESTDIR)/bin
+! # MANPATH = $(DESTDIR)/man
+! # MANDIR = $(MANSOURCEPATH)1
+! EXTRA_LIBRARIES = $(XLIB)
+
+ # I like my programs optimized, stripped, and setuid. Do what you like.
+! INSTPGMFLAGS = $(INSTUIDFLAGS) -s
+! CDEBUGFLAGS = -O4
+
+ # Since my programs are setuid, I make the data files readable only by me.
+! INSTDATFLAGS = -m 0600
+
+ # These defines are needed by jetpack. Delete the -DBLIT if you don't want
# the game to do all the drawing to an offscreen pixmap. (This is good for
# machines that don't have hardware blitting -- if you have an xterm or a
# graphics workhorse, leave it in, there will be no flicker)
! # DEFINES = -DBLIT -DSCOREPATH=\"$(SCOREFILE)\" -DLEVELPATH=\"$(LEVELFILE)\"
-! DEFINES = -DSCOREPATH=\"$(SCOREFILE)\" -DLEVELPATH=\"$(LEVELFILE)\"
+! DEFINES = -DSCOREPATH=\"$(SCOREFILE)\" -DLEVELPATH=\"$(LEVELFILE)\"
# The score file can be any name you like, just make sure the directory
# it's supposed to reside in exists, or jetpack will start creating score
# files in the directories it is run from. Same for the level files, only
# the filename you give here is only a prefix -- the complete filename has
# the level number appended to it.
-! SCOREFILE = $(LIBDIR)/jetpack.scores
-! LEVELFILE = $(LIBDIR)/jetpack.lev
+! SCOREFILE = $(LIBDIR)/jetpack.scores
+! LEVELFILE = $(LIBDIR)/jetpack.lev
ComplexProgramTarget(jetpack)
diff --git a/games/jetpack/files/patch-ae b/games/jetpack/files/patch-ae
index d0668ab98c94..9d8c69d61a53 100644
--- a/games/jetpack/files/patch-ae
+++ b/games/jetpack/files/patch-ae
@@ -1,10 +1,11 @@
-*** main.c.orig Wed Sep 21 00:33:35 1994
---- main.c Wed Sep 21 00:35:35 1994
+*** main.c.orig Mon Apr 6 12:59:32 1992
+--- main.c Thu Sep 22 13:07:12 1994
***************
*** 1,5 ****
---- 1,8 ----
+--- 1,9 ----
/* main.c : main loop of jetpack
*/
++ #include <sys/types.h>
+ #include <sys/time.h>
+ #include <sys/resource.h>
+
@@ -13,7 +14,7 @@
#include "defs.h"
***************
*** 18,23 ****
---- 21,29 ----
+--- 22,30 ----
int seed;
char lev[20];
register unsigned long timer;
diff --git a/games/jetpack/pkg-plist b/games/jetpack/pkg-plist
index 2a877d23d00d..17ad7e9aefb6 100644
--- a/games/jetpack/pkg-plist
+++ b/games/jetpack/pkg-plist
@@ -1,5 +1,5 @@
@cd /usr/local
-@mode u+rw,a+r
+@mode 644
man/man6/jetpack.6
lib/jetpack/jetpack.lev000
@owner bin