aboutsummaryrefslogtreecommitdiff
path: root/games/jools/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2003-06-06 22:49:57 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2003-06-06 22:49:57 +0000
commit8647ee60c95fad8f55e0422c4c946b24c95d2288 (patch)
tree18c5487df8a95bc964676ccb5651542f551b1b90 /games/jools/Makefile
parent041f2cf930baa771f4a68a42b2a9342df20f3317 (diff)
downloadports-8647ee60c95fad8f55e0422c4c946b24c95d2288.tar.gz
ports-8647ee60c95fad8f55e0422c4c946b24c95d2288.zip
Add jools-0.10, a Bejeweled clone.
jools is a clone of that Pop Cap Games game where you swap adjacent jewels. This game is horribly addictive, and I guess that makes me the enabler. Or the pusher.
Notes
Notes: svn path=/head/; revision=82404
Diffstat (limited to 'games/jools/Makefile')
-rw-r--r--games/jools/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/games/jools/Makefile b/games/jools/Makefile
new file mode 100644
index 000000000000..37ca002b1d48
--- /dev/null
+++ b/games/jools/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: jools
+# Date created: 6 June 2003
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= jools
+PORTVERSION= 0.10
+CATEGORIES= games
+MASTER_SITES= http://www.eecs.umich.edu/~pelzlpj/jools/
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Addictive jewel-swapping puzzle game
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygame/__init__.py:${PORTSDIR}/devel/py-game
+
+USE_PYTHON= yes
+
+do-build:
+ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+
+do-install:
+ cd ${WRKSRC} && ${PYTHON_CMD} ${WRKSRC}/setup.py install --prefix=${PREFIX}
+
+.include <bsd.port.mk>