aboutsummaryrefslogtreecommitdiff
path: root/games/kobodeluxe
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-10-01 04:52:01 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-10-01 04:52:01 +0000
commit0b0abef4ba660973a21493c08fbce5f5b6703f2c (patch)
tree3fe609850d879ae490998e658562da363c82ca3d /games/kobodeluxe
parent6e7f3b8432f06a1b161ce9840956b509e9dd3d5b (diff)
downloadports-0b0abef4ba660973a21493c08fbce5f5b6703f2c.tar.gz
ports-0b0abef4ba660973a21493c08fbce5f5b6703f2c.zip
- Make kobodeluxe compile with gcc41.
- Take maintainership. PR: ports/103857 Submitted by: Dmitry Marakasov <amdmi3@mail.ru>
Notes
Notes: svn path=/head/; revision=174221
Diffstat (limited to 'games/kobodeluxe')
-rw-r--r--games/kobodeluxe/Makefile2
-rw-r--r--games/kobodeluxe/files/patch-gamestate.h11
2 files changed, 12 insertions, 1 deletions
diff --git a/games/kobodeluxe/Makefile b/games/kobodeluxe/Makefile
index 46cccd994b80..5e2289a06d0c 100644
--- a/games/kobodeluxe/Makefile
+++ b/games/kobodeluxe/Makefile
@@ -11,7 +11,7 @@ CATEGORIES= games
MASTER_SITES= http://olofson.net/kobodl/download/
DISTNAME= KoboDeluxe-${DISTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= amdmi3@mail.ru
COMMENT= An SDL port of the scrolling game XKobo
USE_SDL= image sdl
diff --git a/games/kobodeluxe/files/patch-gamestate.h b/games/kobodeluxe/files/patch-gamestate.h
new file mode 100644
index 000000000000..37957db29d2a
--- /dev/null
+++ b/games/kobodeluxe/files/patch-gamestate.h
@@ -0,0 +1,11 @@
+--- gamestate.h.orig Sun Apr 28 05:48:59 2002
++++ gamestate.h Sat Sep 30 23:58:17 2006
+@@ -24,6 +24,8 @@
+
+ #include "window.h"
+
++class gamestatemanager_t;
++
+ class gamestate_t
+ {
+ friend class gamestatemanager_t;