aboutsummaryrefslogtreecommitdiff
path: root/games/ladder/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1999-02-03 11:12:01 +0000
committerSatoshi Asami <asami@FreeBSD.org>1999-02-03 11:12:01 +0000
commit5114e2637e2224ea9b0e0ea4b315bc38370ccf04 (patch)
tree414dd9b31f0192eb7d0054b2463c2eed8afd25b4 /games/ladder/Makefile
parentfd5131ad95770d2ae6bee7059204950dfa6402d1 (diff)
downloadports-5114e2637e2224ea9b0e0ea4b315bc38370ccf04.tar.gz
ports-5114e2637e2224ea9b0e0ea4b315bc38370ccf04.zip
Adjust port Makefiles to new EXTRACT_* variable defaults. See log of
bsd.port.mk rev. 1.304 for details on the change. The fix here is one of the following. (1) Define USE_BZIP2 instead of BUILD_DEPENDS on bzip2 and redefining EXTRACT_* commands. (2) Change ${EXTRACT_CMD} to ${TAR} when the command is obviously calling the "tar" command (i.e., arguments like "-xzf" are spelled out). (3) If ${EXTRACT_CMD} is called directly with ${EXTRACT_BEFORE_ARGS}, add ${EXTRACT_AFTER_ARGS} to the command line as well. (4) If any of EXTRACT_CMD, EXTRACT_BEFORE_ARGS or EXTRACT_AFTER_ARGS is set, define the other two too.
Notes
Notes: svn path=/head/; revision=16518
Diffstat (limited to 'games/ladder/Makefile')
-rw-r--r--games/ladder/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/games/ladder/Makefile b/games/ladder/Makefile
index c4a7ee501286..a1a8696d77a7 100644
--- a/games/ladder/Makefile
+++ b/games/ladder/Makefile
@@ -3,7 +3,7 @@
# Date created: 18 Feb 1998
# Whom: Stefan Zehl <sec@42.org>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1998/02/20 05:46:59 steve Exp $
#
DISTNAME= ladder
@@ -18,6 +18,8 @@ MAINTAINER= sec@42.org
RESTRICTED= "possible copyright problems ?"
NO_WRKSUBDIR= true
-EXTRACT_BEFORE_ARGS=-xf
+EXTRACT_CMD= ${TAR}
+EXTRACT_BEFORE_ARGS= -xf
+EXTRACT_AFTER_ARGS= # empty
.include <bsd.port.mk>