aboutsummaryrefslogtreecommitdiff
path: root/games/lbreakout
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-10-20 07:32:38 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-10-20 07:32:38 +0000
commit0050bccb4541dda8deed41e2ab4966ad77451bab (patch)
tree424ea624b05a7d892961577855a453e242e9cf67 /games/lbreakout
parentc6fb1210fa15062ede807a81af7f6cb4fef8bd11 (diff)
downloadports-0050bccb4541dda8deed41e2ab4966ad77451bab.tar.gz
ports-0050bccb4541dda8deed41e2ab4966ad77451bab.zip
Add lbreakout - a SDL-based clone of classical Breakout game.
Notes
Notes: svn path=/head/; revision=34013
Diffstat (limited to 'games/lbreakout')
-rw-r--r--games/lbreakout/Makefile38
-rw-r--r--games/lbreakout/distinfo1
-rw-r--r--games/lbreakout/files/patch-aa11
-rw-r--r--games/lbreakout/files/patch-ab10
-rw-r--r--games/lbreakout/files/patch-ac21
-rw-r--r--games/lbreakout/files/patch-ad11
-rw-r--r--games/lbreakout/files/patch-ae13
-rw-r--r--games/lbreakout/pkg-comment1
-rw-r--r--games/lbreakout/pkg-descr21
-rw-r--r--games/lbreakout/pkg-plist47
10 files changed, 174 insertions, 0 deletions
diff --git a/games/lbreakout/Makefile b/games/lbreakout/Makefile
new file mode 100644
index 000000000000..230b595dee16
--- /dev/null
+++ b/games/lbreakout/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: lbreakout
+# Date created: 19 October 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lbreakout
+PORTVERSION= 001018
+CATEGORIES= games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= lgames
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= SDL-1.0.2:${PORTSDIR}/devel/sdl
+
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl-config
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBS="-lcompat"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+ @find ${WRKSRC} \( -name "*.[ch]" -or -name "*.cpp" \) | \
+ xargs ${PERL} -pi -e 's|"SDL/SDL|"SDL|g ; s|<SDL/SDL|<SDL|g'
+
+pre-install:
+ ${MKDIR} /var/games/${PORTNAME}
+
+post-install:
+ ${CHOWN} root:games ${PREFIX}/bin/${PORTNAME}
+ ${CHMOD} 2755 ${PREFIX}/bin/${PORTNAME}
+ ${CHMOD} 664 /var/games/${PORTNAME}/${PORTNAME}.hscr
+ ${CHOWN} root:games /var/games/${PORTNAME}/${PORTNAME}.hscr
+
+.include <bsd.port.mk>
diff --git a/games/lbreakout/distinfo b/games/lbreakout/distinfo
new file mode 100644
index 000000000000..db2ca998350b
--- /dev/null
+++ b/games/lbreakout/distinfo
@@ -0,0 +1 @@
+MD5 (lbreakout-001018.tar.gz) = 64cfdae38846205ba0cebfef7ecf7280
diff --git a/games/lbreakout/files/patch-aa b/games/lbreakout/files/patch-aa
new file mode 100644
index 000000000000..3d8896c5d48c
--- /dev/null
+++ b/games/lbreakout/files/patch-aa
@@ -0,0 +1,11 @@
+--- lbreakout/Makefile.in 2000/10/20 06:56:24 1.1
++++ lbreakout/Makefile.in 2000/10/20 06:56:47
+@@ -80,7 +80,7 @@
+
+ bin_PROGRAMS = lbreakout
+ lbreakout_SOURCES = hiscore.cpp dynlist.c level.cpp breakout.cpp sndsrv.c sdl.c menumanager.cpp menuitem.cpp menu.cpp game.cpp main.cpp
+-lbreakout_LDADD = -lpthread -lm @thread_flag@
++lbreakout_LDADD = @thread_flag@
+
+ EXTRA_SUBDIRS = manual
+
diff --git a/games/lbreakout/files/patch-ab b/games/lbreakout/files/patch-ab
new file mode 100644
index 000000000000..341e2de5b7ee
--- /dev/null
+++ b/games/lbreakout/files/patch-ab
@@ -0,0 +1,10 @@
+--- lbreakout/breakout.cpp 2000/10/20 07:01:37 1.1
++++ lbreakout/breakout.cpp 2000/10/20 07:02:11
+@@ -19,6 +19,7 @@
+ #include "level.h"
+ #include <stdlib.h>
+ #include <stdio.h>
++#include <sys/types.h>
+ #include <sys/timeb.h>
+ #include <string.h>
+ #include <math.h>
diff --git a/games/lbreakout/files/patch-ac b/games/lbreakout/files/patch-ac
new file mode 100644
index 000000000000..b542dcbc6a1e
--- /dev/null
+++ b/games/lbreakout/files/patch-ac
@@ -0,0 +1,21 @@
+--- lbreakout/game.cpp 2000/10/20 07:02:55 1.1
++++ lbreakout/game.cpp 2000/10/20 07:03:35
+@@ -15,6 +15,7 @@
+ * *
+ ***************************************************************************/
+
++#include <sys/types.h>
+ #include <sys/timeb.h>
+ #include <stdlib.h>
+ #include <string.h>
+@@ -22,6 +23,10 @@
+ #include "breakout.h"
+ #include "menumanager.h"
+ #include "level.h"
++
++extern "C" {
++ int ftime(struct timeb *tp);
++};
+
+ #ifdef SOUND
+ extern SndSrv sndsrv;
diff --git a/games/lbreakout/files/patch-ad b/games/lbreakout/files/patch-ad
new file mode 100644
index 000000000000..a44be7a66e34
--- /dev/null
+++ b/games/lbreakout/files/patch-ad
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Wed Oct 18 17:27:21 2000
++++ Makefile.in Fri Oct 20 09:57:40 2000
+@@ -46,7 +46,7 @@
+ ACLOCAL = @ACLOCAL@
+ AUTOCONF = @AUTOCONF@
+ AUTOMAKE = @AUTOMAKE@
+-AUTOHEADER = @AUTOHEADER@
++AUTOHEADER = true
+
+ INSTALL = @INSTALL@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@ $(AM_INSTALL_PROGRAM_FLAGS)
diff --git a/games/lbreakout/files/patch-ae b/games/lbreakout/files/patch-ae
new file mode 100644
index 000000000000..a7a54c9c45ce
--- /dev/null
+++ b/games/lbreakout/files/patch-ae
@@ -0,0 +1,13 @@
+--- configure 2000/10/20 06:57:57 1.1
++++ configure 2000/10/20 06:58:16
+@@ -1783,8 +1783,8 @@
+
+
+
+-sdir=$datadir/games/lbreakout
+-hdir=/var/lib/games
++sdir=$datadir/lbreakout
++hdir=/var/games/lbreakout
+ inst_flag="-DSRC_DIR=\\\"$sdir/\\\""
+ hi_inst_flag="-DHI_DIR=\\\"$hdir/\\\""
+
diff --git a/games/lbreakout/pkg-comment b/games/lbreakout/pkg-comment
new file mode 100644
index 000000000000..f14a901ff2f5
--- /dev/null
+++ b/games/lbreakout/pkg-comment
@@ -0,0 +1 @@
+A nice clone of classical Breakout game
diff --git a/games/lbreakout/pkg-descr b/games/lbreakout/pkg-descr
new file mode 100644
index 000000000000..b41e01227f6b
--- /dev/null
+++ b/games/lbreakout/pkg-descr
@@ -0,0 +1,21 @@
+LBreakout is a classical Breakout game and this means (if you like Breakout ;-)
+it is a lot of fun to play! If you never ever played such a game you can check
+out the manual for more information and last but not least... play it!
+
+This is a list of LBreakout's features:
+
+ Sound
+ HighScore
+ A menu with mouse support
+ Mouse or keyboard can be used for playing
+ Controls can be redefined
+ Mouse can be kept in window while playing
+ Your starting level can be chosen
+ A difficulty can be selected (easy, medium, hard)
+ Various backgrounds
+ A lot of collectable extras
+ Nice graphics
+ Cool effects
+ Own levels can be created
+
+WWW: http://lgames.sourceforge.net/lbreakout/lbreakout.html
diff --git a/games/lbreakout/pkg-plist b/games/lbreakout/pkg-plist
new file mode 100644
index 000000000000..f78b699e1fe8
--- /dev/null
+++ b/games/lbreakout/pkg-plist
@@ -0,0 +1,47 @@
+bin/lbreakout
+share/lbreakout/ball.bmp
+share/lbreakout/bkgnd0.bmp
+share/lbreakout/bkgnd1.bmp
+share/lbreakout/bkgnd2.bmp
+share/lbreakout/bricks.bmp
+share/lbreakout/click.wav
+share/lbreakout/club.bmp
+share/lbreakout/damn.wav
+share/lbreakout/damnit.wav
+share/lbreakout/excellent.wav
+share/lbreakout/exp.wav
+share/lbreakout/expand.wav
+share/lbreakout/extras.bmp
+share/lbreakout/f_white.bmp
+share/lbreakout/f_yellow.bmp
+share/lbreakout/font_s.sdlfnt
+share/lbreakout/fr_l.bmp
+share/lbreakout/fr_luc.bmp
+share/lbreakout/fr_r.bmp
+share/lbreakout/fr_rlc.bmp
+share/lbreakout/fr_ruc.bmp
+share/lbreakout/fr_t.bmp
+share/lbreakout/freeze.wav
+share/lbreakout/gainlife.wav
+share/lbreakout/life.bmp
+share/lbreakout/logo.bmp
+share/lbreakout/looselife.wav
+share/lbreakout/metal.wav
+share/lbreakout/numbers.bmp
+share/lbreakout/reflect.wav
+share/lbreakout/score.wav
+share/lbreakout/shine2.bmp
+share/lbreakout/shot.bmp
+share/lbreakout/shot.wav
+share/lbreakout/shrink.wav
+share/lbreakout/slime.wav
+share/lbreakout/title.bmp
+share/lbreakout/verygood.wav
+share/lbreakout/wall.wav
+share/lbreakout/weapon.bmp
+share/lbreakout/weapon.wav
+share/lbreakout/wontgiveup.wav
+@dirrm share/lbreakout
+@cwd /var/games
+lbreakout/lbreakout.hscr
+@dirrm lbreakout